Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование столбца - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Суммирование столбца (Макросы/Sub)
Суммирование столбца
VIDEO56 Дата: Пятница, 08.04.2016, 09:15 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
Всем доброго дня и удачной пятницы.
Понимаю, что данная тема тут не однократно обсуждалась, однако решения на свой файл применить не могу. Есть таблица которая ежедневно заполняется, нужно, чтобы числа из столбца D суммировались накопительно в ячейку D1, из F в F1 и т.д. по столбцам где есть числа. Желательно, чтобы код был не в коде листа, а как отдельный модуль.
Зараенее спасибо!
К сообщению приложен файл: 0206961.xlsm(12Kb)


Всем удачного дня!

Сообщение отредактировал VIDEO56 - Пятница, 08.04.2016, 09:33
 
Ответить
СообщениеВсем доброго дня и удачной пятницы.
Понимаю, что данная тема тут не однократно обсуждалась, однако решения на свой файл применить не могу. Есть таблица которая ежедневно заполняется, нужно, чтобы числа из столбца D суммировались накопительно в ячейку D1, из F в F1 и т.д. по столбцам где есть числа. Желательно, чтобы код был не в коде листа, а как отдельный модуль.
Зараенее спасибо!

Автор - VIDEO56
Дата добавления - 08.04.2016 в 09:15
_Boroda_ Дата: Пятница, 08.04.2016, 09:21 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А просто
Код
=СУММ(D2:D999999)
прописать не подходит?
И что Вы имели в виду
чтобы код был не в коде листа, а как отдельный модуль


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА просто
Код
=СУММ(D2:D999999)
прописать не подходит?
И что Вы имели в виду
чтобы код был не в коде листа, а как отдельный модуль

Автор - _Boroda_
Дата добавления - 08.04.2016 в 09:21
VIDEO56 Дата: Пятница, 08.04.2016, 09:23 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
Александр, нужен не Private Sub.
[moder]А что? Кнопка? Функция пользователя (тогда почему не СУММ)?


Всем удачного дня!
 
Ответить
СообщениеАлександр, нужен не Private Sub.
[moder]А что? Кнопка? Функция пользователя (тогда почему не СУММ)?

Автор - VIDEO56
Дата добавления - 08.04.2016 в 09:23
VIDEO56 Дата: Пятница, 08.04.2016, 09:26 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
ДАААА!!!


Всем удачного дня!
 
Ответить
СообщениеДАААА!!!

Автор - VIDEO56
Дата добавления - 08.04.2016 в 09:26
devilkurs Дата: Пятница, 08.04.2016, 09:32 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 140
Репутация: 37 ±
Замечаний: 0% ±

Excel 2007, 2010
Так а чем Вас не устраивает формула?
Код
=СУММ(СМЕЩ(R[2]C;;;СЧЁТЗ(R[2]C:R[500]C)))

[moder]Где теги?
[offtop]Прошу прощения. Скрипты не работают на работе. А теги наизусть не знаю




Сообщение отредактировал devilkurs - Пятница, 08.04.2016, 09:36
 
Ответить
СообщениеТак а чем Вас не устраивает формула?
Код
=СУММ(СМЕЩ(R[2]C;;;СЧЁТЗ(R[2]C:R[500]C)))

[moder]Где теги?
[offtop]Прошу прощения. Скрипты не работают на работе. А теги наизусть не знаю

Автор - devilkurs
Дата добавления - 08.04.2016 в 09:32
_Boroda_ Дата: Пятница, 08.04.2016, 09:33 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так?
[vba]
Код
Sub tt()
    r1_ = Range("A" & Rows.Count).End(xlUp).Row - 2
    For i = 4 To 21
        If IsNumeric(Cells(3, i)) Then
            If Not IsDate(Cells(3, i)) Then
                Cells(1, i) = WorksheetFunction.Sum(Cells(3, i).Resize(r1_))
            End If
        End If
    Next i
End Sub
[/vba]
К сообщению приложен файл: 0206961_1.xlsm(21Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак?
[vba]
Код
Sub tt()
    r1_ = Range("A" & Rows.Count).End(xlUp).Row - 2
    For i = 4 To 21
        If IsNumeric(Cells(3, i)) Then
            If Not IsDate(Cells(3, i)) Then
                Cells(1, i) = WorksheetFunction.Sum(Cells(3, i).Resize(r1_))
            End If
        End If
    Next i
End Sub
[/vba]

Автор - _Boroda_
Дата добавления - 08.04.2016 в 09:33
VIDEO56 Дата: Пятница, 08.04.2016, 09:35 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
devilkurs, дело в том, что на просторах форума нашел макрос, который из этих сумм вычетает расходы, соответственно формулы не але!
Перевложил файл по своему подобию!


Всем удачного дня!
 
Ответить
Сообщениеdevilkurs, дело в том, что на просторах форума нашел макрос, который из этих сумм вычетает расходы, соответственно формулы не але!
Перевложил файл по своему подобию!

Автор - VIDEO56
Дата добавления - 08.04.2016 в 09:35
_Boroda_ Дата: Пятница, 08.04.2016, 09:40 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
нашел макрос, который из этих сумм вычетает расходы
И че?
соответственно формулы не але
Почему?
Перевложил файл по своему подобию!
Поздравляю. Теперь меняйте в макросе все 3 на 4, а 2 на 3. И заполните там столбец А. Впрочем, держите новый файл

devilkurs,
=СУММ(СМЕЩ(R[2]C;;;СЧЁТЗ(R[2]C:R[500]C)))
Волатильная. не по феншую. тогда уж
Код
=СУММ(D3:ИНДЕКС(D:D;СЧЁТЗ($A:$A)))
К сообщению приложен файл: 0206961_2.xlsm(21Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
нашел макрос, который из этих сумм вычетает расходы
И че?
соответственно формулы не але
Почему?
Перевложил файл по своему подобию!
Поздравляю. Теперь меняйте в макросе все 3 на 4, а 2 на 3. И заполните там столбец А. Впрочем, держите новый файл

devilkurs,
=СУММ(СМЕЩ(R[2]C;;;СЧЁТЗ(R[2]C:R[500]C)))
Волатильная. не по феншую. тогда уж
Код
=СУММ(D3:ИНДЕКС(D:D;СЧЁТЗ($A:$A)))

Автор - _Boroda_
Дата добавления - 08.04.2016 в 09:40
VIDEO56 Дата: Пятница, 08.04.2016, 09:52 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
Александр, перенес макрос в свой файл, изменил все как было рекомендовано, не работает. Выдает "Complite error: Viriable not defined". Вас из дас???
[moder]Не нужно уже ничего делать, я выложил новый файл. Поднимите взгляд на 10 сантиметров.


Всем удачного дня!

Сообщение отредактировал _Boroda_ - Пятница, 08.04.2016, 09:55
 
Ответить
СообщениеАлександр, перенес макрос в свой файл, изменил все как было рекомендовано, не работает. Выдает "Complite error: Viriable not defined". Вас из дас???
[moder]Не нужно уже ничего делать, я выложил новый файл. Поднимите взгляд на 10 сантиметров.

Автор - VIDEO56
Дата добавления - 08.04.2016 в 09:52
VIDEO56 Дата: Пятница, 08.04.2016, 09:56 | Сообщение № 10
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
Я видел файл. У меня файл уже существует, и почему-то макрос в нем не приживается!
[moder]Поставьте себя на мое место - вот как я могу узнать, что Вы неверно делаете, если Вы подробно свои действия не описываете?


Всем удачного дня!

Сообщение отредактировал _Boroda_ - Пятница, 08.04.2016, 10:03
 
Ответить
СообщениеЯ видел файл. У меня файл уже существует, и почему-то макрос в нем не приживается!
[moder]Поставьте себя на мое место - вот как я могу узнать, что Вы неверно делаете, если Вы подробно свои действия не описываете?

Автор - VIDEO56
Дата добавления - 08.04.2016 в 09:56
_Boroda_ Дата: Пятница, 08.04.2016, 10:07 | Сообщение № 11
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А Вы перенесли именно так, как у меня или у Вас в модуле еще строчка в самом верху есть? Вот такая: "Option Explicit". Если есть, то либо удаляйте ее, либо после строки Sub объявляйте переменные
[vba]
Код
dim r1_, i
[/vba]

Добавлено

И еще - в макросе лишнее условие
[vba]
Код
            If Not IsDate(Cells(4, i)) Then
[/vba]


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Пятница, 08.04.2016, 10:21
 
Ответить
СообщениеА Вы перенесли именно так, как у меня или у Вас в модуле еще строчка в самом верху есть? Вот такая: "Option Explicit". Если есть, то либо удаляйте ее, либо после строки Sub объявляйте переменные
[vba]
Код
dim r1_, i
[/vba]

Добавлено

И еще - в макросе лишнее условие
[vba]
Код
            If Not IsDate(Cells(4, i)) Then
[/vba]

Автор - _Boroda_
Дата добавления - 08.04.2016 в 10:07
VIDEO56 Дата: Пятница, 08.04.2016, 10:08 | Сообщение № 12
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
Я из вашего файла скопировал макрос и вставил в свой. При запуске макроса выдает ошибку


Всем удачного дня!
 
Ответить
СообщениеЯ из вашего файла скопировал макрос и вставил в свой. При запуске макроса выдает ошибку

Автор - VIDEO56
Дата добавления - 08.04.2016 в 10:08
VIDEO56 Дата: Пятница, 08.04.2016, 10:13 | Сообщение № 13
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
Александр, разобрался. Все работает. Спасибо за оперативность и терпение!


Всем удачного дня!
 
Ответить
СообщениеАлександр, разобрался. Все работает. Спасибо за оперативность и терпение!

Автор - VIDEO56
Дата добавления - 08.04.2016 в 10:13
al-Ex Дата: Пятница, 08.04.2016, 10:13 | Сообщение № 14
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 146
Репутация: 53 ±
Замечаний: 20% ±

Excel 2010
Этот попробуй


Сообщение отредактировал al-Ex - Пятница, 08.04.2016, 10:27
 
Ответить
СообщениеЭтот попробуй

Автор - al-Ex
Дата добавления - 08.04.2016 в 10:13
VIDEO56 Дата: Пятница, 08.04.2016, 10:38 | Сообщение № 15
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
al-Ex, спасибо за участие!


Всем удачного дня!

Сообщение отредактировал VIDEO56 - Пятница, 08.04.2016, 10:38
 
Ответить
Сообщениеal-Ex, спасибо за участие!

Автор - VIDEO56
Дата добавления - 08.04.2016 в 10:38
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Суммирование столбца (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!