Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подтягивание данных из списка построчно. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Подтягивание данных из списка построчно. (Макросы/Sub)
Подтягивание данных из списка построчно.
enchanter Дата: Четверг, 26.05.2016, 15:14 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Привет всем, вот столкнулся с такой задачей, сам я чайник в этом, но надеюсь поможете.
Есть список товаров, как бы база данных, у них свой код, наименование и т.д на отдельном листе, хотелось бы чтоб при формирование накладной все данные касающиеся вводимого кода, подтягивались бы сами. Буду очень признателен за помощь.
Прикручиваю файл как пример, таблицы простейшие.
К сообщению приложен файл: _Microsoft_Offi.xlsx(13Kb)
 
Ответить
СообщениеПривет всем, вот столкнулся с такой задачей, сам я чайник в этом, но надеюсь поможете.
Есть список товаров, как бы база данных, у них свой код, наименование и т.д на отдельном листе, хотелось бы чтоб при формирование накладной все данные касающиеся вводимого кода, подтягивались бы сами. Буду очень признателен за помощь.
Прикручиваю файл как пример, таблицы простейшие.

Автор - enchanter
Дата добавления - 26.05.2016 в 15:14
Sancho Дата: Четверг, 26.05.2016, 15:25 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 0% ±

2007, 2010, 2013
enchanter, использование формулы =ВПР или =ГПР на мой взгляд достаточно, судя по описанию. файл не открывал

Код
=ВПР(что ищем в данном случае ссылка на ячейку куда будет вводиться код;где ищем диапазон из нескольких столбцов где первый столбец код последующие столбцы необходимые данные;номер столбца если необходимый столбец находится в следующем после кода то 2;ЛОЖЬ)
 
Ответить
Сообщениеenchanter, использование формулы =ВПР или =ГПР на мой взгляд достаточно, судя по описанию. файл не открывал

Код
=ВПР(что ищем в данном случае ссылка на ячейку куда будет вводиться код;где ищем диапазон из нескольких столбцов где первый столбец код последующие столбцы необходимые данные;номер столбца если необходимый столбец находится в следующем после кода то 2;ЛОЖЬ)

Автор - Sancho
Дата добавления - 26.05.2016 в 15:25
_Boroda_ Дата: Четверг, 26.05.2016, 15:26 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9369
Репутация: 3942 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(B3="";"";ИНДЕКС(Наименование!C$3:C$999;ПОИСКПОЗ($B3;Наименование!$B$3:$B$999;)))

Еще Вам автообновляемый списочек выпадающий сделал в желтых ячейках.
Как сделано посмотреть можно, нажав Контрл F3
К сообщению приложен файл: 1494541.xlsx(15Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(B3="";"";ИНДЕКС(Наименование!C$3:C$999;ПОИСКПОЗ($B3;Наименование!$B$3:$B$999;)))

Еще Вам автообновляемый списочек выпадающий сделал в желтых ячейках.
Как сделано посмотреть можно, нажав Контрл F3

Автор - _Boroda_
Дата добавления - 26.05.2016 в 15:26
enchanter Дата: Четверг, 26.05.2016, 15:32 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, спасибо большое, вы в который раз мне помогли))
 
Ответить
Сообщение_Boroda_, спасибо большое, вы в который раз мне помогли))

Автор - enchanter
Дата добавления - 26.05.2016 в 15:32
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Подтягивание данных из списка построчно. (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!