Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сортировка и сопоставлен2 х списков по кол-ву и наименованию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Сортировка и сопоставлен2 х списков по кол-ву и наименованию (Макросы/Sub)
Сортировка и сопоставлен2 х списков по кол-ву и наименованию
vermut Дата: Четверг, 09.06.2016, 09:15 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
Здравствуйте профи! Есть 2 списка каждый содержит два столбца наименование и кол-во; причем наименования расположены в разном порядке. Необходимо сопоставить кол-во по каждой позиции наименования. Если какие либо наименование не встречается в 2х списках то оно и соответствующее кол-во выводиться на другой лист. Ребята как это реализовать? Наверное это очень сложно.Файл приложила.
К сообщению приложен файл: _-.xlsx(14Kb)


Сообщение отредактировал vermut - Четверг, 09.06.2016, 09:17
 
Ответить
СообщениеЗдравствуйте профи! Есть 2 списка каждый содержит два столбца наименование и кол-во; причем наименования расположены в разном порядке. Необходимо сопоставить кол-во по каждой позиции наименования. Если какие либо наименование не встречается в 2х списках то оно и соответствующее кол-во выводиться на другой лист. Ребята как это реализовать? Наверное это очень сложно.Файл приложила.

Автор - vermut
Дата добавления - 09.06.2016 в 09:15
_Boroda_ Дата: Четверг, 09.06.2016, 09:19 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9827
Репутация: 4148 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вывод количества
Код
=ВПР(A2;E$2:F$5;2;)

Если кого-то не найдет, то чтобы не ругался
Код
=ЕСЛИОШИБКА(ВПР(A2;E$2:F$5;2;);)

Если какие либо наименование не встречается в 2х списках то оно и соответствующее кол-во выводиться на другой лист
А вот здесь уточнить надо бы - выводятся наименования из первого списка, из второго или из обоих?
А ненайденные вывести так можно
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/ЕНД(ПОИСКПОЗ(A$2:A$5;E$2:E$5;))/ЕНД(ПОИСКПОЗ(A$2:A$5;I$1:I1;));A$2:A$5);"")
К сообщению приложен файл: 52452_1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВывод количества
Код
=ВПР(A2;E$2:F$5;2;)

Если кого-то не найдет, то чтобы не ругался
Код
=ЕСЛИОШИБКА(ВПР(A2;E$2:F$5;2;);)

Если какие либо наименование не встречается в 2х списках то оно и соответствующее кол-во выводиться на другой лист
А вот здесь уточнить надо бы - выводятся наименования из первого списка, из второго или из обоих?
А ненайденные вывести так можно
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/ЕНД(ПОИСКПОЗ(A$2:A$5;E$2:E$5;))/ЕНД(ПОИСКПОЗ(A$2:A$5;I$1:I1;));A$2:A$5);"")

Автор - _Boroda_
Дата добавления - 09.06.2016 в 09:19
vermut Дата: Четверг, 09.06.2016, 09:26 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
А вот здесь уточнить


Cпасибо Вам, выводятся из каждого списка отдельно
 
Ответить
Сообщение
А вот здесь уточнить


Cпасибо Вам, выводятся из каждого списка отдельно

Автор - vermut
Дата добавления - 09.06.2016 в 09:26
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Сортировка и сопоставлен2 х списков по кол-ву и наименованию (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!