Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск и копирование данных из одного файла в другой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Поиск и копирование данных из одного файла в другой (Макросы/Sub)
Поиск и копирование данных из одного файла в другой
krest Дата: Четверг, 21.07.2016, 11:30 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте, нужна помощь! Есть файл "Данные" и файл "Сборка"
В файле "Данные" на листе 1 в столбце D (Range("D2:D200")) перечислены предметы,
на против каждого предмета в ячейках (Ex:Ix) его характеристики.
Требуется, когда в файле "Сборка" Лист1 в ячейку D2 вбиваем предмет, происходил его поиск в файле "Данные" в столбце D,
а его свойства (Ex:Ix) копировались в файл "Сборка" Лист1 Range(E2:I2).
К сообщению приложен файл: 9872421.xlsx(10Kb) · 0870473.xlsx(8Kb)
 
Ответить
СообщениеЗдравствуйте, нужна помощь! Есть файл "Данные" и файл "Сборка"
В файле "Данные" на листе 1 в столбце D (Range("D2:D200")) перечислены предметы,
на против каждого предмета в ячейках (Ex:Ix) его характеристики.
Требуется, когда в файле "Сборка" Лист1 в ячейку D2 вбиваем предмет, происходил его поиск в файле "Данные" в столбце D,
а его свойства (Ex:Ix) копировались в файл "Сборка" Лист1 Range(E2:I2).

Автор - krest
Дата добавления - 21.07.2016 в 11:30
lebensvoll Дата: Четверг, 21.07.2016, 11:35 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 2 ±
Замечаний: 60% ±

Excel 2010
krest, а почему бы вам просто лист Данные не перенести в первый файл и сделать все через формулу???


Кто бы ты ни был, мир в твоих руках
 
Ответить
Сообщениеkrest, а почему бы вам просто лист Данные не перенести в первый файл и сделать все через формулу???

Автор - lebensvoll
Дата добавления - 21.07.2016 в 11:35
Pelena Дата: Четверг, 21.07.2016, 11:45 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9889
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Код
=ВПР($D2;[9872421.xlsx]Лист1!$D$1:$I$4;СТОЛБЕЦ(B1);0)

Имя файла получилось то, что в посте. Измените на нужное
К сообщению приложен файл: 8532974.xlsx(10Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ВПР($D2;[9872421.xlsx]Лист1!$D$1:$I$4;СТОЛБЕЦ(B1);0)

Имя файла получилось то, что в посте. Измените на нужное

Автор - Pelena
Дата добавления - 21.07.2016 в 11:45
krest Дата: Четверг, 21.07.2016, 11:55 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
не, файлы должны быть разные.
 
Ответить
Сообщениене, файлы должны быть разные.

Автор - krest
Дата добавления - 21.07.2016 в 11:55
krest Дата: Четверг, 21.07.2016, 11:56 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, дай Бог вам здоровья!
 
Ответить
СообщениеPelena, дай Бог вам здоровья!

Автор - krest
Дата добавления - 21.07.2016 в 11:56
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Поиск и копирование данных из одного файла в другой (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!