Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Преобразование массива данных - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Преобразование массива данных (Макросы/Sub)
Преобразование массива данных
kill-out Дата: Среда, 11.10.2017, 10:31 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!

Форумчане, прошу подсказать как лучше преобразовать данные, и как удобнее, через формулы или макрос?
Цель - создать по каждой номенклатуре отдельную строчку с ценой за коробку.
Наименований около 700, каждую строчку вручную дублировать не рационально %)

Я правильно понимаю, что сначала макросом надо продублировать каждую строчку, а остальные доработки уже обычными формулами можно сделать?
К сообщению приложен файл: _2.xls(35Kb)
 
Ответить
СообщениеЗдравствуйте!

Форумчане, прошу подсказать как лучше преобразовать данные, и как удобнее, через формулы или макрос?
Цель - создать по каждой номенклатуре отдельную строчку с ценой за коробку.
Наименований около 700, каждую строчку вручную дублировать не рационально %)

Я правильно понимаю, что сначала макросом надо продублировать каждую строчку, а остальные доработки уже обычными формулами можно сделать?

Автор - kill-out
Дата добавления - 11.10.2017 в 10:31
_Boroda_ Дата: Среда, 11.10.2017, 10:43 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Такк нужно?
Код
=ИНДЕКС('как есть'!A:A;СТРОКА()/2+1)&""

Код
=ИНДЕКС('как есть'!F:G;СТРОКА()/2+1;1+ЕНЕЧЁТ(СТРОКА()))&""

Код
=ЕСЛИ(ЕНЕЧЁТ(СТРОКА())*(A2<>"");"к";"")
К сообщению приложен файл: _2-7-1.xls(46Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТакк нужно?
Код
=ИНДЕКС('как есть'!A:A;СТРОКА()/2+1)&""

Код
=ИНДЕКС('как есть'!F:G;СТРОКА()/2+1;1+ЕНЕЧЁТ(СТРОКА()))&""

Код
=ЕСЛИ(ЕНЕЧЁТ(СТРОКА())*(A2<>"");"к";"")

Автор - _Boroda_
Дата добавления - 11.10.2017 в 10:43
kill-out Дата: Среда, 11.10.2017, 12:33 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Спасибо! всё так, кроме момента, что местами поменять цены в столбце F: например, по первой позиции цена в коробке должна быть 60р, а не 53.
какую формулу нужно исправить?
 
Ответить
Сообщение_Boroda_, Спасибо! всё так, кроме момента, что местами поменять цены в столбце F: например, по первой позиции цена в коробке должна быть 60р, а не 53.
какую формулу нужно исправить?

Автор - kill-out
Дата добавления - 11.10.2017 в 12:33
_Boroda_ Дата: Среда, 11.10.2017, 12:39 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вторую
Код
=ИНДЕКС('как есть'!F:G;СТРОКА()/2+1;1+ЕЧЁТН(СТРОКА()))&""
К сообщению приложен файл: _2-7-2.xls(46Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВторую
Код
=ИНДЕКС('как есть'!F:G;СТРОКА()/2+1;1+ЕЧЁТН(СТРОКА()))&""

Автор - _Boroda_
Дата добавления - 11.10.2017 в 12:39
kill-out Дата: Среда, 11.10.2017, 13:17 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, спасибо ещё раз!
 
Ответить
Сообщение_Boroda_, спасибо ещё раз!

Автор - kill-out
Дата добавления - 11.10.2017 в 13:17
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Преобразование массива данных (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!