Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определение пропущенных звонков по базе данных - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Определение пропущенных звонков по базе данных (Макросы/Sub)
Определение пропущенных звонков по базе данных
gracefuldoe Дата: Среда, 10.01.2018, 09:45 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Помогите пожалуйста составить макрос, который будет сравнивать 2 списка (пример прикрепила) с номерами телефонов.

В одном списке все успешные звонки, в другом пропущенные. Макрос должен выдавать список пропущенных звонков, учитывая также время звонка. Т.е. если звонок есть и в пропущенных и в успешных, но в пропущенных время звонка позднее, значит он пропущенный. И наоборот соответственно.
К сообщению приложен файл: 4675644.xlsx(13.7 Kb)


Сообщение отредактировал gracefuldoe - Среда, 10.01.2018, 09:52
 
Ответить
СообщениеПомогите пожалуйста составить макрос, который будет сравнивать 2 списка (пример прикрепила) с номерами телефонов.

В одном списке все успешные звонки, в другом пропущенные. Макрос должен выдавать список пропущенных звонков, учитывая также время звонка. Т.е. если звонок есть и в пропущенных и в успешных, но в пропущенных время звонка позднее, значит он пропущенный. И наоборот соответственно.

Автор - gracefuldoe
Дата добавления - 10.01.2018 в 09:45
китин Дата: Среда, 10.01.2018, 09:50 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4924
Репутация: 786 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
нет примера, увы


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениенет примера, увы

Автор - китин
Дата добавления - 10.01.2018 в 09:50
gracefuldoe Дата: Среда, 10.01.2018, 09:53 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
китин, приложила, почему-то первый раз слетел
К сообщению приложен файл: 3159260.xlsx(13.7 Kb)


Сообщение отредактировал gracefuldoe - Среда, 10.01.2018, 09:54
 
Ответить
Сообщениекитин, приложила, почему-то первый раз слетел

Автор - gracefuldoe
Дата добавления - 10.01.2018 в 09:53
китин Дата: Среда, 10.01.2018, 09:59 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4924
Репутация: 786 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
не знаю, может я что то туплю с утра, но непонятненько.
у вас же уже есть список пропущенных в файле. по какому критерию надо вытаскивать список пропущенных из пропущенных??? %)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениене знаю, может я что то туплю с утра, но непонятненько.
у вас же уже есть список пропущенных в файле. по какому критерию надо вытаскивать список пропущенных из пропущенных??? %)

Автор - китин
Дата добавления - 10.01.2018 в 09:59
gracefuldoe Дата: Среда, 10.01.2018, 10:02 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
китин, часть из них может быть в успешных (дозвонились сами какое-то время спустя), другой части перезвонили администраторы. Нужно вычленить тех, кто не дозвонился и кому не перезвонили.
 
Ответить
Сообщениекитин, часть из них может быть в успешных (дозвонились сами какое-то время спустя), другой части перезвонили администраторы. Нужно вычленить тех, кто не дозвонился и кому не перезвонили.

Автор - gracefuldoe
Дата добавления - 10.01.2018 в 10:02
sboy Дата: Среда, 10.01.2018, 10:09 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1909
Репутация: 558 ±
Замечаний: 0% ±

Excel 2010
вариант формулой (потом можно фильтровать)
Код
=ЕСЛИОШИБКА(ЕСЛИ(ИНДЕКС(Успешные!$A$1:$A$70;ПОИСКПОЗ(B1;Успешные!$B$1:$B$70;))>A1;"успешно перезвонили";"пропущен");"пропущен")
К сообщению приложен файл: 5340941.xlsx(14.0 Kb)
 
Ответить
Сообщениевариант формулой (потом можно фильтровать)
Код
=ЕСЛИОШИБКА(ЕСЛИ(ИНДЕКС(Успешные!$A$1:$A$70;ПОИСКПОЗ(B1;Успешные!$B$1:$B$70;))>A1;"успешно перезвонили";"пропущен");"пропущен")

Автор - sboy
Дата добавления - 10.01.2018 в 10:09
gracefuldoe Дата: Среда, 10.01.2018, 10:15 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
sboy, работает как нужно! спасибо большое! hands
 
Ответить
Сообщениеsboy, работает как нужно! спасибо большое! hands

Автор - gracefuldoe
Дата добавления - 10.01.2018 в 10:15
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Определение пропущенных звонков по базе данных (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!