Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Создание таблицы с суммированием при совпадении значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Создание таблицы с суммированием при совпадении значений (VBA Создание суммированной таблицы)
Создание таблицы с суммированием при совпадении значений
vldmlt Дата: Пятница, 06.07.2018, 15:01 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Помогите с кодом VBA...
Из Исходной таблицы получить Результирующую:
т.е. при совпадении Код-Наименование-Дата просуммировать Количество

Спасибо всем!

(пример во вложении)
 
Ответить
СообщениеДобрый день!
Помогите с кодом VBA...
Из Исходной таблицы получить Результирующую:
т.е. при совпадении Код-Наименование-Дата просуммировать Количество

Спасибо всем!

(пример во вложении)

Автор - vldmlt
Дата добавления - 06.07.2018 в 15:01
Pelena Дата: Пятница, 06.07.2018, 15:18 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12838
Репутация: 2828 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Файл не приложился, проверьте размер до 100 кБ


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФайл не приложился, проверьте размер до 100 кБ

Автор - Pelena
Дата добавления - 06.07.2018 в 15:18
Kuzmich Дата: Пятница, 06.07.2018, 15:18 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 362
Репутация: 67 ±
Замечаний: 0% ±

Excel 2003
Цитата
(пример во вложении)

и где он?
 
Ответить
Сообщение
Цитата
(пример во вложении)

и где он?

Автор - Kuzmich
Дата добавления - 06.07.2018 в 15:18
vldmlt Дата: Пятница, 06.07.2018, 16:02 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
((
не прицепился
К сообщению приложен файл: 3026942.xlsx(10.1 Kb)
 
Ответить
Сообщение((
не прицепился

Автор - vldmlt
Дата добавления - 06.07.2018 в 16:02
_Boroda_ Дата: Пятница, 06.07.2018, 16:05 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12686
Репутация: 5200 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А сводной таблицей не подойдет? Как раз для нее задачка

* Перевложил файл с диапазоном для сводной до 999 строки
К сообщению приложен файл: 3026942_1.xlsx(14.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА сводной таблицей не подойдет? Как раз для нее задачка

* Перевложил файл с диапазоном для сводной до 999 строки

Автор - _Boroda_
Дата добавления - 06.07.2018 в 16:05
Pelena Дата: Пятница, 06.07.2018, 16:06 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12838
Репутация: 2828 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Напрашивается сводная
К сообщению приложен файл: 8230209.xlsx(13.9 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНапрашивается сводная

Автор - Pelena
Дата добавления - 06.07.2018 в 16:06
китин Дата: Суббота, 07.07.2018, 09:01 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4930
Репутация: 787 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
или формулой массива
Код
=ИНДЕКС(B$4:B$9;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($B$4:$B$9&$C$4:$C$9;$B$4:$B$9&$C$4:$C$9;0)=СТРОКА($B$4:$B$9)-3;СТРОКА($B$4:$B$9)-3);СТРОКА(A1)))

и вторая
Код
=СУММПРОИЗВ($D$4:$D$9*($B$4:$B$9&$C$4:$C$9=$B14&$C14))
К сообщению приложен файл: vldmlt.xlsx(10.8 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеили формулой массива
Код
=ИНДЕКС(B$4:B$9;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($B$4:$B$9&$C$4:$C$9;$B$4:$B$9&$C$4:$C$9;0)=СТРОКА($B$4:$B$9)-3;СТРОКА($B$4:$B$9)-3);СТРОКА(A1)))

и вторая
Код
=СУММПРОИЗВ($D$4:$D$9*($B$4:$B$9&$C$4:$C$9=$B14&$C14))

Автор - китин
Дата добавления - 07.07.2018 в 09:01
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Создание таблицы с суммированием при совпадении значений (VBA Создание суммированной таблицы)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!