Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Макрос на перенос данных из листа в лист - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Макрос на перенос данных из листа в лист (Макросы/Sub)
Макрос на перенос данных из листа в лист
Sany Дата: Вторник, 31.07.2018, 09:07 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток!
Подскажите, как осуществить перенос данных из листа в лист посредством макроса?
Из листа График(месячный) колонки: J; K; L; M; N; O в лист график (годовой) колонки: L; M; N; O; P; Q
В VBA к сожалению не силен, переносил формулой ВПР:
Код
=ВПР($B8;'График (годовой)'!B:W;17;0)

Но ввиду большого количества ячеек программа начинает сильно тормозить и производит нужные вычисления, или просто занесение информации очень долго.
Файл с таблицей (укороченная версия) прилагаю
К сообщению приложен файл: _--_.xlsx(85.4 Kb)
 
Ответить
СообщениеДоброго времени суток!
Подскажите, как осуществить перенос данных из листа в лист посредством макроса?
Из листа График(месячный) колонки: J; K; L; M; N; O в лист график (годовой) колонки: L; M; N; O; P; Q
В VBA к сожалению не силен, переносил формулой ВПР:
Код
=ВПР($B8;'График (годовой)'!B:W;17;0)

Но ввиду большого количества ячеек программа начинает сильно тормозить и производит нужные вычисления, или просто занесение информации очень долго.
Файл с таблицей (укороченная версия) прилагаю

Автор - Sany
Дата добавления - 31.07.2018 в 09:07
_Boroda_ Дата: Вторник, 31.07.2018, 09:25 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13701
Репутация: 5587 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Подождите, я не понял
Из листа График(месячный) колонки: J; K; L; M; N; O в лист график (годовой) колонки: L; M; N; O; P; Q
=ВПР($B8;'График (годовой)'!B:W;17;0)
Но ввиду большого количества ячеек программа начинает сильно тормозить

А формула переносит данные ИЗ годовой. Вы ничего не перепутали?
По поводу "Тормозит" - все правильно делает. Не нужно сувать во второй аргумент ВПРа полностью столбцы. Вместо "B:W" напишите, например, "B1:W999". Кстати, если у Вас перед B8 доллар стоит, то надо бы и B1:W999 написать с долларами - "$B$1:$W$999". Это если Вы эту формулу будете копировать (о чем свидетельствует первый доллар)
Попробуйте еще формулу вот так написать (в ИНДЕКСе полный столбец можно писать)
Код
=ИНДЕКС('График (годовой)'!S:S;ПОИСКПОЗ($B8;'График (годовой)'!$B$1:$B$999;))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПодождите, я не понял
Из листа График(месячный) колонки: J; K; L; M; N; O в лист график (годовой) колонки: L; M; N; O; P; Q
=ВПР($B8;'График (годовой)'!B:W;17;0)
Но ввиду большого количества ячеек программа начинает сильно тормозить

А формула переносит данные ИЗ годовой. Вы ничего не перепутали?
По поводу "Тормозит" - все правильно делает. Не нужно сувать во второй аргумент ВПРа полностью столбцы. Вместо "B:W" напишите, например, "B1:W999". Кстати, если у Вас перед B8 доллар стоит, то надо бы и B1:W999 написать с долларами - "$B$1:$W$999". Это если Вы эту формулу будете копировать (о чем свидетельствует первый доллар)
Попробуйте еще формулу вот так написать (в ИНДЕКСе полный столбец можно писать)
Код
=ИНДЕКС('График (годовой)'!S:S;ПОИСКПОЗ($B8;'График (годовой)'!$B$1:$B$999;))

Автор - _Boroda_
Дата добавления - 31.07.2018 в 09:25
Sany Дата: Вторник, 31.07.2018, 11:02 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо!!!
Код
=ИНДЕКС
не пробовал, сейчас исправлюсь)))
 
Ответить
СообщениеСпасибо!!!
Код
=ИНДЕКС
не пробовал, сейчас исправлюсь)))

Автор - Sany
Дата добавления - 31.07.2018 в 11:02
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Макрос на перенос данных из листа в лист (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!