Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сопоставление нескольких критериев - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Сопоставление нескольких критериев (Макросы/Sub)
Сопоставление нескольких критериев
-=Dj=- Дата: Воскресенье, 15.09.2019, 22:43 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, нужна помощь с обработкой данных таблицы.
Надо сопоставить несколько критериев и вынести в отдельный столбец с наибольшим значением, в данном случае датой.
Другими словами, присвоить торговой точке менеджера, который посещал ее последним.
К сообщению приложен файл: 5067106.xlsx(10.8 Kb)


Сообщение отредактировал -=Dj=- - Воскресенье, 15.09.2019, 22:43
 
Ответить
СообщениеЗдравствуйте, нужна помощь с обработкой данных таблицы.
Надо сопоставить несколько критериев и вынести в отдельный столбец с наибольшим значением, в данном случае датой.
Другими словами, присвоить торговой точке менеджера, который посещал ее последним.

Автор - -=Dj=-
Дата добавления - 15.09.2019 в 22:43
Pelena Дата: Воскресенье, 15.09.2019, 22:54 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14579
Репутация: 3192 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Обязательно макросом? Формула не подойдёт?
Формула массива
Код
=ИНДЕКС($B$2:$B$10;ПОИСКПОЗ(МАКС(($C$2:$C$10=C2)*($D$2:$D$10=D2)*($E$2:$E$10=E2)*$A$2:$A$10);($C$2:$C$10=C2)*($D$2:$D$10=D2)*($E$2:$E$10=E2)*$A$2:$A$10;0))
К сообщению приложен файл: 8333173.xlsx(12.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Обязательно макросом? Формула не подойдёт?
Формула массива
Код
=ИНДЕКС($B$2:$B$10;ПОИСКПОЗ(МАКС(($C$2:$C$10=C2)*($D$2:$D$10=D2)*($E$2:$E$10=E2)*$A$2:$A$10);($C$2:$C$10=C2)*($D$2:$D$10=D2)*($E$2:$E$10=E2)*$A$2:$A$10;0))

Автор - Pelena
Дата добавления - 15.09.2019 в 22:54
Nic70y Дата: Понедельник, 16.09.2019, 08:57 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 5681
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
не массивный вариант
Код
=ИНДЕКС(B:B;ОКРУГЛ(ОСТАТ(МАКС(ИНДЕКС((C$2:C$10=C2)*(D$2:D$10=D2)*(E$2:E$10=E2)*A$2:A$10+СТРОКА(A$2:A$10)/10000;));1)*10000;))
если даты не повторяются (как в примере)
Код
=ВПР(МАКС(ИНДЕКС((C$2:C$10=C2)*(D$2:D$10=D2)*(E$2:E$10=E2)*A$2:A$10;));A$2:B$10;2;)


ЯД(poison) 41001841029809
 
Ответить
Сообщениене массивный вариант
Код
=ИНДЕКС(B:B;ОКРУГЛ(ОСТАТ(МАКС(ИНДЕКС((C$2:C$10=C2)*(D$2:D$10=D2)*(E$2:E$10=E2)*A$2:A$10+СТРОКА(A$2:A$10)/10000;));1)*10000;))
если даты не повторяются (как в примере)
Код
=ВПР(МАКС(ИНДЕКС((C$2:C$10=C2)*(D$2:D$10=D2)*(E$2:E$10=E2)*A$2:A$10;));A$2:B$10;2;)

Автор - Nic70y
Дата добавления - 16.09.2019 в 08:57
-=Dj=- Дата: Понедельник, 16.09.2019, 09:54 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо огромное! Можно и формулами, тему перекиньте в нужный раздел...
 
Ответить
СообщениеСпасибо огромное! Можно и формулами, тему перекиньте в нужный раздел...

Автор - -=Dj=-
Дата добавления - 16.09.2019 в 09:54
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Сопоставление нескольких критериев (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!