Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автозаполнение ячейки по значению другой ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Автозаполнение ячейки по значению другой ячейки (Макросы/Sub)
Автозаполнение ячейки по значению другой ячейки
HeyKa Дата: Пятница, 18.10.2019, 15:01 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте!

Прошу помощь! Есть таблица. На вкладке "ИНН" в столбце А указано наименование контрагента. В столбце В - его ИНН.
Нужно сделать так, чтобы на вкладке "Контрагент" при наборе в ручную в столбце А наименования контрагента в столбце В появлялся его ИНН.

Заранее благодарен!
К сообщению приложен файл: 2663701.xlsx(10.0 Kb)
 
Ответить
СообщениеЗдравствуйте!

Прошу помощь! Есть таблица. На вкладке "ИНН" в столбце А указано наименование контрагента. В столбце В - его ИНН.
Нужно сделать так, чтобы на вкладке "Контрагент" при наборе в ручную в столбце А наименования контрагента в столбце В появлялся его ИНН.

Заранее благодарен!

Автор - HeyKa
Дата добавления - 18.10.2019 в 15:01
YouGreed Дата: Пятница, 18.10.2019, 15:26 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 436
Репутация: 94 ±
Замечаний: 0% ±

Excel 2010
HeyKa, Смотрите вложение.

Сделал, список по контрагентам, выпадающий.

Формула проста:

Код
=ЕСЛИОШИБКА(ВПР($A2;ИНН!$A$2:$B$12;2;);"")
К сообщению приложен файл: ___.xlsx(10.5 Kb)
 
Ответить
СообщениеHeyKa, Смотрите вложение.

Сделал, список по контрагентам, выпадающий.

Формула проста:

Код
=ЕСЛИОШИБКА(ВПР($A2;ИНН!$A$2:$B$12;2;);"")

Автор - YouGreed
Дата добавления - 18.10.2019 в 15:26
HeyKa Дата: Пятница, 18.10.2019, 18:36 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
YouGreed, спасибо большое! А есть возможность сделать без выпадающего списка. Контрагентов будет более 200.
Заранее благодарен!
 
Ответить
СообщениеYouGreed, спасибо большое! А есть возможность сделать без выпадающего списка. Контрагентов будет более 200.
Заранее благодарен!

Автор - HeyKa
Дата добавления - 18.10.2019 в 18:36
Pelena Дата: Суббота, 19.10.2019, 18:56 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14763
Репутация: 3229 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Откройте Данные -- Проверка данных и выберите тип данных Любое значение. Выпадающий список удалится, НО тогда любая ошибка/опечатка в наборе названия контрагента - и формула не сработает


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеОткройте Данные -- Проверка данных и выберите тип данных Любое значение. Выпадающий список удалится, НО тогда любая ошибка/опечатка в наборе названия контрагента - и формула не сработает

Автор - Pelena
Дата добавления - 19.10.2019 в 18:56
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Автозаполнение ячейки по значению другой ячейки (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!