Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Среднее последних пяти значений с условием - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Среднее последних пяти значений с условием (Макросы/Sub)
Среднее последних пяти значений с условием
Olega93 Дата: Понедельник, 11.05.2020, 17:53 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый вечер. Может кто подскажет как решить такую задачу с помощью макроса, хотя я не знаю как это и формулами реализовать. Попробую объяснить на примере с погодой. Например я фиксирую, был ли дождь в определенный день и записываю температуру за этот день. В столбце "B" 1 - был дождь, 0 - не было. В столбце С значения температуры. А в столбце D та средняя величина которую я хочу рассчитывать. Для примера я вручную записал в каждой ячейке формулы. Расчет должен производиться с условием наличия дождя. Например для ячейки D16, смотрим что в тот день не было дождя, значит просматриваемый диапазон будет С2:С15, из которого нужно найти 5 последних значений для без дождливых дней и посчитать среднее между ними. Соответственно также делать для все остальных ячеек с учетом 0 и 1 в столбце В.
К сообщению приложен файл: 7301374.xls(28.0 Kb)
 
Ответить
СообщениеДобрый вечер. Может кто подскажет как решить такую задачу с помощью макроса, хотя я не знаю как это и формулами реализовать. Попробую объяснить на примере с погодой. Например я фиксирую, был ли дождь в определенный день и записываю температуру за этот день. В столбце "B" 1 - был дождь, 0 - не было. В столбце С значения температуры. А в столбце D та средняя величина которую я хочу рассчитывать. Для примера я вручную записал в каждой ячейке формулы. Расчет должен производиться с условием наличия дождя. Например для ячейки D16, смотрим что в тот день не было дождя, значит просматриваемый диапазон будет С2:С15, из которого нужно найти 5 последних значений для без дождливых дней и посчитать среднее между ними. Соответственно также делать для все остальных ячеек с учетом 0 и 1 в столбце В.

Автор - Olega93
Дата добавления - 11.05.2020 в 17:53
Pelena Дата: Понедельник, 11.05.2020, 19:02 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15746
Репутация: 3430 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Наверное, можно оптимизировать, но пока так
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ((ИНДЕКС($C$1:C1;АГРЕГАТ(15;6;СТРОКА($C$1:C1)/($B$1:B1=B2);МАКС(СЧЁТЕСЛИ($B$1:B1;B2)-4;1))):C1)*(ИНДЕКС($B$1:B1;АГРЕГАТ(15;6;СТРОКА($C$1:C1)/($B$1:B1=B2);МАКС(СЧЁТЕСЛИ($B$1:B1;B2)-4;1))):B1=B2))/МИН(СЧЁТЕСЛИ($B$1:B1;B2);5);0)
К сообщению приложен файл: 0957360.xls(36.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Наверное, можно оптимизировать, но пока так
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ((ИНДЕКС($C$1:C1;АГРЕГАТ(15;6;СТРОКА($C$1:C1)/($B$1:B1=B2);МАКС(СЧЁТЕСЛИ($B$1:B1;B2)-4;1))):C1)*(ИНДЕКС($B$1:B1;АГРЕГАТ(15;6;СТРОКА($C$1:C1)/($B$1:B1=B2);МАКС(СЧЁТЕСЛИ($B$1:B1;B2)-4;1))):B1=B2))/МИН(СЧЁТЕСЛИ($B$1:B1;B2);5);0)

Автор - Pelena
Дата добавления - 11.05.2020 в 19:02
Olega93 Дата: Понедельник, 11.05.2020, 20:35 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Pelena, Спасибо, работает)
 
Ответить
СообщениеPelena, Спасибо, работает)

Автор - Olega93
Дата добавления - 11.05.2020 в 20:35
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Среднее последних пяти значений с условием (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!