Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск одинаковых позиций - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Поиск одинаковых позиций (Макросы/Sub)
Поиск одинаковых позиций
Espada Дата: Вторник, 13.10.2020, 11:59 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 100
Репутация: 0 ±
Замечаний: 0% ±

Доброго дня, поставили такую задачу: в Списке данных, Найти каждую кратную тридцати повторяющуюся позицию. и пометить её. сравнивать позиции по двум столбцам. может кто-нибудь помочь или хотя бы натолкнуть на мысль, как сделать? вообще идей нету. Спасибо.
 
Ответить
СообщениеДоброго дня, поставили такую задачу: в Списке данных, Найти каждую кратную тридцати повторяющуюся позицию. и пометить её. сравнивать позиции по двум столбцам. может кто-нибудь помочь или хотя бы натолкнуть на мысль, как сделать? вообще идей нету. Спасибо.

Автор - Espada
Дата добавления - 13.10.2020 в 11:59
Pelena Дата: Вторник, 13.10.2020, 12:05 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16785
Репутация: 3621 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Файл покажете?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФайл покажете?

Автор - Pelena
Дата добавления - 13.10.2020 в 12:05
Espada Дата: Вторник, 13.10.2020, 14:51 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 100
Репутация: 0 ±
Замечаний: 0% ±

Файл покажете?

Извиняюсь, забыл. в Столбце Пометка отображены позиции которые повторяются в списке каждые 30 раз. Сравнение позиций идёт по Наименованию и партии.
К сообщению приложен файл: 8833996.xlsx(20.6 Kb)
 
Ответить
Сообщение
Файл покажете?

Извиняюсь, забыл. в Столбце Пометка отображены позиции которые повторяются в списке каждые 30 раз. Сравнение позиций идёт по Наименованию и партии.

Автор - Espada
Дата добавления - 13.10.2020 в 14:51
Pelena Дата: Вторник, 13.10.2020, 21:08 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16785
Репутация: 3621 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Не совсем понятно, как надо было пометить.
Формула для столбца Пометка
Код
=ЕСЛИ(ОСТАТ(СЧЁТЕСЛИМН($C$2:$C2;C2;$D$2:$D2;D2);30)=0;СЧЁТЕСЛИМН($C$2:$C2;C2;$D$2:$D2;D2)&" "&C2&" "&D2;"")
К сообщению приложен файл: 0498734.xlsx(35.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНе совсем понятно, как надо было пометить.
Формула для столбца Пометка
Код
=ЕСЛИ(ОСТАТ(СЧЁТЕСЛИМН($C$2:$C2;C2;$D$2:$D2;D2);30)=0;СЧЁТЕСЛИМН($C$2:$C2;C2;$D$2:$D2;D2)&" "&C2&" "&D2;"")

Автор - Pelena
Дата добавления - 13.10.2020 в 21:08
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Поиск одинаковых позиций (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!