Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Округлить число по условию (с сохранением остатка) - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Округлить число по условию (с сохранением остатка) (Макросы/Sub)
Округлить число по условию (с сохранением остатка)
rtv206 Дата: Воскресенье, 17.01.2021, 16:20 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго времени суток уважаемые форумчане!
В очередной раз обращаюсь к Вам за помощью.
Есть проблема при написании макроса:
На листе "Лист1" заданные данные, (ряд чисел), строк и столбцов может быть разное количество.
Необходимо на другой лист перенести данные, которые необходимо округлить:
округление провести вверх если модуль разницы числа на Лист1 и числа на Лист2 больше 0,5 - округляем вверх, если меньше -0,5 округляем - вниз.
Остаток числа от округления прибавить к следующему числу.
На Лист1 - исходные данные
на Лист2 - то что должно получится.
К сообщению приложен файл: 9558062.xlsx(11.2 Kb)
 
Ответить
СообщениеДоброго времени суток уважаемые форумчане!
В очередной раз обращаюсь к Вам за помощью.
Есть проблема при написании макроса:
На листе "Лист1" заданные данные, (ряд чисел), строк и столбцов может быть разное количество.
Необходимо на другой лист перенести данные, которые необходимо округлить:
округление провести вверх если модуль разницы числа на Лист1 и числа на Лист2 больше 0,5 - округляем вверх, если меньше -0,5 округляем - вниз.
Остаток числа от округления прибавить к следующему числу.
На Лист1 - исходные данные
на Лист2 - то что должно получится.

Автор - rtv206
Дата добавления - 17.01.2021 в 16:20
Pelena Дата: Воскресенье, 17.01.2021, 17:51 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17258
Репутация: 3809 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Модуль разницы не может быть меньше -0,5.
Если данные только на Лист1, то как сравнить
числа на Лист1 и числа на Лист2

Поясните на примере первых двух-трёх чисел алгоритм


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Модуль разницы не может быть меньше -0,5.
Если данные только на Лист1, то как сравнить
числа на Лист1 и числа на Лист2

Поясните на примере первых двух-трёх чисел алгоритм

Автор - Pelena
Дата добавления - 17.01.2021 в 17:51
rtv206 Дата: Понедельник, 18.01.2021, 11:19 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, там опечатка должно быть:..... если меньше 0,5 округляем - вниз.
Пример приложил в файл в файле
К сообщению приложен файл: 7469846.xlsx(13.8 Kb)
 
Ответить
СообщениеPelena, там опечатка должно быть:..... если меньше 0,5 округляем - вниз.
Пример приложил в файл в файле

Автор - rtv206
Дата добавления - 18.01.2021 в 11:19
Pelena Дата: Понедельник, 18.01.2021, 19:48 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 17258
Репутация: 3809 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Формула для С5 на листе 2
Код
=ОКРУГЛ(СУММ(Лист1!$C5:C5)-СУММ($B5:B5);0)
К сообщению приложен файл: 4700585.xlsx(16.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула для С5 на листе 2
Код
=ОКРУГЛ(СУММ(Лист1!$C5:C5)-СУММ($B5:B5);0)

Автор - Pelena
Дата добавления - 18.01.2021 в 19:48
rtv206 Дата: Понедельник, 18.01.2021, 21:38 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, Благодарю за помощь!
А макросом это можно сделать?
Количество столбов и строк очень большое, и не всегда одинаковое.
 
Ответить
СообщениеPelena, Благодарю за помощь!
А макросом это можно сделать?
Количество столбов и строк очень большое, и не всегда одинаковое.

Автор - rtv206
Дата добавления - 18.01.2021 в 21:38
Pelena Дата: Понедельник, 18.01.2021, 21:54 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 17258
Репутация: 3809 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Можно и макросом
К сообщению приложен файл: 7469846.xlsm(22.1 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеМожно и макросом

Автор - Pelena
Дата добавления - 18.01.2021 в 21:54
rtv206 Дата: Вторник, 19.01.2021, 19:33 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, Благодарю за помоць.
Буду тестировать.
 
Ответить
СообщениеPelena, Благодарю за помоць.
Буду тестировать.

Автор - rtv206
Дата добавления - 19.01.2021 в 19:33
rtv206 Дата: Вторник, 19.01.2021, 20:24 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, подскажите, пожалуйста, что необходимо поменять в коде если добавить в таблице начале таблицы один столбец.
Или одну строчку которая в округлении не принимает участие
К сообщению приложен файл: 7469846-1-.xlsm(20.2 Kb)
 
Ответить
СообщениеPelena, подскажите, пожалуйста, что необходимо поменять в коде если добавить в таблице начале таблицы один столбец.
Или одну строчку которая в округлении не принимает участие

Автор - rtv206
Дата добавления - 19.01.2021 в 20:24
Pelena Дата: Вторник, 19.01.2021, 22:26 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 17258
Репутация: 3809 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
В начале кода завела переменные. С их помощью сможете задавать кол-во строк и столбцов, которые не участвуют в округлении, а также начальную ячейку таблицы
К сообщению приложен файл: 8358927.xlsm(23.6 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВ начале кода завела переменные. С их помощью сможете задавать кол-во строк и столбцов, которые не участвуют в округлении, а также начальную ячейку таблицы

Автор - Pelena
Дата добавления - 19.01.2021 в 22:26
rtv206 Дата: Вторник, 19.01.2021, 23:01 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, спасибо!!!
 
Ответить
СообщениеPelena, спасибо!!!

Автор - rtv206
Дата добавления - 19.01.2021 в 23:01
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Округлить число по условию (с сохранением остатка) (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!