Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнение колонки в таблице данными из другой по условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Заполнение колонки в таблице данными из другой по условию (Макросы/Sub)
Заполнение колонки в таблице данными из другой по условию
AlexOD Дата: Суббота, 02.10.2021, 23:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Доброго всем дня гуру Excel! Очень нужна ваша помощь в написании макроса. Есть два файла "Картотека ИУ-2.xlsm" и "Журнал КДС.xlsm".
Что нужно:
Файл "Картотека ИУ-2.xlsm". написать макрос для заполнения последней датой колонки "Последняя передача" из файла "Журнал КДС.xlsm" по Иннос если в колонке передача стоит "положена" или "посылка", и строка в файле "Картотека ИУ-2.xlsm"без заливки цветом. Я честно пытался весь день найти решение, но либо не верно составляю поисковый запрос, либо просто не везет.
К сообщению приложен файл: _-2.xlsm(9.5 Kb) · 5113232.xlsm(9.9 Kb)
 
Ответить
СообщениеДоброго всем дня гуру Excel! Очень нужна ваша помощь в написании макроса. Есть два файла "Картотека ИУ-2.xlsm" и "Журнал КДС.xlsm".
Что нужно:
Файл "Картотека ИУ-2.xlsm". написать макрос для заполнения последней датой колонки "Последняя передача" из файла "Журнал КДС.xlsm" по Иннос если в колонке передача стоит "положена" или "посылка", и строка в файле "Картотека ИУ-2.xlsm"без заливки цветом. Я честно пытался весь день найти решение, но либо не верно составляю поисковый запрос, либо просто не везет.

Автор - AlexOD
Дата добавления - 02.10.2021 в 23:14
AlexOD Дата: Воскресенье, 03.10.2021, 21:42 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Добрый вечер! Нашел почти решение при помощи формулы
Код
=ЕСЛИОШИБКА(МАКС(ИНДЕКС(('[Журнал КДС.xlsm]Передачи'!$L$2:$L$100000=CB2)*('[Журнал КДС.xlsm]Передачи'!$F$2:$F$100000="положена")*'[Журнал КДС.xlsm]Передачи'!$A$2:$A$100000;0));"")

Но ничего не получается если вставить в формулу еще и "посылка" и если нет "положена" не оставляет ячейку пустой, да и довольно таки сильно подтормаживает. Может кто подскажет другое решение?


Сообщение отредактировал Serge_007 - Понедельник, 04.10.2021, 13:15
 
Ответить
СообщениеДобрый вечер! Нашел почти решение при помощи формулы
Код
=ЕСЛИОШИБКА(МАКС(ИНДЕКС(('[Журнал КДС.xlsm]Передачи'!$L$2:$L$100000=CB2)*('[Журнал КДС.xlsm]Передачи'!$F$2:$F$100000="положена")*'[Журнал КДС.xlsm]Передачи'!$A$2:$A$100000;0));"")

Но ничего не получается если вставить в формулу еще и "посылка" и если нет "положена" не оставляет ячейку пустой, да и довольно таки сильно подтормаживает. Может кто подскажет другое решение?

Автор - AlexOD
Дата добавления - 03.10.2021 в 21:42
китин Дата: Понедельник, 04.10.2021, 12:58 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
AlexOD, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
СообщениеAlexOD, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - китин
Дата добавления - 04.10.2021 в 12:58
NikitaDvorets Дата: Среда, 06.10.2021, 11:55 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 364
Репутация: 65 ±
Замечаний: 0% ±

Excel 2019
AlexOD, добрый день.
Журнал и картотека объединены в один файл, добавлен код условия заливки ячейки цветом (vba).
Вариант решения - в прилагаемом файле.
К сообщению приложен файл: __06-10-2021.xlsm(20.3 Kb)
 
Ответить
СообщениеAlexOD, добрый день.
Журнал и картотека объединены в один файл, добавлен код условия заливки ячейки цветом (vba).
Вариант решения - в прилагаемом файле.

Автор - NikitaDvorets
Дата добавления - 06.10.2021 в 11:55
AlexOD Дата: Суббота, 09.10.2021, 21:37 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Цитата NikitaDvorets, 06.10.2021 в 11:55, в сообщении № 4 ()
Журнал и картотека объединены в один файл, добавлен код условия заливки ячейки цветом (vba).
Вариант решения - в прилагаемом файле.

Огромное спасибо за помощь, но это не совсем то что нужно, "журнал" и "картотека" должны быть раздельно так как у журнала включен общий доступ и записи в нем ведутся с двух компьютеров, а заливка строки цветом в картотеке выполняется макросом при любой записи в колонке "Куда убыл". Вот вобщем то формула которая удовлетворяет поставленной задаче:
Код
=ЕСЛИ(МАКС(ИНДЕКС(('[Журнал КДС.xlsm]Передачи'!$L$2:$L$9999=CB22)*('[Журнал КДС.xlsm]Передачи'!$F$2:$F$9999="положена")*'[Журнал КДС.xlsm]Передачи'!$A$2:$A$9999;0));МАКС(ИНДЕКС(('[Журнал КДС.xlsm]Передачи'!$L$2:$L$9999=CB22)*('[Журнал КДС.xlsm]Передачи'!$F$2:$F$9999="положена")*'[Журнал КДС.xlsm]Передачи'!$A$2:$A$9999;0));"не получал")

Но так как компьютер довольно слабый а строк в Картотеке >14 тыс. то наблюдаются довольно таки сильные тормоза при заполнении журнала. Может подскажете хотябы пример как то что делает формула реализовать макросом , разово выполнить - заполнить колонку.
 
Ответить
Сообщение
Цитата NikitaDvorets, 06.10.2021 в 11:55, в сообщении № 4 ()
Журнал и картотека объединены в один файл, добавлен код условия заливки ячейки цветом (vba).
Вариант решения - в прилагаемом файле.

Огромное спасибо за помощь, но это не совсем то что нужно, "журнал" и "картотека" должны быть раздельно так как у журнала включен общий доступ и записи в нем ведутся с двух компьютеров, а заливка строки цветом в картотеке выполняется макросом при любой записи в колонке "Куда убыл". Вот вобщем то формула которая удовлетворяет поставленной задаче:
Код
=ЕСЛИ(МАКС(ИНДЕКС(('[Журнал КДС.xlsm]Передачи'!$L$2:$L$9999=CB22)*('[Журнал КДС.xlsm]Передачи'!$F$2:$F$9999="положена")*'[Журнал КДС.xlsm]Передачи'!$A$2:$A$9999;0));МАКС(ИНДЕКС(('[Журнал КДС.xlsm]Передачи'!$L$2:$L$9999=CB22)*('[Журнал КДС.xlsm]Передачи'!$F$2:$F$9999="положена")*'[Журнал КДС.xlsm]Передачи'!$A$2:$A$9999;0));"не получал")

Но так как компьютер довольно слабый а строк в Картотеке >14 тыс. то наблюдаются довольно таки сильные тормоза при заполнении журнала. Может подскажете хотябы пример как то что делает формула реализовать макросом , разово выполнить - заполнить колонку.

Автор - AlexOD
Дата добавления - 09.10.2021 в 21:37
NikitaDvorets Дата: Среда, 20.10.2021, 17:34 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 364
Репутация: 65 ±
Замечаний: 0% ±

Excel 2019
AlexOD, добрый день!
Просьба уточнить формулу:
Цитата
=ЕСЛИ(МАКС(ИНДЕКС(('[Журнал КДС.xlsm]Передачи'!$L$2:$L$9999=CB22)*('[Журнал КДС.xlsm]Передачи'!$F$2:$F$9999="положена")*'[Журнал КДС.xlsm]Передачи'!$A$2:$A$9999;0));МАКС(ИНДЕКС(('[Журнал КДС.xlsm]Передачи'!$L$2:$L$9999=CB22)*('[Журнал КДС.xlsm]Передачи'!$F$2:$F$9999="положена")*'[Журнал КДС.xlsm]Передачи'!$A$2:$A$9999;0));"не получал")


Готов разработать пример макроса, если Вы пришлете 2 файла, в одном из которых будет поисковая формула.


Сообщение отредактировал NikitaDvorets - Среда, 20.10.2021, 17:54
 
Ответить
СообщениеAlexOD, добрый день!
Просьба уточнить формулу:
Цитата
=ЕСЛИ(МАКС(ИНДЕКС(('[Журнал КДС.xlsm]Передачи'!$L$2:$L$9999=CB22)*('[Журнал КДС.xlsm]Передачи'!$F$2:$F$9999="положена")*'[Журнал КДС.xlsm]Передачи'!$A$2:$A$9999;0));МАКС(ИНДЕКС(('[Журнал КДС.xlsm]Передачи'!$L$2:$L$9999=CB22)*('[Журнал КДС.xlsm]Передачи'!$F$2:$F$9999="положена")*'[Журнал КДС.xlsm]Передачи'!$A$2:$A$9999;0));"не получал")


Готов разработать пример макроса, если Вы пришлете 2 файла, в одном из которых будет поисковая формула.

Автор - NikitaDvorets
Дата добавления - 20.10.2021 в 17:34
Kuzmich Дата: Среда, 20.10.2021, 18:27 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 682
Репутация: 150 ±
Замечаний: 0% ±

Excel 2003
Цитата
Готов разработать пример макроса,

NikitaDvorets
Уже разработан
https://www.planetaexcel.ru/forum....=144037
 
Ответить
Сообщение
Цитата
Готов разработать пример макроса,

NikitaDvorets
Уже разработан
https://www.planetaexcel.ru/forum....=144037

Автор - Kuzmich
Дата добавления - 20.10.2021 в 18:27
NikitaDvorets Дата: Среда, 20.10.2021, 22:27 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 364
Репутация: 65 ±
Замечаний: 0% ±

Excel 2019
Kuzmich, благодарю за комментарий :-)
 
Ответить
СообщениеKuzmich, благодарю за комментарий :-)

Автор - NikitaDvorets
Дата добавления - 20.10.2021 в 22:27
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Заполнение колонки в таблице данными из другой по условию (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!