Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Приращение числа в формуле - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Приращение числа в формуле (Макросы/Sub)
Приращение числа в формуле
Pro_ex Дата: Воскресенье, 09.01.2022, 12:32 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте.
Подскажите пожалуйста как сделать приращения числа в формуле, чтобы протянув вниз в каждой ячейке число увеличивалось 1.5555 ; 1.5556; 1.5557; 1.5558 и т.д.
Код
=СУММЕСЛИМН(D2:D20;C2:C20;1,5555)
К сообщению приложен файл: 1236145.xlsx(9.1 Kb)
 
Ответить
СообщениеЗдравствуйте.
Подскажите пожалуйста как сделать приращения числа в формуле, чтобы протянув вниз в каждой ячейке число увеличивалось 1.5555 ; 1.5556; 1.5557; 1.5558 и т.д.
Код
=СУММЕСЛИМН(D2:D20;C2:C20;1,5555)

Автор - Pro_ex
Дата добавления - 09.01.2022 в 12:32
Nic70y Дата: Воскресенье, 09.01.2022, 12:44 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7731
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
так
Код
=СУММЕСЛИМН(D$2:D$20;C$2:C$20;1,5555+(СТРОКА(I1)-1)/10000)
наверное


ЮMoney 41001841029809
 
Ответить
Сообщениетак
Код
=СУММЕСЛИМН(D$2:D$20;C$2:C$20;1,5555+(СТРОКА(I1)-1)/10000)
наверное

Автор - Nic70y
Дата добавления - 09.01.2022 в 12:44
Pro_ex Дата: Воскресенье, 09.01.2022, 12:48 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007


Отлично, благодарю Nic70y!

А как сделать чтобы было по уменьшению 1,5555; 1,5554; 1,5553.... и протянуть вверх теперь? Думал сам поменяю плюс на минус. Но вверх тяну не работает.


Сообщение отредактировал Pro_ex - Воскресенье, 09.01.2022, 13:01
 
Ответить
Сообщение

Отлично, благодарю Nic70y!

А как сделать чтобы было по уменьшению 1,5555; 1,5554; 1,5553.... и протянуть вверх теперь? Думал сам поменяю плюс на минус. Но вверх тяну не работает.

Автор - Pro_ex
Дата добавления - 09.01.2022 в 12:48
bmv98rus Дата: Воскресенье, 09.01.2022, 14:10 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3944
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=-(ROWS(I$1:I1)-1)
естесвенно i1- это та ячейка в которой формула. по идее можно и знак задать автоматом
например для i11
Код
=SUMPRODUCT(D$2:D$20;C$2:C$20;1,5555+SIGN(ROW()-ROW($I$11))*(ROWS(I$11:I11)-1)/10000)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=-(ROWS(I$1:I1)-1)
естесвенно i1- это та ячейка в которой формула. по идее можно и знак задать автоматом
например для i11
Код
=SUMPRODUCT(D$2:D$20;C$2:C$20;1,5555+SIGN(ROW()-ROW($I$11))*(ROWS(I$11:I11)-1)/10000)

Автор - bmv98rus
Дата добавления - 09.01.2022 в 14:10
Pro_ex Дата: Воскресенье, 09.01.2022, 14:43 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
естесвенно i1- это та ячейка в которой формула


Спасибо bmv98rus!
 
Ответить
Сообщение
естесвенно i1- это та ячейка в которой формула


Спасибо bmv98rus!

Автор - Pro_ex
Дата добавления - 09.01.2022 в 14:43
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Приращение числа в формуле (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!