Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма каждой n-ой строки/столбца - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Сумма каждой n-ой строки/столбца (Макросы/Sub)
Сумма каждой n-ой строки/столбца
ZaraZa Дата: Суббота, 03.09.2022, 12:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Друзья, помогите разобраться, пожалуйста!
Есть такой макрос, найденный на просторах интернета:
[vba]
Код
Function SumIntervalRows(WorkRng As Range, interval As Integer) As Double
'Updateby Extendoffice
Dim arr As Variant
Dim total As Double
total = 0
arr = WorkRng.Value
For i = interval To UBound(arr, 1) Step interval
total = total + arr(i, 1)
Next
SumIntervalRows = total
End Function
[/vba]
[vba]
Код
Function SumIntervalCols(WorkRng As Range, interval As Integer) As Double
Dim arr As Variant
Dim total As Double
total = 0
arr = WorkRng.Value
For j = interval To UBound(arr, 2) Step interval
total = total + arr(1, j)
Next
SumIntervalCols = total
End Function
[/vba]
К сожалению, он не работает почему-то.
Мне очень нужен макрос, где можно указать, например, считать каждую вторую ячейку в столбце.
Помогите, очень прошу.
К сообщению приложен файл: 7289710.xlsx(15.5 Kb)


Сообщение отредактировал ZaraZa - Суббота, 03.09.2022, 17:34
 
Ответить
СообщениеДрузья, помогите разобраться, пожалуйста!
Есть такой макрос, найденный на просторах интернета:
[vba]
Код
Function SumIntervalRows(WorkRng As Range, interval As Integer) As Double
'Updateby Extendoffice
Dim arr As Variant
Dim total As Double
total = 0
arr = WorkRng.Value
For i = interval To UBound(arr, 1) Step interval
total = total + arr(i, 1)
Next
SumIntervalRows = total
End Function
[/vba]
[vba]
Код
Function SumIntervalCols(WorkRng As Range, interval As Integer) As Double
Dim arr As Variant
Dim total As Double
total = 0
arr = WorkRng.Value
For j = interval To UBound(arr, 2) Step interval
total = total + arr(1, j)
Next
SumIntervalCols = total
End Function
[/vba]
К сожалению, он не работает почему-то.
Мне очень нужен макрос, где можно указать, например, считать каждую вторую ячейку в столбце.
Помогите, очень прошу.

Автор - ZaraZa
Дата добавления - 03.09.2022 в 12:27
Pelena Дата: Суббота, 03.09.2022, 13:34 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18555
Репутация: 4202 ±
Замечаний: ±

Excel 2016 & Mac Excel
Обязательно макрос? Формулой не вариант?
Код
=СУММЕСЛИ($B$5:$B$28;"=";J$5:J$28)
К сообщению приложен файл: 6386429.xlsx(15.6 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеОбязательно макрос? Формулой не вариант?
Код
=СУММЕСЛИ($B$5:$B$28;"=";J$5:J$28)

Автор - Pelena
Дата добавления - 03.09.2022 в 13:34
ZaraZa Дата: Суббота, 03.09.2022, 14:09 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Спасибо большое! Но я хотела бы макрос. Чтобы вдруг надо будет каждую четвертую посчитать.
 
Ответить
СообщениеСпасибо большое! Но я хотела бы макрос. Чтобы вдруг надо будет каждую четвертую посчитать.

Автор - ZaraZa
Дата добавления - 03.09.2022 в 14:09
Pelena Дата: Суббота, 03.09.2022, 14:13 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 18555
Репутация: 4202 ±
Замечаний: ±

Excel 2016 & Mac Excel
UDF из первого поста тоже вроде работает
К сообщению приложен файл: 7289710.xlsm(21.3 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеUDF из первого поста тоже вроде работает

Автор - Pelena
Дата добавления - 03.09.2022 в 14:13
ZaraZa Дата: Суббота, 03.09.2022, 17:33 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

И у меня заработал!)) Волшебство какое-то...
Спасибо!
 
Ответить
СообщениеИ у меня заработал!)) Волшебство какое-то...
Спасибо!

Автор - ZaraZa
Дата добавления - 03.09.2022 в 17:33
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Сумма каждой n-ой строки/столбца (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!