Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проставить макросом цену на каждый лист. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Проставить макросом цену на каждый лист. (Макросы/Sub)
Проставить макросом цену на каждый лист.
Mark1976 Дата: Суббота, 09.03.2024, 19:32 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 738
Репутация: 3 ±
Замечаний: 0% ±

Excel 2010, 2013
Здравствуйте. Помогите с решением. Будет 100 листов (имена листов будут другие не как в примере). Есть лист "Цена". Необходимо быстро проставить на каждый лист цену в колонку H. Заранее спасибо за решение.
К сообщению приложен файл: raskhod.xlsx (27.5 Kb)


Сообщение отредактировал Mark1976 - Суббота, 09.03.2024, 19:43
 
Ответить
СообщениеЗдравствуйте. Помогите с решением. Будет 100 листов (имена листов будут другие не как в примере). Есть лист "Цена". Необходимо быстро проставить на каждый лист цену в колонку H. Заранее спасибо за решение.

Автор - Mark1976
Дата добавления - 09.03.2024 в 19:32
gling Дата: Суббота, 09.03.2024, 22:03 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2523
Репутация: 678 ±
Замечаний: 0% ±

2010
Здравствуйте.
Необходимо быстро проставить на каждый лист цену в колонку H
ПКМ по ярлычку любого листа -- Выделить все листы; Зажав Ctrl ЛКМ по ярлычку листа "Цена", в результате выделены все 100 листов. На любом из выделенных листов в ячейке H11 прописываете формулу
Код
=СУММЕСЛИМН(Цена!F:F;Цена!A:A;A11;Цена!B:B;B11;Цена!C:C;C11;Цена!D:D;D11)
протягиваете её до нужных пределов. Снимаете выделение листов. Если нет повторов названий соответствующих по четырем столбцам, то цены будут правильными, если есть дубликаты, то цены дубликатов ссумируются.


ЯД-41001506838083

Сообщение отредактировал gling - Суббота, 09.03.2024, 22:04
 
Ответить
СообщениеЗдравствуйте.
Необходимо быстро проставить на каждый лист цену в колонку H
ПКМ по ярлычку любого листа -- Выделить все листы; Зажав Ctrl ЛКМ по ярлычку листа "Цена", в результате выделены все 100 листов. На любом из выделенных листов в ячейке H11 прописываете формулу
Код
=СУММЕСЛИМН(Цена!F:F;Цена!A:A;A11;Цена!B:B;B11;Цена!C:C;C11;Цена!D:D;D11)
протягиваете её до нужных пределов. Снимаете выделение листов. Если нет повторов названий соответствующих по четырем столбцам, то цены будут правильными, если есть дубликаты, то цены дубликатов ссумируются.

Автор - gling
Дата добавления - 09.03.2024 в 22:03
Mark1976 Дата: Воскресенье, 10.03.2024, 07:39 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 738
Репутация: 3 ±
Замечаний: 0% ±

Excel 2010, 2013
gling, огромное, огромное спасибо. Формула работает, сумма считается.
 
Ответить
Сообщениеgling, огромное, огромное спасибо. Формула работает, сумма считается.

Автор - Mark1976
Дата добавления - 10.03.2024 в 07:39
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Проставить макросом цену на каждый лист. (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!