Домашняя страница Undo Do Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Упрощение формулы поиска и выбора значения. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вопросы по Excel для Mac » Упрощение формулы поиска и выбора значения.
Упрощение формулы поиска и выбора значения.
Ohtnik77 Дата: Четверг, 29.11.2018, 16:11 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте, жители форума!
Обращаюсь к вам за мудрым советом.
В примере книга Excel, состоящая из двух листов (да уж, книга :D ). На первом листе простенькая но длинная и громоздкая формула для поиска позиции и выбора значения. Вопрос: есть ли какие то варианты уменьшения этой формулы (количество значений больше чем в примере)?
Буду признателен!
К сообщению приложен файл: 0955722.xlsx(25.5 Kb)


Сообщение отредактировал Ohtnik77 - Четверг, 29.11.2018, 16:14
 
Ответить
СообщениеЗдравствуйте, жители форума!
Обращаюсь к вам за мудрым советом.
В примере книга Excel, состоящая из двух листов (да уж, книга :D ). На первом листе простенькая но длинная и громоздкая формула для поиска позиции и выбора значения. Вопрос: есть ли какие то варианты уменьшения этой формулы (количество значений больше чем в примере)?
Буду признателен!

Автор - Ohtnik77
Дата добавления - 29.11.2018 в 16:11
_Boroda_ Дата: Четверг, 29.11.2018, 16:24 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13660
Репутация: 5574 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно доптаблицу сделать, тогда так
Код
=ЕСЛИОШИБКА(ВПР(ВПР(A2;состав!A$2:B$99;2;);K$1:L$99;2;);"")

Или прямо в формуле прописывать
Код
=ЕСЛИОШИБКА(--ВПР(ВПР(A2;состав!A$2:B$99;2;);{14;"8:":2;"9:":8;"10:":16;"11:":6;"6:"};2;);"")
К сообщению приложен файл: 0955722_1.xlsx(23.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно доптаблицу сделать, тогда так
Код
=ЕСЛИОШИБКА(ВПР(ВПР(A2;состав!A$2:B$99;2;);K$1:L$99;2;);"")

Или прямо в формуле прописывать
Код
=ЕСЛИОШИБКА(--ВПР(ВПР(A2;состав!A$2:B$99;2;);{14;"8:":2;"9:":8;"10:":16;"11:":6;"6:"};2;);"")

Автор - _Boroda_
Дата добавления - 29.11.2018 в 16:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вопросы по Excel для Mac » Упрощение формулы поиска и выбора значения.
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!