Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как убрать "Н/Д" в формуле определения массы изделия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как убрать "Н/Д" в формуле определения массы изделия (Формулы/Formulas)
Как убрать "Н/Д" в формуле определения массы изделия
ASM_0408 Дата: Вторник, 27.05.2014, 21:26 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 221
Репутация: 0 ±
Замечаний: 0% ±

2016
Доброго времени суток. Подскажите пожалуйста как избавится от "Н/Д" в формуле [/spoiler]=ЕСЛИ(ЕНД(ВПР(A441;'Цена металла'!$B$3:$E$116;4))="м.п";"м.п";ВПР(A441;'Цена металла'!$B$3:$E$116;4;0))*K441*I441[spoiler]
 
Ответить
СообщениеДоброго времени суток. Подскажите пожалуйста как избавится от "Н/Д" в формуле [/spoiler]=ЕСЛИ(ЕНД(ВПР(A441;'Цена металла'!$B$3:$E$116;4))="м.п";"м.п";ВПР(A441;'Цена металла'!$B$3:$E$116;4;0))*K441*I441[spoiler]

Автор - ASM_0408
Дата добавления - 27.05.2014 в 21:26
mus013 Дата: Вторник, 27.05.2014, 21:35 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 102
Репутация: 25 ±
Замечаний: 0% ±

Excel 2007
Д вечер,могу поделиться собственным опытом-выделяю столбец-ставлю фильтр выбираю по "Н/Д"-удаляю-
копирую данные столбца значением. Удачи.


Помогать, действительно важно и нужно. «Может, это и не изменит мир, но точно изменит вас!»
 
Ответить
СообщениеД вечер,могу поделиться собственным опытом-выделяю столбец-ставлю фильтр выбираю по "Н/Д"-удаляю-
копирую данные столбца значением. Удачи.

Автор - mus013
Дата добавления - 27.05.2014 в 21:35
shurikus Дата: Вторник, 27.05.2014, 21:35 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 44 ±
Замечаний: 0% ±

Excel 2007
А может эта ошибка что-нибудь полезное указывает???
Если нет, то поставьте:
Код
=ЕСЛИОШИБКА(ЕСЛИ(ЕНД(ВПР(A441;'Цена металла'!$B$3:$E$116;4))="м.п";"м.п";ВПР(A441;'Цена металла'!$B$3:$E$116;4;0))*K441*I441;"")
 
Ответить
СообщениеА может эта ошибка что-нибудь полезное указывает???
Если нет, то поставьте:
Код
=ЕСЛИОШИБКА(ЕСЛИ(ЕНД(ВПР(A441;'Цена металла'!$B$3:$E$116;4))="м.п";"м.п";ВПР(A441;'Цена металла'!$B$3:$E$116;4;0))*K441*I441;"")

Автор - shurikus
Дата добавления - 27.05.2014 в 21:35
AlexM Дата: Вторник, 27.05.2014, 21:51 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4231
Репутация: 1043 ±
Замечаний: 0% ±

Excel 2003
Мне кажется, то вы потеряли нолик в формуле. попробуйте так
Код
=ЕСЛИ(ЕНД(ВПР(A441;'Цена металла'!$B$3:$E$116;4;0))="м.п";"м.п";ВПР(A441;'Цена металла'!$B$3:$E$116;4;0))*K441*I441

Точнее можно сказать при наличии файла



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Вторник, 27.05.2014, 21:53
 
Ответить
СообщениеМне кажется, то вы потеряли нолик в формуле. попробуйте так
Код
=ЕСЛИ(ЕНД(ВПР(A441;'Цена металла'!$B$3:$E$116;4;0))="м.п";"м.п";ВПР(A441;'Цена металла'!$B$3:$E$116;4;0))*K441*I441

Точнее можно сказать при наличии файла

Автор - AlexM
Дата добавления - 27.05.2014 в 21:51
ASM_0408 Дата: Вторник, 27.05.2014, 22:22 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 221
Репутация: 0 ±
Замечаний: 0% ±

2016
Всем спасибо! Сам так и не добил. Суть в следующем при наличии значения в столбце I это надо перемножить на столбец K и столбец Е листа Цена металла событие должно происходить при значении столбца M м2, при значении м.п. перемножаются столбцы J и K и столбец Е листа Цена металла.
К сообщению приложен файл: 3791800.xlsx(72.7 Kb)
 
Ответить
СообщениеВсем спасибо! Сам так и не добил. Суть в следующем при наличии значения в столбце I это надо перемножить на столбец K и столбец Е листа Цена металла событие должно происходить при значении столбца M м2, при значении м.п. перемножаются столбцы J и K и столбец Е листа Цена металла.

Автор - ASM_0408
Дата добавления - 27.05.2014 в 22:22
AlexM Дата: Вторник, 27.05.2014, 22:43 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4231
Репутация: 1043 ±
Замечаний: 0% ±

Excel 2003
У меня конвертер не преобразует ваш файл в формат xls



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеУ меня конвертер не преобразует ваш файл в формат xls

Автор - AlexM
Дата добавления - 27.05.2014 в 22:43
ASM_0408 Дата: Вторник, 27.05.2014, 22:51 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 221
Репутация: 0 ±
Замечаний: 0% ±

2016
Блин файл не сжимается до 100кб.
 
Ответить
СообщениеБлин файл не сжимается до 100кб.

Автор - ASM_0408
Дата добавления - 27.05.2014 в 22:51
shurikus Дата: Вторник, 27.05.2014, 23:04 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 44 ±
Замечаний: 0% ±

Excel 2007
Не совсем понял зачем в вашей формуле искать "м.п." в столбце Е листа "цена металла":
ЕСЛИ(ЕНД(ВПР(A441;'Цена металла'!$B$3:$E$116;4))="м.п"
- его там физически не видно.
Еще вопрос по тому, где в столбце М значение м2:
при значении столбца M м2

Но вдруг пойдет такая формула:
Код
=ЕСЛИ(I441<>"";ЕСЛИ(F441="м2";I441*ВПР(A441;'Цена металла'!$B$3:$H$107;4;0);ЕСЛИ(F441="м.п.";J441*K441*ВПР(A441;'Цена металла'!$B$3:$H$107;4;0);));)
 
Ответить
СообщениеНе совсем понял зачем в вашей формуле искать "м.п." в столбце Е листа "цена металла":
ЕСЛИ(ЕНД(ВПР(A441;'Цена металла'!$B$3:$E$116;4))="м.п"
- его там физически не видно.
Еще вопрос по тому, где в столбце М значение м2:
при значении столбца M м2

Но вдруг пойдет такая формула:
Код
=ЕСЛИ(I441<>"";ЕСЛИ(F441="м2";I441*ВПР(A441;'Цена металла'!$B$3:$H$107;4;0);ЕСЛИ(F441="м.п.";J441*K441*ВПР(A441;'Цена металла'!$B$3:$H$107;4;0);));)

Автор - shurikus
Дата добавления - 27.05.2014 в 23:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как убрать "Н/Д" в формуле определения массы изделия (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!