Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/функция ЕСЛИ с датами - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » функция ЕСЛИ с датами (функция ЕСЛИ с датами)
функция ЕСЛИ с датами
Uralan Дата: Вторник, 10.07.2012, 12:22 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

добрый день! Не могу найти ответ на этот вопрос. Хочу использовать функцию ЕСЛИ применительно к датам. Хочу вот так: если дата, которую вводит пользователь в определенную ячейку, лето, то использовать один коэффициент, если осень другой и т. д. Помогите, пожалуйста!
 
Ответить
Сообщениедобрый день! Не могу найти ответ на этот вопрос. Хочу использовать функцию ЕСЛИ применительно к датам. Хочу вот так: если дата, которую вводит пользователь в определенную ячейку, лето, то использовать один коэффициент, если осень другой и т. д. Помогите, пожалуйста!

Автор - Uralan
Дата добавления - 10.07.2012 в 12:22
Serge_007 Дата: Вторник, 10.07.2012, 12:35 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14465
Репутация: 2384 ±
Замечаний: ±

Excel 2010
Тупо "в лоб":
[vba]
Code
=ВПР(МЕСЯЦ(A1);{0;"k зимы":3;"k весны":6;"k лета":9;"k осени":12;"k зимы"};2)
[/vba]


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеТупо "в лоб":
[vba]
Code
=ВПР(МЕСЯЦ(A1);{0;"k зимы":3;"k весны":6;"k лета":9;"k осени":12;"k зимы"};2)
[/vba]

Автор - Serge_007
Дата добавления - 10.07.2012 в 12:35
Uralan Дата: Вторник, 10.07.2012, 13:00 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Serge_007, Спасибо!
 
Ответить
СообщениеSerge_007, Спасибо!

Автор - Uralan
Дата добавления - 10.07.2012 в 13:00
ВладимирG Дата: Вторник, 10.07.2012, 15:09 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 136
Репутация: 22 ±
Замечаний: 0% ±

2007
=Выбор(МЕСЯЦ(A1);"k зимы";"k зимы";"k весны";"k весны";"k весны";"k лета";"k лета";"k лета";"k осени";"k осени";"k осени";"k зимы")
 
Ответить
Сообщение=Выбор(МЕСЯЦ(A1);"k зимы";"k зимы";"k весны";"k весны";"k весны";"k лета";"k лета";"k лета";"k осени";"k осени";"k осени";"k зимы")

Автор - ВладимирG
Дата добавления - 10.07.2012 в 15:09
MCH Дата: Вторник, 10.07.2012, 19:49 | Сообщение № 5
Группа: Админы
Ранг: Старожил
Сообщений: 1969
Репутация: 737 ±
Замечаний: ±

=ВЫБОР(ОСТАТ(МЕСЯЦ(A12)/3;4)+1;"зима";"весна";"лето";"осень")
 
Ответить
Сообщение=ВЫБОР(ОСТАТ(МЕСЯЦ(A12)/3;4)+1;"зима";"весна";"лето";"осень")

Автор - MCH
Дата добавления - 10.07.2012 в 19:49
ВладимирG Дата: Вторник, 10.07.2012, 20:55 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 136
Репутация: 22 ±
Замечаний: 0% ±

2007
Да, =ОСТАТ(МЕСЯЦ(A1:A12)/3;4)+1 - шикарная комбинация
 
Ответить
СообщениеДа, =ОСТАТ(МЕСЯЦ(A1:A12)/3;4)+1 - шикарная комбинация

Автор - ВладимирG
Дата добавления - 10.07.2012 в 20:55
Serge_007 Дата: Вторник, 10.07.2012, 21:14 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 14465
Репутация: 2384 ±
Замечаний: ±

Excel 2010
Quote (ВладимирG)
шикарная комбинация

_Boroda_ тут как-то тоже что-то такое заковыристое выкладывал, не могу найти sad


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Quote (ВладимирG)
шикарная комбинация

_Boroda_ тут как-то тоже что-то такое заковыристое выкладывал, не могу найти sad

Автор - Serge_007
Дата добавления - 10.07.2012 в 21:14
elizarov_1973 Дата: Четверг, 13.09.2012, 23:14 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте. Помогите составить формулу с датами и функцией ЕСЛИ. Заранее спасибо.
К сообщению приложен файл: 8775836.xls(24.0 Kb)
 
Ответить
СообщениеЗдравствуйте. Помогите составить формулу с датами и функцией ЕСЛИ. Заранее спасибо.

Автор - elizarov_1973
Дата добавления - 13.09.2012 в 23:14
Pelena Дата: Четверг, 13.09.2012, 23:32 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 17873
Репутация: 4019 ±
Замечаний: ±

Excel 2016 & Mac Excel
Можно так
Code
=ЕСЛИ(A2="Б";0;(ОТБР(МЕСЯЦ(B2)/7)+1)&"//"&ОСТАТ(ГОД(B2);100))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеМожно так
Code
=ЕСЛИ(A2="Б";0;(ОТБР(МЕСЯЦ(B2)/7)+1)&"//"&ОСТАТ(ГОД(B2);100))

Автор - Pelena
Дата добавления - 13.09.2012 в 23:32
Serge_007 Дата: Четверг, 13.09.2012, 23:38 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 14465
Репутация: 2384 ±
Замечаний: ±

Excel 2010
Code
=ЕСЛИ(A2="а";(МЕСЯЦ(B2)>5)+1&"//"&ПРАВБ(ГОД(B2);2);"")

Ещё вариант:
Code
=ЕСЛИ(A2="а";(МЕСЯЦ(B2)>5)+1&"//"&ТЕКСТ(B2;"ГГ");0)
К сообщению приложен файл: elizarov_1973.xls(27.5 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Code
=ЕСЛИ(A2="а";(МЕСЯЦ(B2)>5)+1&"//"&ПРАВБ(ГОД(B2);2);"")

Ещё вариант:
Code
=ЕСЛИ(A2="а";(МЕСЯЦ(B2)>5)+1&"//"&ТЕКСТ(B2;"ГГ");0)

Автор - Serge_007
Дата добавления - 13.09.2012 в 23:38
elizarov_1973 Дата: Пятница, 14.09.2012, 19:21 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Serge_007, Огромное спасибо! Очень помогли.
 
Ответить
СообщениеSerge_007, Огромное спасибо! Очень помогли.

Автор - elizarov_1973
Дата добавления - 14.09.2012 в 19:21
Serg777s Дата: Четверг, 19.10.2017, 14:28 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Не подскажете, как лучше сделать?
Надо чтобы проставлялся коэффициент или текст события в зависимости от того, между какими датами в конкретном месяце находится это событие?
Более подробно показал в Примере.

и можно ли как-нибудь подсвечивать (выделять) весь столбец текущего месяца (тоже отобразил в Примере)?
К сообщению приложен файл: 2991881.xlsx(11.5 Kb)


Сообщение отредактировал Serg777s - Четверг, 19.10.2017, 14:28
 
Ответить
СообщениеНе подскажете, как лучше сделать?
Надо чтобы проставлялся коэффициент или текст события в зависимости от того, между какими датами в конкретном месяце находится это событие?
Более подробно показал в Примере.

и можно ли как-нибудь подсвечивать (выделять) весь столбец текущего месяца (тоже отобразил в Примере)?

Автор - Serg777s
Дата добавления - 19.10.2017 в 14:28
_Boroda_ Дата: Четверг, 19.10.2017, 14:36 | Сообщение № 13
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15979
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
- Прочитайте Правила форума
- Создайте свою тему согласно п.5q Правил форума


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение- Прочитайте Правила форума
- Создайте свою тему согласно п.5q Правил форума

Автор - _Boroda_
Дата добавления - 19.10.2017 в 14:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » функция ЕСЛИ с датами (функция ЕСЛИ с датами)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!