Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск конкретного слова из текста в ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск конкретного слова из текста в ячейке (Формулы/Formulas)
Поиск конкретного слова из текста в ячейке
Пытливый Дата: Пятница, 11.12.2015, 11:24 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 80% ±

Excel 2010
Здравствуйте.
Мне необходимо собрать формулу, которая:
- берет Ф.И.О человека (столбец 1),
- находит его должность (столбец 2),
- и если в его должности находит определенные слова (в 1 ячейке - 1 слово) выдает в ячейку "+ ретик", если слова не встречаются - оставляет ячейку пустой.
Код

=ЕСЛИ(ИЛИ(ВПР(A2;A:B;2;0)="Дефектоскопист";ВПР(A2;A:B;2;0)="Электрогазосварщик";ВПР(A2;A:B;2;0)="Электросварщик");"+ретик";"")


Нет формулы поиска слова в массиве.
К сообщению приложен файл: 8404991.xlsx(10.1 Kb)


Сообщение отредактировал Manyasha - Пятница, 11.12.2015, 11:51
 
Ответить
СообщениеЗдравствуйте.
Мне необходимо собрать формулу, которая:
- берет Ф.И.О человека (столбец 1),
- находит его должность (столбец 2),
- и если в его должности находит определенные слова (в 1 ячейке - 1 слово) выдает в ячейку "+ ретик", если слова не встречаются - оставляет ячейку пустой.
Код

=ЕСЛИ(ИЛИ(ВПР(A2;A:B;2;0)="Дефектоскопист";ВПР(A2;A:B;2;0)="Электрогазосварщик";ВПР(A2;A:B;2;0)="Электросварщик");"+ретик";"")


Нет формулы поиска слова в массиве.

Автор - Пытливый
Дата добавления - 11.12.2015 в 11:24
китин Дата: Пятница, 11.12.2015, 11:46 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5968
Репутация: 927 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
может так?только нужные слова надо вынести в отдельный столбец
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(1;--ЕЧИСЛО(ПОИСК($E$6:$E$8;B2));0));"";"+ретик")
формула массива
[p.s.]только не понял причем тут ФИО?
К сообщению приложен файл: primer.xlsx(10.4 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 11.12.2015, 11:48
 
Ответить
Сообщениеможет так?только нужные слова надо вынести в отдельный столбец
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(1;--ЕЧИСЛО(ПОИСК($E$6:$E$8;B2));0));"";"+ретик")
формула массива
[p.s.]только не понял причем тут ФИО?

Автор - китин
Дата добавления - 11.12.2015 в 11:46
YouGreed Дата: Пятница, 11.12.2015, 11:51 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 437
Репутация: 95 ±
Замечаний: 0% ±

Excel 2010
Пытливый, Так?
Код
=ЕСЛИ(СУММ(($E$5:$E$7=ПСТР(ВПР($A2;$A$2:$B$4;2;);1;НАЙТИ(" ";ВПР($A2;$A$2:$B$4;2;);1)-1))*СТРОКА($A2));"+ ретик";"-")

Откровенно, накидал туда, всякого всякого, можно попроще...
К сообщению приложен файл: ___.xlsx(9.8 Kb)
 
Ответить
СообщениеПытливый, Так?
Код
=ЕСЛИ(СУММ(($E$5:$E$7=ПСТР(ВПР($A2;$A$2:$B$4;2;);1;НАЙТИ(" ";ВПР($A2;$A$2:$B$4;2;);1)-1))*СТРОКА($A2));"+ ретик";"-")

Откровенно, накидал туда, всякого всякого, можно попроще...

Автор - YouGreed
Дата добавления - 11.12.2015 в 11:51
Пытливый Дата: Пятница, 11.12.2015, 11:59 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 80% ±

Excel 2010
китин,
Принцип работы очень нравится. Но можно без выноса? как-то в формуле прописать (документ итак забит до отказа).
 
Ответить
Сообщениекитин,
Принцип работы очень нравится. Но можно без выноса? как-то в формуле прописать (документ итак забит до отказа).

Автор - Пытливый
Дата добавления - 11.12.2015 в 11:59
Пытливый Дата: Пятница, 11.12.2015, 12:00 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 80% ±

Excel 2010
YouGreed,
Извини, формула хорошая но если слово не в начале предложения - сыпется.
 
Ответить
СообщениеYouGreed,
Извини, формула хорошая но если слово не в начале предложения - сыпется.

Автор - Пытливый
Дата добавления - 11.12.2015 в 12:00
китин Дата: Пятница, 11.12.2015, 12:03 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 5968
Репутация: 927 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Но можно без выноса?

легко
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(1;--ЕЧИСЛО(ПОИСК({"Дефектоскопист":"Электрогазосварщик":"Электросварщик"};B2));0));"";"+ретик")


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 11.12.2015, 12:04
 
Ответить
Сообщение
Но можно без выноса?

легко
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(1;--ЕЧИСЛО(ПОИСК({"Дефектоскопист":"Электрогазосварщик":"Электросварщик"};B2));0));"";"+ретик")

Автор - китин
Дата добавления - 11.12.2015 в 12:03
AlexM Дата: Пятница, 11.12.2015, 12:32 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3889
Репутация: 976 ±
Замечаний: 0% ±

Excel 2003
китин, зачем ПОИСКПОЗ()
Код
=ЕСЛИ(ИЛИ(ЕЧИСЛО(ПОИСК({"Дефектоскопист":"Электрогазосварщик":"Электросварщик"};B2)));"+ретик";"")
К сообщению приложен файл: 8404991_1.xls(25.5 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениекитин, зачем ПОИСКПОЗ()
Код
=ЕСЛИ(ИЛИ(ЕЧИСЛО(ПОИСК({"Дефектоскопист":"Электрогазосварщик":"Электросварщик"};B2)));"+ретик";"")

Автор - AlexM
Дата добавления - 11.12.2015 в 12:32
китин Дата: Пятница, 11.12.2015, 12:37 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 5968
Репутация: 927 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
AlexM, hands hands hands просто ПОИСК не работал, а до ИЛИ мозгов не хватило


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеAlexM, hands hands hands просто ПОИСК не работал, а до ИЛИ мозгов не хватило

Автор - китин
Дата добавления - 11.12.2015 в 12:37
AlexM Дата: Пятница, 11.12.2015, 12:39 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3889
Репутация: 976 ±
Замечаний: 0% ±

Excel 2003
Для уменьшения количества букв в формуле можно поэкспериментировать с массивом, например так
Код
{"ефект":"рогаз":"росва"}



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеДля уменьшения количества букв в формуле можно поэкспериментировать с массивом, например так
Код
{"ефект":"рогаз":"росва"}

Автор - AlexM
Дата добавления - 11.12.2015 в 12:39
Пытливый Дата: Пятница, 11.12.2015, 13:15 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 80% ±

Excel 2010
hands AlexM, китин,
Мужики спасибо!
Вы не совсем меня поняли:
мне нужна была формула, которая:
- берет Ф.И.О человека (столбец 1),
- находит его должность (столбец 2) и уже ПОТОМ...
Но с Вашей помощью у меня получилось!!!
[code]ЕСЛИ(ИЛИ(ЕЧИСЛО(ПОИСК({"Дефектоскопист":"Электрогазосварщик":"Электросварщик"};ВПР(A2;Лист1!A:B;2;0))));"+ретик";"")

Второй лист.
СПАСИБО!!!
К сообщению приложен файл: 3412031.xls(26.0 Kb)
 
Ответить
Сообщениеhands AlexM, китин,
Мужики спасибо!
Вы не совсем меня поняли:
мне нужна была формула, которая:
- берет Ф.И.О человека (столбец 1),
- находит его должность (столбец 2) и уже ПОТОМ...
Но с Вашей помощью у меня получилось!!!
[code]ЕСЛИ(ИЛИ(ЕЧИСЛО(ПОИСК({"Дефектоскопист":"Электрогазосварщик":"Электросварщик"};ВПР(A2;Лист1!A:B;2;0))));"+ретик";"")

Второй лист.
СПАСИБО!!!

Автор - Пытливый
Дата добавления - 11.12.2015 в 13:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск конкретного слова из текста в ячейке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!