Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/диапазон ячеек не лежащих рядом - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » диапазон ячеек не лежащих рядом (Формулы/Formulas)
диапазон ячеек не лежащих рядом
hatabtnt Дата: Вторник, 29.12.2015, 23:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Всем доброго времени суток.

Имеется таблица сотрудников

Хочу сделать снизу 2 строки в одной будет кол-во человек в ночной смене, в другой кол-во человек в дневной смене.

Пытался сделать через Счетесли, если верхняя ячейка дня каждого человека больше к примеру 18 то счет, но Эксель не воспринимается диапазон по отдельным ячейкам
(ставит их через " ; " и получается ошибка формулы).

Подскажите как возможно посчитать кол-во людей в дневной и ночной сменах (только без макросов).

Заранее благодарен.
[moder]Приложите пример в файле![/moder]


Сообщение отредактировал Manyasha - Вторник, 29.12.2015, 23:04
 
Ответить
СообщениеВсем доброго времени суток.

Имеется таблица сотрудников

Хочу сделать снизу 2 строки в одной будет кол-во человек в ночной смене, в другой кол-во человек в дневной смене.

Пытался сделать через Счетесли, если верхняя ячейка дня каждого человека больше к примеру 18 то счет, но Эксель не воспринимается диапазон по отдельным ячейкам
(ставит их через " ; " и получается ошибка формулы).

Подскажите как возможно посчитать кол-во людей в дневной и ночной сменах (только без макросов).

Заранее благодарен.
[moder]Приложите пример в файле![/moder]

Автор - hatabtnt
Дата добавления - 29.12.2015 в 23:02
Serge_007 Дата: Вторник, 29.12.2015, 23:06 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13145
Репутация: ±
Замечаний: ±

Excel 2010
hatabtnt, здравствуйте

кол-во человек в ночной смене, в другой кол-во человек в дневной смене
Как отличать дневную от ночной?

[p.s.]Почитайте правила форума, особенно п 3. Его несоблюдение приведет к вынесению Вам замечания[/p.s.]


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщениеhatabtnt, здравствуйте

кол-во человек в ночной смене, в другой кол-во человек в дневной смене
Как отличать дневную от ночной?

[p.s.]Почитайте правила форума, особенно п 3. Его несоблюдение приведет к вынесению Вам замечания[/p.s.]

Автор - Serge_007
Дата добавления - 29.12.2015 в 23:06
hatabtnt Дата: Среда, 30.12.2015, 21:46 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
ночная смена: верхняя ячейка 20 (начало работы) ячейка ниже 8 (конец работы) и нижняя ячейка 11 (длительность)


Сообщение отредактировал hatabtnt - Среда, 30.12.2015, 21:48
 
Ответить
Сообщениеночная смена: верхняя ячейка 20 (начало работы) ячейка ниже 8 (конец работы) и нижняя ячейка 11 (длительность)

Автор - hatabtnt
Дата добавления - 30.12.2015 в 21:46
ShAM Дата: Среда, 30.12.2015, 22:59 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1236
Репутация: 209 ±
Замечаний: 0% ±

Excel 2010
Почитайте правила форума, особенно п 3. Его несоблюдение приведет к вынесению Вам замечания

Цитата
Модератор:
Приложите пример в файле!
 
Ответить
Сообщение
Почитайте правила форума, особенно п 3. Его несоблюдение приведет к вынесению Вам замечания

Цитата
Модератор:
Приложите пример в файле!

Автор - ShAM
Дата добавления - 30.12.2015 в 22:59
Serge_007 Дата: Четверг, 31.12.2015, 00:16 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 13145
Репутация: ±
Замечаний: ±

Excel 2010
ночная смена: верхняя ячейка 20
Основываясь на этом принципе:
Код
=СУММПРОИЗВ(($A1:$A9<>"")*(B1:B9=20))




[p.s.]
Почитайте правила форума, особенно п 3. Его несоблюдение приведет к вынесению Вам замечания
Замечание вынес[/p.s.]
К сообщению приложен файл: 9150642.gif(28Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
ночная смена: верхняя ячейка 20
Основываясь на этом принципе:
Код
=СУММПРОИЗВ(($A1:$A9<>"")*(B1:B9=20))




[p.s.]
Почитайте правила форума, особенно п 3. Его несоблюдение приведет к вынесению Вам замечания
Замечание вынес[/p.s.]

Автор - Serge_007
Дата добавления - 31.12.2015 в 00:16
hatabtnt Дата: Воскресенье, 03.01.2016, 14:14 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
попробовал
=СУММ(($A1:$A9<>"")*(B1:B9=20))
выдает ошибку #знач
К сообщению приложен файл: 7170652.jpg(57Kb)
 
Ответить
Сообщениепопробовал
=СУММ(($A1:$A9<>"")*(B1:B9=20))
выдает ошибку #знач

Автор - hatabtnt
Дата добавления - 03.01.2016 в 14:14
buchlotnik Дата: Воскресенье, 03.01.2016, 14:43 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3005
Репутация: 839 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
hatabtnt, формулу массива вводят одновременным нажатием ctrl+shift+enter


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщениеhatabtnt, формулу массива вводят одновременным нажатием ctrl+shift+enter

Автор - buchlotnik
Дата добавления - 03.01.2016 в 14:43
hatabtnt Дата: Воскресенье, 03.01.2016, 16:49 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Вот файл пример
К сообщению приложен файл: 8350336.xlsx(19Kb)
 
Ответить
СообщениеВот файл пример

Автор - hatabtnt
Дата добавления - 03.01.2016 в 16:49
buchlotnik Дата: Воскресенье, 03.01.2016, 16:54 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3005
Репутация: 839 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
используйте массивный ввод + диапазоны должны быть одинакового размера
Код
=СУММ(($B1:$B18<>"")*(C1:C18=20))
К сообщению приложен файл: 0497851.xlsx(19Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщениеиспользуйте массивный ввод + диапазоны должны быть одинакового размера
Код
=СУММ(($B1:$B18<>"")*(C1:C18=20))

Автор - buchlotnik
Дата добавления - 03.01.2016 в 16:54
Udik Дата: Воскресенье, 03.01.2016, 17:22 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1588
Репутация: 191 ±
Замечаний: 0% ±

Excel 2016 х 64
или простая
Код
=СУММПРОИЗВ((C1:C18=20)*(ОСТАТ(СТРОКА(C1:C18);3)=1))
К сообщению приложен файл: 9341731.xlsx(22Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Воскресенье, 03.01.2016, 17:23
 
Ответить
Сообщениеили простая
Код
=СУММПРОИЗВ((C1:C18=20)*(ОСТАТ(СТРОКА(C1:C18);3)=1))

Автор - Udik
Дата добавления - 03.01.2016 в 17:22
hatabtnt Дата: Воскресенье, 03.01.2016, 17:55 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
всем большое спасибо
 
Ответить
Сообщениевсем большое спасибо

Автор - hatabtnt
Дата добавления - 03.01.2016 в 17:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » диапазон ячеек не лежащих рядом (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!