Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выпадающий список с выбором и зависимостью - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выпадающий список с выбором и зависимостью (Формулы/Formulas)
Выпадающий список с выбором и зависимостью
antipro Дата: Среда, 30.12.2015, 10:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Есть таблица с данными (во вложении) на новом листе нужно сделать так чтобы пользователь выбирал (или сам вводил) наименование города и в ответ получал всю информацию по данному городу с листа с данными.
К сообщению приложен файл: 6718150.xlsx(17Kb)


Сообщение отредактировал antipro - Среда, 30.12.2015, 10:48
 
Ответить
СообщениеЕсть таблица с данными (во вложении) на новом листе нужно сделать так чтобы пользователь выбирал (или сам вводил) наименование города и в ответ получал всю информацию по данному городу с листа с данными.

Автор - antipro
Дата добавления - 30.12.2015 в 10:46
Manyasha Дата: Среда, 30.12.2015, 11:00 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1990
Репутация: 819 ±
Замечаний: 0% ±

Excel 2010, 2016
antipro, так подойдет?
Код
=ЕСЛИОШИБКА(ИНДЕКС('Города бензин'!B$3:B$100;НАИМЕНЬШИЙ(ЕСЛИ('Города бензин'!$B$3:$B$100=Лист2!$C$1;СТРОКА('Города бензин'!$B$3:$B$100);"");СТРОКА(B1))-2);"")

формула массива
К сообщению приложен файл: 6718150-1.xlsx(21Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеantipro, так подойдет?
Код
=ЕСЛИОШИБКА(ИНДЕКС('Города бензин'!B$3:B$100;НАИМЕНЬШИЙ(ЕСЛИ('Города бензин'!$B$3:$B$100=Лист2!$C$1;СТРОКА('Города бензин'!$B$3:$B$100);"");СТРОКА(B1))-2);"")

формула массива

Автор - Manyasha
Дата добавления - 30.12.2015 в 11:00
antipro Дата: Среда, 30.12.2015, 11:21 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Почти то что нужно. Основная идея верная. Но нужно чуть больше.
Столбик А ввожу города, в остальные получаю данные.
Не могу понять что дают фигурные скобки.
P.S. Попробовал сам переписать формулу не получилось выругалась что слишком много аргументов.
[moder]Не нужно цитировать посты целиком - это нарушение Правил форума[/moder]


Сообщение отредактировал Manyasha - Среда, 30.12.2015, 11:29
 
Ответить
СообщениеПочти то что нужно. Основная идея верная. Но нужно чуть больше.
Столбик А ввожу города, в остальные получаю данные.
Не могу понять что дают фигурные скобки.
P.S. Попробовал сам переписать формулу не получилось выругалась что слишком много аргументов.
[moder]Не нужно цитировать посты целиком - это нарушение Правил форума[/moder]

Автор - antipro
Дата добавления - 30.12.2015 в 11:21
Manyasha Дата: Среда, 30.12.2015, 11:32 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1990
Репутация: 819 ±
Замечаний: 0% ±

Excel 2010, 2016
Так у Вас для 1 города может быть несколько строчек...
Нарисуйте в файле, как должен выглядеть результат на примере 2-3 городов.
что дают фигурные скобки

формула массива

Вводить сочетанием ctrl+shift+enter


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеТак у Вас для 1 города может быть несколько строчек...
Нарисуйте в файле, как должен выглядеть результат на примере 2-3 городов.
что дают фигурные скобки

формула массива

Вводить сочетанием ctrl+shift+enter

Автор - Manyasha
Дата добавления - 30.12.2015 в 11:32
buchlotnik Дата: Среда, 30.12.2015, 11:33 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3113
Репутация: 853 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
можно и сводную собрать со срезом
К сообщению приложен файл: 6718150-1-.xlsx(25Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 30.12.2015, 11:33
 
Ответить
Сообщениеможно и сводную собрать со срезом

Автор - buchlotnik
Дата добавления - 30.12.2015 в 11:33
antipro Дата: Среда, 30.12.2015, 11:57 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
можно и сводную собрать со срезом

Да то что хотел, но как быть если надо город повторно выбрать после какого-то города?

Так у Вас для 1 города может быть несколько строчек...

Извиняюсь есть косяк. То что ваш коллега реализовал, но на вашей базе с ручным вводом городом хочется увидеть.

В итоге получится таблица что доехать от такого то города до такого-то будет стоить столько-то, по ценам города отправления.


Сообщение отредактировал antipro - Среда, 30.12.2015, 14:13
 
Ответить
Сообщение
можно и сводную собрать со срезом

Да то что хотел, но как быть если надо город повторно выбрать после какого-то города?

Так у Вас для 1 города может быть несколько строчек...

Извиняюсь есть косяк. То что ваш коллега реализовал, но на вашей базе с ручным вводом городом хочется увидеть.

В итоге получится таблица что доехать от такого то города до такого-то будет стоить столько-то, по ценам города отправления.

Автор - antipro
Дата добавления - 30.12.2015 в 11:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выпадающий список с выбором и зависимостью (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!