Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка данных по двум условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка данных по двум условиям (Формулы/Formulas)
Выборка данных по двум условиям
skov Дата: Вторник, 05.01.2016, 14:37 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте. Есть обновляемая база данных. Необходимо в соседней таблице отследить изменения, нужно видеть только актуальные данные из базы. В базе могут изменяться не все ячейки, в этом случае пустые ячейки не должны обнулять предыдущие данные. В последнем столбце "История", хотелось бы сцепить все записи по позиции из столбца "Примечание".
К сообщению приложен файл: 7757827.xlsx(12Kb)
 
Ответить
СообщениеЗдравствуйте. Есть обновляемая база данных. Необходимо в соседней таблице отследить изменения, нужно видеть только актуальные данные из базы. В базе могут изменяться не все ячейки, в этом случае пустые ячейки не должны обнулять предыдущие данные. В последнем столбце "История", хотелось бы сцепить все записи по позиции из столбца "Примечание".

Автор - skov
Дата добавления - 05.01.2016 в 14:37
Udik Дата: Вторник, 05.01.2016, 15:15 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1297
Репутация: 161 ±
Замечаний: 0% ±

Excel 2013
Для двух столбцов
массивка Последнее обновление
Код
{=ЕСЛИ(МАКС(ЕСЛИ($D$5:$D$36=N5;$C$5:$C$36;""));МАКС(ЕСЛИ($D$5:$D$36=N5;$C$5:$C$36;""));"")}

и простая Объем
Код
=ЕСЛИ(O5="";"";ПРОСМОТР(;-1/($C$5:C34&$D$5:$D$36=O5&N5);$E$5:$E$36))


как в Историю вытянуть несколько строк формулой не знаю
К сообщению приложен файл: 5333166.xlsx(15Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
СообщениеДля двух столбцов
массивка Последнее обновление
Код
{=ЕСЛИ(МАКС(ЕСЛИ($D$5:$D$36=N5;$C$5:$C$36;""));МАКС(ЕСЛИ($D$5:$D$36=N5;$C$5:$C$36;""));"")}

и простая Объем
Код
=ЕСЛИ(O5="";"";ПРОСМОТР(;-1/($C$5:C34&$D$5:$D$36=O5&N5);$E$5:$E$36))


как в Историю вытянуть несколько строк формулой не знаю

Автор - Udik
Дата добавления - 05.01.2016 в 15:15
skov Дата: Вторник, 05.01.2016, 15:21 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо. Жаль что в Объеме обнулилось число пустой ячейкой
 
Ответить
СообщениеСпасибо. Жаль что в Объеме обнулилось число пустой ячейкой

Автор - skov
Дата добавления - 05.01.2016 в 15:21
Udik Дата: Вторник, 05.01.2016, 15:36 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1297
Репутация: 161 ±
Замечаний: 0% ±

Excel 2013
Раз пустая ячейка, значит объёма нет, значит 0, можно при желании изменить


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
СообщениеРаз пустая ячейка, значит объёма нет, значит 0, можно при желании изменить

Автор - Udik
Дата добавления - 05.01.2016 в 15:36
skov Дата: Вторник, 05.01.2016, 15:41 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Тут получается, что каждая новая запись в базе меняет информацию по строке. Если пустая ячейка, значит новых данных нет и ячейка в правой таблице не должна измениться
 
Ответить
СообщениеТут получается, что каждая новая запись в базе меняет информацию по строке. Если пустая ячейка, значит новых данных нет и ячейка в правой таблице не должна измениться

Автор - skov
Дата добавления - 05.01.2016 в 15:41
Udik Дата: Вторник, 05.01.2016, 15:58 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1297
Репутация: 161 ±
Замечаний: 0% ±

Excel 2013
Сейчас формула отлавливает последнюю по времени запись и выводит это время, а другая выводит объём в этой записи, если пусто выводит 0. Можно сделать, чтобы ячейка пустой казалась/оставалась (через формат ячейки или ЕСЛИ). А если надо, чтобы объём искался последний непустой, то менять формулу надо или на ВБА уходить :)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
СообщениеСейчас формула отлавливает последнюю по времени запись и выводит это время, а другая выводит объём в этой записи, если пусто выводит 0. Можно сделать, чтобы ячейка пустой казалась/оставалась (через формат ячейки или ЕСЛИ). А если надо, чтобы объём искался последний непустой, то менять формулу надо или на ВБА уходить :)

Автор - Udik
Дата добавления - 05.01.2016 в 15:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка данных по двум условиям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!