Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Транспонировать массив данных - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Транспонировать массив данных (Формулы/Formulas)
Транспонировать массив данных
DonPedro3x Дата: Четверг, 07.01.2016, 15:39 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый день, форумчане!

Вопрос такой. Есть массив данных. В этом массиве возраст указан по столбцам, а рассматриваемый год - по строкам.

Необходимо транспонировать данные, так чтобы для каждого региона возраст отображался по строкам, а рассматриваемый год - по столбцам.

Я сделал первый пример вручную через транспонирование. Как сделать так, чтобы не надо было 80 раз делать копи-паст с транспонированием, а можно было кодом.

Чтобы уместить в 100кб, оставил только первые пару регионов

Заранее спасибо большое!
К сообщению приложен файл: 8969229.xlsx(76Kb)


Сообщение отредактировал DonPedro3x - Четверг, 07.01.2016, 16:14
 
Ответить
СообщениеДобрый день, форумчане!

Вопрос такой. Есть массив данных. В этом массиве возраст указан по столбцам, а рассматриваемый год - по строкам.

Необходимо транспонировать данные, так чтобы для каждого региона возраст отображался по строкам, а рассматриваемый год - по столбцам.

Я сделал первый пример вручную через транспонирование. Как сделать так, чтобы не надо было 80 раз делать копи-паст с транспонированием, а можно было кодом.

Чтобы уместить в 100кб, оставил только первые пару регионов

Заранее спасибо большое!

Автор - DonPedro3x
Дата добавления - 07.01.2016 в 15:39
Hugo Дата: Четверг, 07.01.2016, 16:11 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2662
Репутация: 599 ±
Замечаний: 0% ±

Записали одно такое транспонирование макрорекордером - и в цикл его, творчески изменив диапазоны.


excel@nxt.ru
webmoney: E265281470651 R418926282008 Z422237915069
 
Ответить
СообщениеЗаписали одно такое транспонирование макрорекордером - и в цикл его, творчески изменив диапазоны.

Автор - Hugo
Дата добавления - 07.01.2016 в 16:11
Manyasha Дата: Четверг, 07.01.2016, 16:11 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1721
Репутация: 722 ±
Замечаний: 0% ±

Excel 2007, 2010
DonPedro3x, у меня не открывается файл...пишет, что поврежден.
Если нужен макрос, почему тему в этом разделе создали?
[p.s.]А функция ТРАНСП не подходит?


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеDonPedro3x, у меня не открывается файл...пишет, что поврежден.
Если нужен макрос, почему тему в этом разделе создали?
[p.s.]А функция ТРАНСП не подходит?

Автор - Manyasha
Дата добавления - 07.01.2016 в 16:11
DonPedro3x Дата: Четверг, 07.01.2016, 16:15 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Manyasha, я перекрепил файл.

Просто у меня таких листов 5. Транспонирование делать 5 раз по 80 долго.

Я думаю это кодом можно как-нибудь.
 
Ответить
СообщениеManyasha, я перекрепил файл.

Просто у меня таких листов 5. Транспонирование делать 5 раз по 80 долго.

Я думаю это кодом можно как-нибудь.

Автор - DonPedro3x
Дата добавления - 07.01.2016 в 16:15
_Boroda_ Дата: Четверг, 07.01.2016, 16:25 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9786
Репутация: 4135 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС($D$2:$AR$183;СТОЛБЕЦ(A12)+26*($AT12-1);$AV12-14)

Потом можно скопировать и вставить значениями
К сообщению приложен файл: 8969229_1.xlsx(82Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС($D$2:$AR$183;СТОЛБЕЦ(A12)+26*($AT12-1);$AV12-14)

Потом можно скопировать и вставить значениями

Автор - _Boroda_
Дата добавления - 07.01.2016 в 16:25
DonPedro3x Дата: Четверг, 07.01.2016, 17:42 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
_Boroda_, супер. То что надо. Спасибо большое!
 
Ответить
Сообщение_Boroda_, супер. То что надо. Спасибо большое!

Автор - DonPedro3x
Дата добавления - 07.01.2016 в 17:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Транспонировать массив данных (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!