Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/если текст, то сцепить - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » если текст, то сцепить (Формулы/Formulas)
если текст, то сцепить
KostyanBr Дата: Четверг, 07.01.2016, 22:03 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Помогите составить формулу.
есть файл в csv
нужно подставить текст в те колонки в которых присутствует текст, т.е. должно получиться так:

в идеале лучше вот так:

заранее спасибо.
К сообщению приложен файл: 111.csv(0Kb)
 
Ответить
СообщениеПомогите составить формулу.
есть файл в csv
нужно подставить текст в те колонки в которых присутствует текст, т.е. должно получиться так:

в идеале лучше вот так:

заранее спасибо.

Автор - KostyanBr
Дата добавления - 07.01.2016 в 22:03
_Boroda_ Дата: Четверг, 07.01.2016, 22:14 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
="Фото/"&A2&ЕСЛИ(B2="";"";", Фото/"&B2&ЕСЛИ(C2="";"";", Фото/"&C2&ЕСЛИ(D2="";"";", Фото/"&D2)))

При сохранении в csv формула преобразуется в значение
К сообщению приложен файл: 111_12.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
="Фото/"&A2&ЕСЛИ(B2="";"";", Фото/"&B2&ЕСЛИ(C2="";"";", Фото/"&C2&ЕСЛИ(D2="";"";", Фото/"&D2)))

При сохранении в csv формула преобразуется в значение

Автор - _Boroda_
Дата добавления - 07.01.2016 в 22:14
KostyanBr Дата: Четверг, 07.01.2016, 22:26 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Так нужно?

да, идеально. Только если как сделать чтоб вообще ни чего не подставлялось если нет не в одной колонке ничего
 
Ответить
Сообщение
Так нужно?

да, идеально. Только если как сделать чтоб вообще ни чего не подставлялось если нет не в одной колонке ничего

Автор - KostyanBr
Дата добавления - 07.01.2016 в 22:26
_Boroda_ Дата: Четверг, 07.01.2016, 22:33 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Аналогично. Только добавляем ЕСЛИ и в первую ссылку
Код
=ЕСЛИ(A2="";"";"Фото/"&A2&ЕСЛИ(B2="";"";", Фото/"&B2&ЕСЛИ(C2="";"";", Фото/"&C2&ЕСЛИ(D2="";"";", Фото/"&D2))))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеАналогично. Только добавляем ЕСЛИ и в первую ссылку
Код
=ЕСЛИ(A2="";"";"Фото/"&A2&ЕСЛИ(B2="";"";", Фото/"&B2&ЕСЛИ(C2="";"";", Фото/"&C2&ЕСЛИ(D2="";"";", Фото/"&D2))))

Автор - _Boroda_
Дата добавления - 07.01.2016 в 22:33
KostyanBr Дата: Четверг, 07.01.2016, 22:39 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Отлично. Спасибо.
 
Ответить
СообщениеОтлично. Спасибо.

Автор - KostyanBr
Дата добавления - 07.01.2016 в 22:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » если текст, то сцепить (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!