Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск совпадений в диапазоне с дополнительной проверкой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск совпадений в диапазоне с дополнительной проверкой (Формулы/Formulas)
Поиск совпадений в диапазоне с дополнительной проверкой
w00t Дата: Четверг, 07.01.2016, 23:05 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 126
Репутация: 3 ±
Замечаний: 0% ±

Во вложении пример.
Столбцы I, J, K, L - это то, что должно быть в итоге.
Проверить на точное совпадение довольно просто (см. формулу в B22 и ниже). Вывести позицию так же легко для точного совпадения (см. J3).

Что пытаюсь сделать: сцепка Город и ФИО во второй таблице должны совпасть со сцепкой Город+ФИО в первой таблице. Если точное совпадение есть - то пишем Ok и указываем позицию (берем из первой). Если совпадения нет по Город+ФИО, то делаем дополнительную проверку. Вдруг из второй таблицы какое-то ФИО совпадает с ФИО из первой таблицы. Если совпало, но во второй таблице один город для него указан, а в первой другой - то это не есть хорошо, ставим Wrong и указываем позицию. Если ФИО такого совсем не нашлось в первой таблице - не пишем ничего.

Интересует усложнение формулы без утяжеления расчетов в случае огромного количества строк. В частности, чтобы все было так, как сейчас есть в I:L по условию выше.
К сообщению приложен файл: 7717540.xlsx(15Kb)
 
Ответить
СообщениеВо вложении пример.
Столбцы I, J, K, L - это то, что должно быть в итоге.
Проверить на точное совпадение довольно просто (см. формулу в B22 и ниже). Вывести позицию так же легко для точного совпадения (см. J3).

Что пытаюсь сделать: сцепка Город и ФИО во второй таблице должны совпасть со сцепкой Город+ФИО в первой таблице. Если точное совпадение есть - то пишем Ok и указываем позицию (берем из первой). Если совпадения нет по Город+ФИО, то делаем дополнительную проверку. Вдруг из второй таблицы какое-то ФИО совпадает с ФИО из первой таблицы. Если совпало, но во второй таблице один город для него указан, а в первой другой - то это не есть хорошо, ставим Wrong и указываем позицию. Если ФИО такого совсем не нашлось в первой таблице - не пишем ничего.

Интересует усложнение формулы без утяжеления расчетов в случае огромного количества строк. В частности, чтобы все было так, как сейчас есть в I:L по условию выше.

Автор - w00t
Дата добавления - 07.01.2016 в 23:05
_Boroda_ Дата: Пятница, 08.01.2016, 01:01 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9828
Репутация: 4151 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(M3;D$3:D$17;));"Ok";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(G3;B$3:B$17;));"Wrong";""))

Код
=ЕСЛИОШИБКА(ИНДЕКС(C$3:C$17;ПОИСКПОЗ(M3;D$3:D$17;));ЕСЛИОШИБКА(ИНДЕКС(C$3:C$17;ПОИСКПОЗ(G3;B$3:B$17;));""))
К сообщению приложен файл: 7717540_1.xlsx(15Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(M3;D$3:D$17;));"Ok";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(G3;B$3:B$17;));"Wrong";""))

Код
=ЕСЛИОШИБКА(ИНДЕКС(C$3:C$17;ПОИСКПОЗ(M3;D$3:D$17;));ЕСЛИОШИБКА(ИНДЕКС(C$3:C$17;ПОИСКПОЗ(G3;B$3:B$17;));""))

Автор - _Boroda_
Дата добавления - 08.01.2016 в 01:01
w00t Дата: Пятница, 08.01.2016, 01:17 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 126
Репутация: 3 ±
Замечаний: 0% ±

Да, то что нужно, спасибо.
 
Ответить
СообщениеДа, то что нужно, спасибо.

Автор - w00t
Дата добавления - 08.01.2016 в 01:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск совпадений в диапазоне с дополнительной проверкой (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!