Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическое формирование таблиц - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое формирование таблиц (Формулы/Formulas)
Автоматическое формирование таблиц
TerryUndersen Дата: Понедельник, 11.01.2016, 17:45 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день. уважаемый форум.

Возник вопрос с автоматическим формированием таблиц со связями.

Листы "5.Анализ_осн.материалов", "6.Анализ_объемов". создаются вручную из "3.ВО"

Лист "7.Заявка_на_материалы" создается вручную из "5.Анализ_осн.материалов".

Дело в том, что лист "3.ВО" подвергается периодическим изменениям, и всегда отследить изменение других листов проблематично. случаются ошибки связанные с "ЧФ".

"5.Анализ_осн.материалов" формируется по критерию "м" в столбце "А"

"6.Анализ_объемов" формируется по критерию "Ч.Ч" в столбце "А"

"7.Заявка_на_материалы" формируется как таблица с уникальными значениями листа "5.Анализ_осн.материалов" %)

Существует ли способ решить данную задачу, при помощи функции? или без VBA не обойтись?
К сообщению приложен файл: 144-10-.xlsx(80Kb)
 
Ответить
СообщениеДобрый день. уважаемый форум.

Возник вопрос с автоматическим формированием таблиц со связями.

Листы "5.Анализ_осн.материалов", "6.Анализ_объемов". создаются вручную из "3.ВО"

Лист "7.Заявка_на_материалы" создается вручную из "5.Анализ_осн.материалов".

Дело в том, что лист "3.ВО" подвергается периодическим изменениям, и всегда отследить изменение других листов проблематично. случаются ошибки связанные с "ЧФ".

"5.Анализ_осн.материалов" формируется по критерию "м" в столбце "А"

"6.Анализ_объемов" формируется по критерию "Ч.Ч" в столбце "А"

"7.Заявка_на_материалы" формируется как таблица с уникальными значениями листа "5.Анализ_осн.материалов" %)

Существует ли способ решить данную задачу, при помощи функции? или без VBA не обойтись?

Автор - TerryUndersen
Дата добавления - 11.01.2016 в 17:45
китин Дата: Вторник, 12.01.2016, 08:00 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4094
Репутация: 632 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
проверяйте.
лист "5.Анализ_осн.материалов" формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС('3.ВО'!$B$12:$B$73;НАИМЕНЬШИЙ(ЕСЛИ('3.ВО'!$A$12:$A$73="м";СТРОКА('3.ВО'!$A$12:$A$73)-11);СТРОКА(A1)));"")
плюс ИНДЕКС с ПОИСКПОЗ
Лист "6.Анализ_объемов" обычный ВПР
Код
=ЕСЛИОШИБКА(ВПР($A17;'3.ВО'!$A$13:$K$73;2);"")

[p.s.] формулы в столбцах помеченные желтым. немного переделал шапки таблиц
К сообщению приложен файл: TerryUndersen.xlsx(91Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 12.01.2016, 08:00
 
Ответить
Сообщениепроверяйте.
лист "5.Анализ_осн.материалов" формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС('3.ВО'!$B$12:$B$73;НАИМЕНЬШИЙ(ЕСЛИ('3.ВО'!$A$12:$A$73="м";СТРОКА('3.ВО'!$A$12:$A$73)-11);СТРОКА(A1)));"")
плюс ИНДЕКС с ПОИСКПОЗ
Лист "6.Анализ_объемов" обычный ВПР
Код
=ЕСЛИОШИБКА(ВПР($A17;'3.ВО'!$A$13:$K$73;2);"")

[p.s.] формулы в столбцах помеченные желтым. немного переделал шапки таблиц

Автор - китин
Дата добавления - 12.01.2016 в 08:00
TerryUndersen Дата: Вторник, 12.01.2016, 09:27 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
hands Очень близкий вариант к необходимому. Спасибо

Лист "6.Анализ_объемов" обычный ВПР


Вот тут небольшой нюанс, хотелось бы чтоб он распознавал как в случае с листом "5.Анализ_осн.материалов" формат значения в столбце "А" листа "3.ВО" как "1,2,3..." и "1.1, 1.2, 1.3, 1.4..." а далее на основании их выкладывал этот диапазон из которого далее ВПРом вытягивались значения как в предложенном Вами варианте.
 
Ответить
Сообщениеhands Очень близкий вариант к необходимому. Спасибо

Лист "6.Анализ_объемов" обычный ВПР


Вот тут небольшой нюанс, хотелось бы чтоб он распознавал как в случае с листом "5.Анализ_осн.материалов" формат значения в столбце "А" листа "3.ВО" как "1,2,3..." и "1.1, 1.2, 1.3, 1.4..." а далее на основании их выкладывал этот диапазон из которого далее ВПРом вытягивались значения как в предложенном Вами варианте.

Автор - TerryUndersen
Дата добавления - 12.01.2016 в 09:27
китин Дата: Вторник, 12.01.2016, 10:28 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4094
Репутация: 632 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а так? формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС('3.ВО'!$B$12:$B$73;НАИМЕНЬШИЙ(ЕСЛИ(('3.ВО'!$A$12:$A$73<>"м")*('3.ВО'!$A$12:$A$73<>"");СТРОКА('3.ВО'!$A$12:$A$73)-11);СТРОКА(A1)));"")
К сообщению приложен файл: _TerryUndersen-.xlsx(93Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа так? формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС('3.ВО'!$B$12:$B$73;НАИМЕНЬШИЙ(ЕСЛИ(('3.ВО'!$A$12:$A$73<>"м")*('3.ВО'!$A$12:$A$73<>"");СТРОКА('3.ВО'!$A$12:$A$73)-11);СТРОКА(A1)));"")

Автор - китин
Дата добавления - 12.01.2016 в 10:28
TerryUndersen Дата: Вторник, 12.01.2016, 11:22 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
а так? формула массива


hands Спасибо большое. немного доработаю, но путь решения тот thumb
 
Ответить
Сообщение
а так? формула массива


hands Спасибо большое. немного доработаю, но путь решения тот thumb

Автор - TerryUndersen
Дата добавления - 12.01.2016 в 11:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое формирование таблиц (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!