Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск текста в одной ячейке и вывод результата в др - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск текста в одной ячейке и вывод результата в др (Формулы/Formulas)
Поиск текста в одной ячейке и вывод результата в др
anna1201 Дата: Вторник, 12.01.2016, 13:17 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте
Помогите, пожалуйста, составить формулу.
Задача такая:
В столбце В есть строчки, в которых есть название города из списка столбца А. Нужно найти такие строчки, и вынести в соседний столбец
К сообщению приложен файл: 6910779.xls(96Kb)
 
Ответить
СообщениеЗдравствуйте
Помогите, пожалуйста, составить формулу.
Задача такая:
В столбце В есть строчки, в которых есть название города из списка столбца А. Нужно найти такие строчки, и вынести в соседний столбец

Автор - anna1201
Дата добавления - 12.01.2016 в 13:17
_Boroda_ Дата: Вторник, 12.01.2016, 13:34 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9828
Репутация: 4151 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС(B$1:B$174;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ПОИСКПОЗ("*"&A$1:A$418&"*";B$1:B$174;);999);СТРОКА()))

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
Убрать ошибки
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$1:B$174;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ПОИСКПОЗ("*"&A$1:A$418&"*";B$1:B$174;);999);СТРОКА()));"")
К сообщению приложен файл: 6910779_1.xlsx(28Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС(B$1:B$174;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ПОИСКПОЗ("*"&A$1:A$418&"*";B$1:B$174;);999);СТРОКА()))

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
Убрать ошибки
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$1:B$174;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(ПОИСКПОЗ("*"&A$1:A$418&"*";B$1:B$174;);999);СТРОКА()));"")

Автор - _Boroda_
Дата добавления - 12.01.2016 в 13:34
SLAVICK Дата: Вторник, 12.01.2016, 13:37 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1924
Репутация: 650 ±
Замечаний: 0% ±

2007,2010,2013,2016
Так?: формула массива
Код
=ЕСЛИ(СУММПРОИЗВ(--ЕЧИСЛО(НАЙТИ($A$1:$A$418;B1;1)));ИНДЕКС($A$1:$A$418;МАКС(ЕСЛИ(--ЕЧИСЛО(НАЙТИ($A$1:$A$418;B1;1));СТРОКА($A$1:$A$418);0));1);"")
К сообщению приложен файл: 6910779.xlsx(36Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеТак?: формула массива
Код
=ЕСЛИ(СУММПРОИЗВ(--ЕЧИСЛО(НАЙТИ($A$1:$A$418;B1;1)));ИНДЕКС($A$1:$A$418;МАКС(ЕСЛИ(--ЕЧИСЛО(НАЙТИ($A$1:$A$418;B1;1));СТРОКА($A$1:$A$418);0));1);"")

Автор - SLAVICK
Дата добавления - 12.01.2016 в 13:37
anna1201 Дата: Вторник, 12.01.2016, 14:04 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Огромное спасибо! girl_smile
 
Ответить
СообщениеОгромное спасибо! girl_smile

Автор - anna1201
Дата добавления - 12.01.2016 в 14:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск текста в одной ячейке и вывод результата в др (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!