Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Упрощ. и оптимизация ежемесячного отчета, махинации с ВПР. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Упрощ. и оптимизация ежемесячного отчета, махинации с ВПР. (Формулы/Formulas)
Упрощ. и оптимизация ежемесячного отчета, махинации с ВПР.
Rodgerino Дата: Вторник, 12.01.2016, 19:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день!
Есть вот такой план+ежемесячный отчет. Все находится в одном файле. раньше в ручную все заносили по каждому объекту а при добавлении новых адресов приходилось все перебирать и переносить. Сейчас решил упростить на сколько это возможно.
Адресов в 5-6 раз больше чем представлено в файле. Листы которые необходимы для отчета и выделены зеленым. Остальное это просто информация, которая сортируется, фильтруется и т.д.
Вопросы:
1. Как можно упростить файл? Там ведь будут данные за 12 месяцев
2. кроме ВПР что можно использовать?
3. формулу каждой ячейки ВПР приходится подбивать под каждое ее местоположение. То есть приходится номер столбца менять в зависимости от месяца (во вкладке "все данные" в ВПР месяц надо выбирать для каждой вкладки)

Огромное всем спасибо!
К сообщению приложен файл: ---.xlsx(74Kb)
 
Ответить
СообщениеДобрый день!
Есть вот такой план+ежемесячный отчет. Все находится в одном файле. раньше в ручную все заносили по каждому объекту а при добавлении новых адресов приходилось все перебирать и переносить. Сейчас решил упростить на сколько это возможно.
Адресов в 5-6 раз больше чем представлено в файле. Листы которые необходимы для отчета и выделены зеленым. Остальное это просто информация, которая сортируется, фильтруется и т.д.
Вопросы:
1. Как можно упростить файл? Там ведь будут данные за 12 месяцев
2. кроме ВПР что можно использовать?
3. формулу каждой ячейки ВПР приходится подбивать под каждое ее местоположение. То есть приходится номер столбца менять в зависимости от месяца (во вкладке "все данные" в ВПР месяц надо выбирать для каждой вкладки)

Огромное всем спасибо!

Автор - Rodgerino
Дата добавления - 12.01.2016 в 19:02
Nic70y Дата: Вторник, 12.01.2016, 19:14 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4124
Репутация: 881 ±
Замечаний: 0% ±

Excel 2013
То есть приходится номер столбца менять в зависимости от месяца
как вариант в ОСНОВНОЙ ОТЧЕТ:
Код
=ЕСЛИОШИБКА(ВПР($A4;'все данные'!$A:$Y;ПОИСКПОЗ(B$2;'все данные'!$1:$1;););0)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Вторник, 12.01.2016, 19:15
 
Ответить
Сообщение
То есть приходится номер столбца менять в зависимости от месяца
как вариант в ОСНОВНОЙ ОТЧЕТ:
Код
=ЕСЛИОШИБКА(ВПР($A4;'все данные'!$A:$Y;ПОИСКПОЗ(B$2;'все данные'!$1:$1;););0)

Автор - Nic70y
Дата добавления - 12.01.2016 в 19:14
_Boroda_ Дата: Вторник, 12.01.2016, 20:07 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Лист "Все данные". Если в А прямые ссылки, то зачем в В ВПР?
Переписал в В тоже прямвми ссылками и переписал там ВПР, чтобы можно было растягивать его вправо
Код
=ЕСЛИОШИБКА(ВПР($A3;ДВССЫЛ(ЕСЛИ(C$1="";B$1;C$1)&"!$B2:$G999");2+(C$2="сумма")*4;0);)

Лист "Основной отчет" формулу переписал так
Код
=ЕСЛИОШИБКА(ВПР($A4;'все данные'!$A$3:$Y$999;МЕСЯЦ(1&B$2)*2+1;);)

Дальше аналогично
К сообщению приложен файл: 167988.xlsx(78Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЛист "Все данные". Если в А прямые ссылки, то зачем в В ВПР?
Переписал в В тоже прямвми ссылками и переписал там ВПР, чтобы можно было растягивать его вправо
Код
=ЕСЛИОШИБКА(ВПР($A3;ДВССЫЛ(ЕСЛИ(C$1="";B$1;C$1)&"!$B2:$G999");2+(C$2="сумма")*4;0);)

Лист "Основной отчет" формулу переписал так
Код
=ЕСЛИОШИБКА(ВПР($A4;'все данные'!$A$3:$Y$999;МЕСЯЦ(1&B$2)*2+1;);)

Дальше аналогично

Автор - _Boroda_
Дата добавления - 12.01.2016 в 20:07
Rodgerino Дата: Среда, 13.01.2016, 11:59 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, Nic70y,
Огромное вам спасибо!
Стало гораздо лучше и удобнее. Тоже думал по поводу ДВССЫЛ, но не знал как ее правильно использовать.
Если у вас есть предложения по изменению/упрощению/добавлению чего-то в этом отчете, то я с огромным удовольствием готов выслушать и принять)
Еще раз большое вам спасибо! booze
 
Ответить
Сообщение_Boroda_, Nic70y,
Огромное вам спасибо!
Стало гораздо лучше и удобнее. Тоже думал по поводу ДВССЫЛ, но не знал как ее правильно использовать.
Если у вас есть предложения по изменению/упрощению/добавлению чего-то в этом отчете, то я с огромным удовольствием готов выслушать и принять)
Еще раз большое вам спасибо! booze

Автор - Rodgerino
Дата добавления - 13.01.2016 в 11:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Упрощ. и оптимизация ежемесячного отчета, махинации с ВПР. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!