Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывести сумму в зависимоти от значений соседних ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести сумму в зависимоти от значений соседних ячеек (Формулы/Formulas)
Вывести сумму в зависимоти от значений соседних ячеек
meloman007 Дата: Среда, 13.01.2016, 10:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем доброго времени суток.

Прошу помочь со следующей задачей, требуется вывести отчетность по месяцам опираясь на данные соседних ячеек.
Какую формулу нужно использовать, чтобы в сводную таблицу складывалась информация 2-ух таблиц?
То есть мне нужно отдельно посчитать, сколько денег было получено за один месяц по определенным направлениям уже сгруппированным в одну ячейку.
Возможно ли это сделать формулой?
Так как я обычный пользователь экселя, макросами пользоваться не умею.
В приложении пример того, что требуется.

Заранее спасибо.
К сообщению приложен файл: 865426.xlsx(10Kb)


Сообщение отредактировал meloman007 - Среда, 13.01.2016, 10:58
 
Ответить
СообщениеВсем доброго времени суток.

Прошу помочь со следующей задачей, требуется вывести отчетность по месяцам опираясь на данные соседних ячеек.
Какую формулу нужно использовать, чтобы в сводную таблицу складывалась информация 2-ух таблиц?
То есть мне нужно отдельно посчитать, сколько денег было получено за один месяц по определенным направлениям уже сгруппированным в одну ячейку.
Возможно ли это сделать формулой?
Так как я обычный пользователь экселя, макросами пользоваться не умею.
В приложении пример того, что требуется.

Заранее спасибо.

Автор - meloman007
Дата добавления - 13.01.2016 в 10:57
китин Дата: Среда, 13.01.2016, 10:59 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4097
Репутация: 632 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Согласно приложенного примера
Код
=СУММПРОИЗВ($C$2:$C$15*(МЕСЯЦ(B$21)=МЕСЯЦ($B$2:$B$15))*(ЛЕВБ($A$2:$A$15;1)=ПРАВБ($A22;1)))
К сообщению приложен файл: 3214.xlsx(11Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 13.01.2016, 11:07
 
Ответить
СообщениеСогласно приложенного примера
Код
=СУММПРОИЗВ($C$2:$C$15*(МЕСЯЦ(B$21)=МЕСЯЦ($B$2:$B$15))*(ЛЕВБ($A$2:$A$15;1)=ПРАВБ($A22;1)))

Автор - китин
Дата добавления - 13.01.2016 в 10:59
Pelena Дата: Среда, 13.01.2016, 11:07 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10996
Репутация: 2454 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Формула для В22
Код
=СУММПРОИЗВ((ЛЕВСИМВ($A$2:$A$15)=$A22)*(ТЕКСТ($B$2:$B$15;"ММММ ГГГГ")=B$21)*$C$2:$C$15)
К сообщению приложен файл: 7421698.xlsx(11Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Формула для В22
Код
=СУММПРОИЗВ((ЛЕВСИМВ($A$2:$A$15)=$A22)*(ТЕКСТ($B$2:$B$15;"ММММ ГГГГ")=B$21)*$C$2:$C$15)

Автор - Pelena
Дата добавления - 13.01.2016 в 11:07
Che79 Дата: Среда, 13.01.2016, 11:18 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 359
Репутация: 52 ±
Замечаний: 0% ±

Excel 2007, 2010, 2016 RUS
meloman007, добрый день.
Еще одна вариация для B22, протягиваемая по строкам и столбцам
Код
=СУММПРОИЗВ($C$2:$C$15*(ЛЕВБ($A$2:$A$15)=ПРАВБ($A22))*(ТЕКСТ($B$2:$B$15;"ММММ")=ТЕКСТ(B$21;"ММММ")))


Делай нормально и будет нормально!
 
Ответить
Сообщениеmeloman007, добрый день.
Еще одна вариация для B22, протягиваемая по строкам и столбцам
Код
=СУММПРОИЗВ($C$2:$C$15*(ЛЕВБ($A$2:$A$15)=ПРАВБ($A22))*(ТЕКСТ($B$2:$B$15;"ММММ")=ТЕКСТ(B$21;"ММММ")))

Автор - Che79
Дата добавления - 13.01.2016 в 11:18
meloman007 Дата: Среда, 13.01.2016, 12:23 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
meloman007, Большое спасибо, очень помогли!
А можете немного пояснить как вы сопоставили буквы, если не сложно. Как работает формула ЛЕВБ ПРАВБ , чтобы они на буквы опирались заданные.
 
Ответить
Сообщениеmeloman007, Большое спасибо, очень помогли!
А можете немного пояснить как вы сопоставили буквы, если не сложно. Как работает формула ЛЕВБ ПРАВБ , чтобы они на буквы опирались заданные.

Автор - meloman007
Дата добавления - 13.01.2016 в 12:23
китин Дата: Среда, 13.01.2016, 12:36 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4097
Репутация: 632 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Как работает формула ЛЕВБ ПРАВБ

ЛЕВБ это примерно то же самое, что и ЛЕВСИМВОЛ,только писать короче
Код
=ЛЕВБ(А1;1)
забирает слева 1 символ , в вашем случае берет первую букву из д1( к примеру).с ПРАВБ та же свистопляска, только он берет 1 символ справа то есть 1 букву с конца предложения


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 13.01.2016, 12:37
 
Ответить
Сообщение
Как работает формула ЛЕВБ ПРАВБ

ЛЕВБ это примерно то же самое, что и ЛЕВСИМВОЛ,только писать короче
Код
=ЛЕВБ(А1;1)
забирает слева 1 символ , в вашем случае берет первую букву из д1( к примеру).с ПРАВБ та же свистопляска, только он берет 1 символ справа то есть 1 букву с конца предложения

Автор - китин
Дата добавления - 13.01.2016 в 12:36
Che79 Дата: Среда, 13.01.2016, 12:42 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 359
Репутация: 52 ±
Замечаний: 0% ±

Excel 2007, 2010, 2016 RUS
К посту выше от китин мне добавить , в общем, нечего)
Разве что, можете еще воспользоваться справкой


Делай нормально и будет нормально!
 
Ответить
СообщениеК посту выше от китин мне добавить , в общем, нечего)
Разве что, можете еще воспользоваться справкой

Автор - Che79
Дата добавления - 13.01.2016 в 12:42
meloman007 Дата: Среда, 13.01.2016, 12:44 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
китин,
Спасибо за развернутый ответ, разобрался)
 
Ответить
Сообщениекитин,
Спасибо за развернутый ответ, разобрался)

Автор - meloman007
Дата добавления - 13.01.2016 в 12:44
китин Дата: Среда, 13.01.2016, 13:10 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4097
Репутация: 632 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а еще и здесь на сайте ЕСТЬ yes yes yes


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 13.01.2016, 15:40
 
Ответить
Сообщениеа еще и здесь на сайте ЕСТЬ yes yes yes

Автор - китин
Дата добавления - 13.01.2016 в 13:10
_Boroda_ Дата: Среда, 13.01.2016, 15:37 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=СУММПРОИЗВ((ЛЕВБ($A$2:$A$15)=$A22)*($B$2:$B$15-ДЕНЬ($B$2:$B$15)=B$21-1)*$C$2:$C$15)

А в зеленых столбца А просто буквы и формат ячейки
;;;"Все направления под номером "@
К сообщению приложен файл: 7421698_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=СУММПРОИЗВ((ЛЕВБ($A$2:$A$15)=$A22)*($B$2:$B$15-ДЕНЬ($B$2:$B$15)=B$21-1)*$C$2:$C$15)

А в зеленых столбца А просто буквы и формат ячейки
;;;"Все направления под номером "@

Автор - _Boroda_
Дата добавления - 13.01.2016 в 15:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести сумму в зависимоти от значений соседних ячеек (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!