Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт ячеек на основании процента от суммы. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт ячеек на основании процента от суммы. (Формулы/Formulas)
Подсчёт ячеек на основании процента от суммы.
ShaD Дата: Среда, 13.01.2016, 12:07 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день.
Честно говоря, не уверен, что мой пример возможно решить формулами, но всё-таки лелею надежду.
Необходимо, чтобы EXCEL подсчитывал количество ячеек (сверху вниз, или начиная с самых высоких цифр) от полученной в проценте суммы.
Файл с примером во вложении.
К сообщению приложен файл: test12.xls(25Kb)
 
Ответить
СообщениеДобрый день.
Честно говоря, не уверен, что мой пример возможно решить формулами, но всё-таки лелею надежду.
Необходимо, чтобы EXCEL подсчитывал количество ячеек (сверху вниз, или начиная с самых высоких цифр) от полученной в проценте суммы.
Файл с примером во вложении.

Автор - ShaD
Дата добавления - 13.01.2016 в 12:07
buchlotnik Дата: Среда, 13.01.2016, 12:25 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2198
Репутация: 647 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно? (с допстолбцом)
Код
=СУММПРОИЗВ(($C$1:$C$14<=СУММ($F$1:I1;J1))*($C$1:$C$14>=СУММ($F$1:I1)))
К сообщению приложен файл: 235467.xls(29Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 13.01.2016, 12:29
 
Ответить
Сообщениетак нужно? (с допстолбцом)
Код
=СУММПРОИЗВ(($C$1:$C$14<=СУММ($F$1:I1;J1))*($C$1:$C$14>=СУММ($F$1:I1)))

Автор - buchlotnik
Дата добавления - 13.01.2016 в 12:25
ShaD Дата: Среда, 13.01.2016, 12:32 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
buchlotnik, это очень похоже на решение, которое мне нужно.
Попробую адаптировать под основной файл.
Спасибо :)
 
Ответить
Сообщениеbuchlotnik, это очень похоже на решение, которое мне нужно.
Попробую адаптировать под основной файл.
Спасибо :)

Автор - ShaD
Дата добавления - 13.01.2016 в 12:32
pabchek Дата: Среда, 13.01.2016, 13:31 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 664
Репутация: 147 ±
Замечаний: 0% ±

Excel 2007
Мой вариант для файла Михаила (buchlotnik),
Код
=ПОИСКПОЗ(СУММ($G$1:G1);$C1:$C14)-СУММ($F$3:F3)

Код
=ПРОСМОТР(СУММ($G1:G1);$C1:$C14;СТРОКА($B1:$B14))-СУММ($F3:F3)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Среда, 13.01.2016, 13:44
 
Ответить
СообщениеМой вариант для файла Михаила (buchlotnik),
Код
=ПОИСКПОЗ(СУММ($G$1:G1);$C1:$C14)-СУММ($F$3:F3)

Код
=ПРОСМОТР(СУММ($G1:G1);$C1:$C14;СТРОКА($B1:$B14))-СУММ($F3:F3)

Автор - pabchek
Дата добавления - 13.01.2016 в 13:31
ShaD Дата: Среда, 13.01.2016, 15:07 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
pabchek, спасибо :)
 
Ответить
Сообщениеpabchek, спасибо :)

Автор - ShaD
Дата добавления - 13.01.2016 в 15:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт ячеек на основании процента от суммы. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!