Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Текстовые фильтры не собирают месяца в года - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Текстовые фильтры не собирают месяца в года (Условное Форматирование/Conditional Formattings)
Текстовые фильтры не собирают месяца в года
SergeyNN Дата: Четверг, 14.01.2016, 12:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Текстовый фильтр "подтягивает" под себя не все ячейки месяцев Январь-Март 2016? В 2015 году такой проблемы нет. На скриншоте выделено красным.
В приложении скриншот и пример файла.
К сообщению приложен файл: question.xlsx(18Kb) · 7868626.jpg(41Kb)
 
Ответить
СообщениеТекстовый фильтр "подтягивает" под себя не все ячейки месяцев Январь-Март 2016? В 2015 году такой проблемы нет. На скриншоте выделено красным.
В приложении скриншот и пример файла.

Автор - SergeyNN
Дата добавления - 14.01.2016 в 12:27
_Boroda_ Дата: Четверг, 14.01.2016, 12:35 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9818
Репутация: 4146 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У Вас там просто обычный текст "Январь", а не дата
Хотя не везде.
Поставьте сначала обычный формат даты (например, Д.М.Г) и выберите все январь-февраль-март. Там окажутся только буквенные названия месяцев.
Что с ними делать - решать уже Вам.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУ Вас там просто обычный текст "Январь", а не дата
Хотя не везде.
Поставьте сначала обычный формат даты (например, Д.М.Г) и выберите все январь-февраль-март. Там окажутся только буквенные названия месяцев.
Что с ними делать - решать уже Вам.

Автор - _Boroda_
Дата добавления - 14.01.2016 в 12:35
SergeyNN Дата: Четверг, 14.01.2016, 12:41 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, А как сделать чтобы была дата? Пожалуйста )))
 
Ответить
Сообщение_Boroda_, А как сделать чтобы была дата? Пожалуйста )))

Автор - SergeyNN
Дата добавления - 14.01.2016 в 12:41
_Boroda_ Дата: Четверг, 14.01.2016, 12:45 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9818
Репутация: 4146 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
как сделать чтобы была дата?

Какая? Если написано буквами "март", то какой из 31 дней марта Вам нужно?
Если первое число, то формулу в соседний столбец
Код
=--ТЕКСТ(D2;"\1@")
К сообщению приложен файл: question_1.xlsx(18Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
как сделать чтобы была дата?

Какая? Если написано буквами "март", то какой из 31 дней марта Вам нужно?
Если первое число, то формулу в соседний столбец
Код
=--ТЕКСТ(D2;"\1@")

Автор - _Boroda_
Дата добавления - 14.01.2016 в 12:45
pabchek Дата: Четверг, 14.01.2016, 12:46 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 664
Репутация: 147 ±
Замечаний: 0% ±

Excel 2007
Возможно так?
Код
=ЕСЛИОШИБКА(--D2;--("1/"&D2))
К сообщению приложен файл: 3662386.xlsx(18Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеВозможно так?
Код
=ЕСЛИОШИБКА(--D2;--("1/"&D2))

Автор - pabchek
Дата добавления - 14.01.2016 в 12:46
SergeyNN Дата: Четверг, 14.01.2016, 15:36 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Boroda, спасибо большое!

Всё, теперь всё понял. Надо не просто в Формате ячеек поставить что это Дата, а надо вписать именно дату в формате 31.11.1996.
До меня вот именно это не доходило. В книжке прочитал, что ячейки должны иметь заполнение в формате Дата, а что это именно ДЕНЬ должен быть какой-то конкретный из этого месяца указан-это было непонятно. Особенно в свете того, что в этой таблице конкретный день не важен. Тут признак именно месяц. Поэтому мне казалось что достаточно написать буквами название месяца, например, Январь и потом из контекстного меню назначить ему тип данных Дата. Именно Ваш вопрос о том, какой именно из ДНЕЙ такого-то месяца меня интересует и натолкнул меня на правильный путь.


Сообщение отредактировал SergeyNN - Четверг, 14.01.2016, 15:37
 
Ответить
СообщениеBoroda, спасибо большое!

Всё, теперь всё понял. Надо не просто в Формате ячеек поставить что это Дата, а надо вписать именно дату в формате 31.11.1996.
До меня вот именно это не доходило. В книжке прочитал, что ячейки должны иметь заполнение в формате Дата, а что это именно ДЕНЬ должен быть какой-то конкретный из этого месяца указан-это было непонятно. Особенно в свете того, что в этой таблице конкретный день не важен. Тут признак именно месяц. Поэтому мне казалось что достаточно написать буквами название месяца, например, Январь и потом из контекстного меню назначить ему тип данных Дата. Именно Ваш вопрос о том, какой именно из ДНЕЙ такого-то месяца меня интересует и натолкнул меня на правильный путь.

Автор - SergeyNN
Дата добавления - 14.01.2016 в 15:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Текстовые фильтры не собирают месяца в года (Условное Форматирование/Conditional Formattings)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!