Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование из двух столбцов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 212»
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование из двух столбцов (Формулы/Formulas)
Суммирование из двух столбцов
anton_street Дата: Пятница, 15.01.2016, 10:37 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Помогите, плиз, разобраться.
Есть два столбца, надо посчитать сумму, причем, если заполнено значение во втором столбце, то брать от туда, если нет - брать из первого.

Спасибо!
К сообщению приложен файл: 0295724.xlsx(9Kb)


Сообщение отредактировал anton_street - Пятница, 15.01.2016, 10:50
 
Ответить
СообщениеДобрый день!
Помогите, плиз, разобраться.
Есть два столбца, надо посчитать сумму, причем, если заполнено значение во втором столбце, то брать от туда, если нет - брать из первого.

Спасибо!

Автор - anton_street
Дата добавления - 15.01.2016 в 10:37
ReAnima Дата: Пятница, 15.01.2016, 10:45 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 50
Репутация: 9 ±
Замечаний: 20% ±

Excel 2013
так ?
Код
=ЕСЛИ(ЕПУСТО(B1);A1;B1)
 
Ответить
Сообщениетак ?
Код
=ЕСЛИ(ЕПУСТО(B1);A1;B1)

Автор - ReAnima
Дата добавления - 15.01.2016 в 10:45
китин Дата: Пятница, 15.01.2016, 10:46 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4345
Репутация: 689 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
файл будет?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениефайл будет?

Автор - китин
Дата добавления - 15.01.2016 в 10:46
anton_street Дата: Пятница, 15.01.2016, 10:52 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Прикрепил файл.
Есть статьи затрат, по каждой запланирована 1000, но по некоторым есть факт. Так вот там, где есть факт, в бюджете надо учитывать его, а там, где факта нет, надо учитывать план. В итоге должно получиться 8500.
 
Ответить
СообщениеПрикрепил файл.
Есть статьи затрат, по каждой запланирована 1000, но по некоторым есть факт. Так вот там, где есть факт, в бюджете надо учитывать его, а там, где факта нет, надо учитывать план. В итоге должно получиться 8500.

Автор - anton_street
Дата добавления - 15.01.2016 в 10:52
anton_street Дата: Пятница, 15.01.2016, 10:52 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
так ?

=ЕСЛИ(ЕПУСТО(B1);A1;B1)


Что-то я не понял как это решает задачу
 
Ответить
Сообщение
так ?

=ЕСЛИ(ЕПУСТО(B1);A1;B1)


Что-то я не понял как это решает задачу

Автор - anton_street
Дата добавления - 15.01.2016 в 10:52
_Boroda_ Дата: Пятница, 15.01.2016, 10:55 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11541
Репутация: 4750 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММ(C2:C9)+СУММЕСЛИ(C2:C9;"";B2:B9)

или
Код
=СУММПРОИЗВ(C2:C9+B2:B9*НЕ(C2:C9))

Или формула массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=СУММ(C2:C9;B2:B9*НЕ(C2:C9))
К сообщению приложен файл: 0295724_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММ(C2:C9)+СУММЕСЛИ(C2:C9;"";B2:B9)

или
Код
=СУММПРОИЗВ(C2:C9+B2:B9*НЕ(C2:C9))

Или формула массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=СУММ(C2:C9;B2:B9*НЕ(C2:C9))

Автор - _Boroda_
Дата добавления - 15.01.2016 в 10:55
anton_street Дата: Пятница, 15.01.2016, 10:59 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Так нужно?

=СУММ(C2:C9)+СУММЕСЛИ(C2:C9;"";B2:B9)


Да, спасибо!
Я почему-то не подумал о таком простом решении :)
[moder]Не надо цитировать пост целиком. Это нарушение Правил форума[/moder]


Сообщение отредактировал Pelena - Пятница, 15.01.2016, 11:02
 
Ответить
Сообщение
Так нужно?

=СУММ(C2:C9)+СУММЕСЛИ(C2:C9;"";B2:B9)


Да, спасибо!
Я почему-то не подумал о таком простом решении :)
[moder]Не надо цитировать пост целиком. Это нарушение Правил форума[/moder]

Автор - anton_street
Дата добавления - 15.01.2016 в 10:59
китин Дата: Пятница, 15.01.2016, 10:59 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4345
Репутация: 689 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
или так?правда массивная
Код
=СУММ(ЕСЛИ(C2:C9="";B2:B9))+СУММ(C2:C9)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеили так?правда массивная
Код
=СУММ(ЕСЛИ(C2:C9="";B2:B9))+СУММ(C2:C9)

Автор - китин
Дата добавления - 15.01.2016 в 10:59
ReAnima Дата: Пятница, 15.01.2016, 11:06 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 50
Репутация: 9 ±
Замечаний: 20% ±

Excel 2013
Что-то я не понял как это решает задачу

Потому, что пример надо сразу прикладывать.
 
Ответить
Сообщение
Что-то я не понял как это решает задачу

Потому, что пример надо сразу прикладывать.

Автор - ReAnima
Дата добавления - 15.01.2016 в 11:06
Che79 Дата: Пятница, 15.01.2016, 11:10 | Сообщение № 10
Группа: Проверенные
Ранг: Ветеран
Сообщений: 533
Репутация: 92 ±
Замечаний: 0% ±

Excel 2010 RUS
ну и мой вариант до кучи, похожий на уже приведенные
Код
=СУММПРОИЗВ(B2:B9*(C2:C9="")+C2:C9)
К сообщению приложен файл: 150116_1.xlsx(9Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщениену и мой вариант до кучи, похожий на уже приведенные
Код
=СУММПРОИЗВ(B2:B9*(C2:C9="")+C2:C9)

Автор - Che79
Дата добавления - 15.01.2016 в 11:10
anton_street Дата: Пятница, 15.01.2016, 11:51 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем большое спасибо!

Интересный вариант
Код
=СУММПРОИЗВ(C2:C9+B2:B9*НЕ(C2:C9))


как работает СУММПРОИЗВ понятно

не ясна вот эта часть B2:B9*НЕ(C2:C9)
можете, плиз, объяснить логику
[moder]Оформляйте формулы тегами - кнопка fx. На первый раз поправил


Сообщение отредактировал _Boroda_ - Пятница, 15.01.2016, 11:55
 
Ответить
СообщениеВсем большое спасибо!

Интересный вариант
Код
=СУММПРОИЗВ(C2:C9+B2:B9*НЕ(C2:C9))


как работает СУММПРОИЗВ понятно

не ясна вот эта часть B2:B9*НЕ(C2:C9)
можете, плиз, объяснить логику
[moder]Оформляйте формулы тегами - кнопка fx. На первый раз поправил

Автор - anton_street
Дата добавления - 15.01.2016 в 11:51
_Boroda_ Дата: Пятница, 15.01.2016, 12:01 | Сообщение № 12
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11541
Репутация: 4750 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
не ясна вот эта часть B2:B9*НЕ(C2:C9)

Функция НЕ преобразует логическое значение в противоположное. Логические значения - это ИСТИНА и ЛОЖЬ. Нули и пустые ячейки преобразуются Excelем в ЛОЖЬ, числа, отличные от нуля в данном случае воспринимаются как ИСТИНА. Т.о., НЕ(C2:C9) даст нам ИСТИНА там, где в С2:С9 пусто или ноль и ЛОЖЬ там, где какое-то число, отличное от нуля. Умножив все это на В2:В9, получим значение из В в первом случае и ноль во втором (число * ИСТИНА = число; число * ЛОЖЬ = 0)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
не ясна вот эта часть B2:B9*НЕ(C2:C9)

Функция НЕ преобразует логическое значение в противоположное. Логические значения - это ИСТИНА и ЛОЖЬ. Нули и пустые ячейки преобразуются Excelем в ЛОЖЬ, числа, отличные от нуля в данном случае воспринимаются как ИСТИНА. Т.о., НЕ(C2:C9) даст нам ИСТИНА там, где в С2:С9 пусто или ноль и ЛОЖЬ там, где какое-то число, отличное от нуля. Умножив все это на В2:В9, получим значение из В в первом случае и ноль во втором (число * ИСТИНА = число; число * ЛОЖЬ = 0)

Автор - _Boroda_
Дата добавления - 15.01.2016 в 12:01
anton_street Дата: Пятница, 15.01.2016, 15:09 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
В продолжении темы еще один вопрос. Пишу сюда же, т.к. решаю одну задачу.

Пример во вложении.
Есть плановое значение на месяц, и на некоторые месяцы есть фактические значения.

Надо посчитать бюджет на год, суммируя факт из соответствующих ячеек где он есть, а если ячейка пустая, то брать на этот месяц плановое значение.

Конечно, можно написать сумму из 12 слагаемых, каждое из которых будет ЕСЛИ, но думаю, есть более изящное решение.

Спасибо!
К сообщению приложен файл: 5487185.xlsx(13Kb)
 
Ответить
СообщениеВ продолжении темы еще один вопрос. Пишу сюда же, т.к. решаю одну задачу.

Пример во вложении.
Есть плановое значение на месяц, и на некоторые месяцы есть фактические значения.

Надо посчитать бюджет на год, суммируя факт из соответствующих ячеек где он есть, а если ячейка пустая, то брать на этот месяц плановое значение.

Конечно, можно написать сумму из 12 слагаемых, каждое из которых будет ЕСЛИ, но думаю, есть более изящное решение.

Спасибо!

Автор - anton_street
Дата добавления - 15.01.2016 в 15:09
_Boroda_ Дата: Пятница, 15.01.2016, 15:19 | Сообщение № 14
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11541
Репутация: 4750 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Аналогично всё
Код
=СУММПРОИЗВ(C2:N2+B2*НЕ(C2:N2))
К сообщению приложен файл: 5487185_1.xlsx(14Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеАналогично всё
Код
=СУММПРОИЗВ(C2:N2+B2*НЕ(C2:N2))

Автор - _Boroda_
Дата добавления - 15.01.2016 в 15:19
Che79 Дата: Пятница, 15.01.2016, 15:34 | Сообщение № 15
Группа: Проверенные
Ранг: Ветеран
Сообщений: 533
Репутация: 92 ±
Замечаний: 0% ±

Excel 2010 RUS
еще вариант
Код
=СУММ(C2:N2;СЧИТАТЬПУСТОТЫ(C2:N2)*B2)


Делай нормально и будет нормально!
 
Ответить
Сообщениееще вариант
Код
=СУММ(C2:N2;СЧИТАТЬПУСТОТЫ(C2:N2)*B2)

Автор - Che79
Дата добавления - 15.01.2016 в 15:34
anton_street Дата: Пятница, 15.01.2016, 15:51 | Сообщение № 16
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Есть проблемка. На самом деле, пустые ячейки не пустые. Там есть формула, которая возвращает либо число, либо, "".
СУММПРОИЗВ не работает с "", а 0 трактует как пустую ячейку. Т.е., если в ячейке рассчитывается 0, то он возьмет плановое значение, хотя, в действительности, может, это факт 0 и таким его и надо считать, в то время как "" означает, что расчет еще не производился.
 
Ответить
СообщениеЕсть проблемка. На самом деле, пустые ячейки не пустые. Там есть формула, которая возвращает либо число, либо, "".
СУММПРОИЗВ не работает с "", а 0 трактует как пустую ячейку. Т.е., если в ячейке рассчитывается 0, то он возьмет плановое значение, хотя, в действительности, может, это факт 0 и таким его и надо считать, в то время как "" означает, что расчет еще не производился.

Автор - anton_street
Дата добавления - 15.01.2016 в 15:51
_Boroda_ Дата: Пятница, 15.01.2016, 16:01 | Сообщение № 17
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11541
Репутация: 4750 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А почему в примере не так?
Формула массива
Код
=СУММ(ЕСЛИ(C2:N2="";B2;C2:N2))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА почему в примере не так?
Формула массива
Код
=СУММ(ЕСЛИ(C2:N2="";B2;C2:N2))

Автор - _Boroda_
Дата добавления - 15.01.2016 в 16:01
китин Дата: Пятница, 15.01.2016, 16:02 | Сообщение № 18
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4345
Репутация: 689 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Код
=СУММ(ЕСЛИ(C2:C9<>"";B2:B9))+СУММ(C2:C9)
массивная


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Код
=СУММ(ЕСЛИ(C2:C9<>"";B2:B9))+СУММ(C2:C9)
массивная

Автор - китин
Дата добавления - 15.01.2016 в 16:02
anton_street Дата: Пятница, 15.01.2016, 16:02 | Сообщение № 19
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММ(C2:N2;СЧИТАТЬПУСТОТЫ(C2:N2)*B2)


вот эта работает
 
Ответить
Сообщение
Код
=СУММ(C2:N2;СЧИТАТЬПУСТОТЫ(C2:N2)*B2)


вот эта работает

Автор - anton_street
Дата добавления - 15.01.2016 в 16:02
китин Дата: Пятница, 15.01.2016, 16:05 | Сообщение № 20
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4345
Репутация: 689 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
вот эта работает

а остальные что?просто где написаны? :D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
вот эта работает

а остальные что?просто где написаны? :D

Автор - китин
Дата добавления - 15.01.2016 в 16:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование из двух столбцов (Формулы/Formulas)
Страница 1 из 212»
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!