Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула заполнение ячеек до следующего значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула заполнение ячеек до следующего значения (Формулы/Formulas)
Формула заполнение ячеек до следующего значения
pantera1945 Дата: Вторник, 19.01.2016, 07:37 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте, уважаемые форумчане! Часто приходится в прайсах поставщиков для подсчета остатков копировать название артикула в столбец (в пустые ячейки), до следующего значения (для дальнейшего сцепления с размерами). Делаю это постоянно вручную, но когда очень большой прайс, и наименований более 1000, глаза становятся в кучу. Помогите, пожалуйста, может есть какая-то формула? Образец прилагаю.
К сообщению приложен файл: 0764364.xlsx(10Kb)


Сообщение отредактировал pantera1945 - Вторник, 19.01.2016, 09:23
 
Ответить
СообщениеЗдравствуйте, уважаемые форумчане! Часто приходится в прайсах поставщиков для подсчета остатков копировать название артикула в столбец (в пустые ячейки), до следующего значения (для дальнейшего сцепления с размерами). Делаю это постоянно вручную, но когда очень большой прайс, и наименований более 1000, глаза становятся в кучу. Помогите, пожалуйста, может есть какая-то формула? Образец прилагаю.

Автор - pantera1945
Дата добавления - 19.01.2016 в 07:37
_Boroda_ Дата: Вторник, 19.01.2016, 07:55 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Функция пользователя, показывающая, на сколько символов отступ в ячейке
[vba]
Код
Function otst(r_ As Range)
    otst = r_.IndentLevel
End Function
[/vba]
А дальше все просто
К сообщению приложен файл: 7312635_1.xlsm(15Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеФункция пользователя, показывающая, на сколько символов отступ в ячейке
[vba]
Код
Function otst(r_ As Range)
    otst = r_.IndentLevel
End Function
[/vba]
А дальше все просто

Автор - _Boroda_
Дата добавления - 19.01.2016 в 07:55
китин Дата: Вторник, 19.01.2016, 08:26 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4117
Репутация: 636 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
или без Функции пользователя. в ячейку Е1 просто =А1.в Е2 формула
Код
=ЕСЛИ(ЕСЛИОШИБКА(ПОИСК("м";A2)=1;0);ЛЕВБ(A2;ПОИСК(" ";A2;ПОИСК(" ";A2)+1));E1)
К сообщению приложен файл: pantera1945.xlsx(10Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеили без Функции пользователя. в ячейку Е1 просто =А1.в Е2 формула
Код
=ЕСЛИ(ЕСЛИОШИБКА(ПОИСК("м";A2)=1;0);ЛЕВБ(A2;ПОИСК(" ";A2;ПОИСК(" ";A2)+1));E1)

Автор - китин
Дата добавления - 19.01.2016 в 08:26
pantera1945 Дата: Вторник, 19.01.2016, 08:56 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
китин, Спасибо большое, часть прайса так получилось сделать!
Только там, где артикул короче или длиннее, например, м 433 или м 3-533 У, формула не работает
Дополнила пример.
К сообщению приложен файл: 7099366.xlsx(10Kb)


Сообщение отредактировал pantera1945 - Вторник, 19.01.2016, 09:24
 
Ответить
Сообщениекитин, Спасибо большое, часть прайса так получилось сделать!
Только там, где артикул короче или длиннее, например, м 433 или м 3-533 У, формула не работает
Дополнила пример.

Автор - pantera1945
Дата добавления - 19.01.2016 в 08:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула заполнение ячеек до следующего значения (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!