Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод значений из диапазона в строку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод значений из диапазона в строку (Формулы/Formulas)
Вывод значений из диапазона в строку
martyr Дата: Вторник, 19.01.2016, 10:26 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день,
форумчане подскажите, как вывести значения в одну строку по условию в столбце 1 (группа связи). То есть, двум строкам присвоен один идент. номер, необходимо по этой группе связи перечислить все значения (всех строк в группе) пример во вложении.
[moder]Интересно, в этой теме вы также по-английски уйдете, как и в остальных своих?
К сообщению приложен файл: 4413549.xlsx(10Kb)


Сообщение отредактировал martyr - Вторник, 19.01.2016, 10:44
 
Ответить
СообщениеДобрый день,
форумчане подскажите, как вывести значения в одну строку по условию в столбце 1 (группа связи). То есть, двум строкам присвоен один идент. номер, необходимо по этой группе связи перечислить все значения (всех строк в группе) пример во вложении.
[moder]Интересно, в этой теме вы также по-английски уйдете, как и в остальных своих?

Автор - martyr
Дата добавления - 19.01.2016 в 10:26
ReAnima Дата: Вторник, 19.01.2016, 10:29 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 8 ±
Замечаний: 20% ±

Excel 2013
нет примера %)
 
Ответить
Сообщениенет примера %)

Автор - ReAnima
Дата добавления - 19.01.2016 в 10:29
martyr Дата: Вторник, 19.01.2016, 10:45 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
ReAnima, прошу прощения, пример добавила
 
Ответить
СообщениеReAnima, прошу прощения, пример добавила

Автор - martyr
Дата добавления - 19.01.2016 в 10:45
buchlotnik Дата: Вторник, 19.01.2016, 11:01 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2628
Репутация: 750 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=ВПР(A2;$A$2:$B$9;2;0)&ПРОСМОТР(;-1/($A$2:$A$9=A2);$B$2:$B$9)
К сообщению приложен файл: 2799916.xlsx(12Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак нужно?
Код
=ВПР(A2;$A$2:$B$9;2;0)&ПРОСМОТР(;-1/($A$2:$A$9=A2);$B$2:$B$9)

Автор - buchlotnik
Дата добавления - 19.01.2016 в 11:01
martyr Дата: Вторник, 19.01.2016, 11:11 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
buchlotnik, спасибо, расскажите пож. что делает вот эта часть формулы ПРОСМОТР(;-1/($A$2:$A$9=A2
 
Ответить
Сообщениеbuchlotnik, спасибо, расскажите пож. что делает вот эта часть формулы ПРОСМОТР(;-1/($A$2:$A$9=A2

Автор - martyr
Дата добавления - 19.01.2016 в 11:11
buchlotnik Дата: Вторник, 19.01.2016, 11:14 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2628
Репутация: 750 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
ищет последнее вхождение группы связи (это если они у вас идут не по порядку и не парами). Если они отсортированы и идут по порядку можно просто
Код
=ВПР(A2;$A$2:$B$9;2;0)&ПРОСМОТР(A2;$A$2:$A$9;$B$2:$B$9)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеищет последнее вхождение группы связи (это если они у вас идут не по порядку и не парами). Если они отсортированы и идут по порядку можно просто
Код
=ВПР(A2;$A$2:$B$9;2;0)&ПРОСМОТР(A2;$A$2:$A$9;$B$2:$B$9)

Автор - buchlotnik
Дата добавления - 19.01.2016 в 11:14
Che79 Дата: Вторник, 19.01.2016, 15:56 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 359
Репутация: 52 ±
Замечаний: 0% ±

Excel 2007, 2010, 2016 RUS
Если они отсортированы и идут по порядку можно просто

Код
=ЕСЛИ(A2=A3;B2&B3;B1&B2)

см. зеленые ячейки
К сообщению приложен файл: 1901161.xlsx(11Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщение
Если они отсортированы и идут по порядку можно просто

Код
=ЕСЛИ(A2=A3;B2&B3;B1&B2)

см. зеленые ячейки

Автор - Che79
Дата добавления - 19.01.2016 в 15:56
martyr Дата: Вторник, 19.01.2016, 16:48 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
buchlotnik,подскажите пож. , а если в одной связной группе будет разное кол-во строк, как изменить формулу
(пример во вложении)
К сообщению приложен файл: 3209366.xlsx(10Kb)
 
Ответить
Сообщениеbuchlotnik,подскажите пож. , а если в одной связной группе будет разное кол-во строк, как изменить формулу
(пример во вложении)

Автор - martyr
Дата добавления - 19.01.2016 в 16:48
martyr Дата: Вторник, 19.01.2016, 17:02 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Che79, Вы не в курсе как дописать формулу если кол-во строк в группе связи будет разное ?
К сообщению приложен файл: 6717785.xlsx(10Kb)
 
Ответить
СообщениеChe79, Вы не в курсе как дописать формулу если кол-во строк в группе связи будет разное ?

Автор - martyr
Дата добавления - 19.01.2016 в 17:02
buchlotnik Дата: Вторник, 19.01.2016, 17:17 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2628
Репутация: 750 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
нехорошо обманывать - изначально заявляли только два значения ;)
Переменное решается UDF-кой [vba]
Код
Function scepka(a As Range, b As Range, c As Range)
    Application.Volatile
    Dim s As String
    Dim i As Integer, j As Integer
    i = b.Rows.Count
    For j = 1 To i
        If b(j) = a Then s = s & c(j)
    Next j
    scepka = s
End Function
[/vba]
К сообщению приложен файл: 3209366.xlsm(16Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениенехорошо обманывать - изначально заявляли только два значения ;)
Переменное решается UDF-кой [vba]
Код
Function scepka(a As Range, b As Range, c As Range)
    Application.Volatile
    Dim s As String
    Dim i As Integer, j As Integer
    i = b.Rows.Count
    For j = 1 To i
        If b(j) = a Then s = s & c(j)
    Next j
    scepka = s
End Function
[/vba]

Автор - buchlotnik
Дата добавления - 19.01.2016 в 17:17
martyr Дата: Вторник, 19.01.2016, 17:57 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
buchlotnik, спасибо!
 
Ответить
Сообщениеbuchlotnik, спасибо!

Автор - martyr
Дата добавления - 19.01.2016 в 17:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод значений из диапазона в строку (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!