Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нумерация несольких строк подряд, Например, 15 ячеек подряд - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нумерация несольких строк подряд, Например, 15 ячеек подряд (Формулы/Formulas)
Нумерация несольких строк подряд, Например, 15 ячеек подряд
Sortafreel Дата: Вторник, 19.01.2016, 15:25 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
День добрый.

Суть: нужно пронумеровать несколько сотен-тысяч ячеек, но не просто "1-2-3", а группами по 1-50. То есть, 15 ячеек "1", за ними 15 ячеек 2, за ними 15 ячеек 3 и т.п. Сейчас я это реализую через растягивание "10/15" - беру последний символ результата, и если он = 0, значит прошел цикл и надо менять число с 1 на 2.

Но я надеюсь, есть и другой способ. Буду благодарен за совет :)
[moder]Приложите пример, если хотите, чтобы ответ максимально подошел под Ваши нужды.[/moder]


Сообщение отредактировал SLAVICK - Вторник, 19.01.2016, 15:31
 
Ответить
СообщениеДень добрый.

Суть: нужно пронумеровать несколько сотен-тысяч ячеек, но не просто "1-2-3", а группами по 1-50. То есть, 15 ячеек "1", за ними 15 ячеек 2, за ними 15 ячеек 3 и т.п. Сейчас я это реализую через растягивание "10/15" - беру последний символ результата, и если он = 0, значит прошел цикл и надо менять число с 1 на 2.

Но я надеюсь, есть и другой способ. Буду благодарен за совет :)
[moder]Приложите пример, если хотите, чтобы ответ максимально подошел под Ваши нужды.[/moder]

Автор - Sortafreel
Дата добавления - 19.01.2016 в 15:25
китин Дата: Вторник, 19.01.2016, 15:33 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4117
Репутация: 636 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
в А1 формулу и протягивайте до
несколько сотен-тысяч ячеек
Код
=ЦЕЛОЕ((СТРОКА(A1)-1)/15)+1
точнее при наличии файла


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 19.01.2016, 15:33
 
Ответить
Сообщениев А1 формулу и протягивайте до
несколько сотен-тысяч ячеек
Код
=ЦЕЛОЕ((СТРОКА(A1)-1)/15)+1
точнее при наличии файла

Автор - китин
Дата добавления - 19.01.2016 в 15:33
Udik Дата: Вторник, 19.01.2016, 15:38 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1376
Репутация: 178 ±
Замечаний: 0% ±

Excel 2016 х 64
или так
Код
= ОКРУГЛВВЕРХ((СТРОКА()-delta)/15;)

delta- смещение начала диапазона относительно 1-й строки, в диспетчере имён устанавливаем

или другой вариант - заполняем 2 сектора, выделяем их и протягиваем на необходимую длину
[p.s.]если проблема в быстром протягивании, то Быстрое заполнение диапазона значениями или формулами
К сообщению приложен файл: t1.xlsx(27Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Вторник, 19.01.2016, 16:04
 
Ответить
Сообщениеили так
Код
= ОКРУГЛВВЕРХ((СТРОКА()-delta)/15;)

delta- смещение начала диапазона относительно 1-й строки, в диспетчере имён устанавливаем

или другой вариант - заполняем 2 сектора, выделяем их и протягиваем на необходимую длину
[p.s.]если проблема в быстром протягивании, то Быстрое заполнение диапазона значениями или формулами

Автор - Udik
Дата добавления - 19.01.2016 в 15:38
Sortafreel Дата: Вторник, 19.01.2016, 16:14 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Понял, спасибо :) Не знал про delta, буду пользоваться. Еще посоветовали:

Код
=ЕСЛИ(ОСТАТ(СТРОКА()-1;15)=0;МАКС($A$1:A1)+1;A1)


То же решение, что я описывал сам, но более элегантно :)


Сообщение отредактировал Sortafreel - Вторник, 19.01.2016, 16:15
 
Ответить
СообщениеПонял, спасибо :) Не знал про delta, буду пользоваться. Еще посоветовали:

Код
=ЕСЛИ(ОСТАТ(СТРОКА()-1;15)=0;МАКС($A$1:A1)+1;A1)


То же решение, что я описывал сам, но более элегантно :)

Автор - Sortafreel
Дата добавления - 19.01.2016 в 16:14
Sortafreel Дата: Вторник, 19.01.2016, 16:17 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
=ЦЕЛОЕ((СТРОКА(A1)-1)/15)+1


Хотя так еще элегантнее :)
 
Ответить
Сообщение
=ЦЕЛОЕ((СТРОКА(A1)-1)/15)+1


Хотя так еще элегантнее :)

Автор - Sortafreel
Дата добавления - 19.01.2016 в 16:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нумерация несольких строк подряд, Например, 15 ячеек подряд (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!