Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как переместить все нечетные строки во второй столбец? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как переместить все нечетные строки во второй столбец? (Формулы/Formulas)
Как переместить все нечетные строки во второй столбец?
kioki Дата: Среда, 20.01.2016, 13:14 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Как переместить все нечетные строки во второй столбец?
К сообщению приложен файл: 2435877.xlsx(11Kb)
 
Ответить
СообщениеКак переместить все нечетные строки во второй столбец?

Автор - kioki
Дата добавления - 20.01.2016 в 13:14
ReAnima Дата: Среда, 20.01.2016, 13:34 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 8 ±
Замечаний: 20% ±

Excel 2013
мб так ?
[moder]Выкладывайте предложенную формулу в посте, чтобы другие форумчане сразу видели вариант.[/moder]
К сообщению приложен файл: 6531026.xlsx(14Kb)


Сообщение отредактировал SLAVICK - Среда, 20.01.2016, 13:39
 
Ответить
Сообщениемб так ?
[moder]Выкладывайте предложенную формулу в посте, чтобы другие форумчане сразу видели вариант.[/moder]

Автор - ReAnima
Дата добавления - 20.01.2016 в 13:34
китин Дата: Среда, 20.01.2016, 13:34 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4329
Репутация: 673 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Так?
Код
=ИНДЕКС($A$1:$A$79;СТРОКА(A1)*2-1)
К сообщению приложен файл: 6158099.xlsx(13Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеТак?
Код
=ИНДЕКС($A$1:$A$79;СТРОКА(A1)*2-1)

Автор - китин
Дата добавления - 20.01.2016 в 13:34
SLAVICK Дата: Среда, 20.01.2016, 13:36 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 2002
Репутация: 673 ±
Замечаний: 0% ±

2007,2010,2013,2016
Так:
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$A$79;СТРОКА(A1)*2-1;0);"")

китин, практически близнецы beer
К сообщению приложен файл: 7196284.xlsx(13Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеТак:
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$A$79;СТРОКА(A1)*2-1;0);"")

китин, практически близнецы beer

Автор - SLAVICK
Дата добавления - 20.01.2016 в 13:36
kioki Дата: Среда, 20.01.2016, 14:37 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
ReAnima, китин, SLAVICK, Всем спасибо, но это не совсем то что я хотел... я говорил про ПЕРЕМЕСТИТЬ... Вообщем если переместить невозможно то покажите как сделать чтоб каждая четная строка была во втором столбце, а каждая нечетная в третьем...
[moder]А почему Вы не сделали в своем файле желаемый результат?


Сообщение отредактировал _Boroda_ - Среда, 20.01.2016, 14:48
 
Ответить
СообщениеReAnima, китин, SLAVICK, Всем спасибо, но это не совсем то что я хотел... я говорил про ПЕРЕМЕСТИТЬ... Вообщем если переместить невозможно то покажите как сделать чтоб каждая четная строка была во втором столбце, а каждая нечетная в третьем...
[moder]А почему Вы не сделали в своем файле желаемый результат?

Автор - kioki
Дата добавления - 20.01.2016 в 14:37
SLAVICK Дата: Среда, 20.01.2016, 14:52 | Сообщение № 6
Группа: Модераторы
Ранг: Старожил
Сообщений: 2002
Репутация: 673 ±
Замечаний: 0% ±

2007,2010,2013,2016
Так?
Просто добавить еще одну формулу:
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$A$79;СТРОКА(A1)*2;0);"")
К сообщению приложен файл: 7196284-1-.xlsx(14Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеТак?
Просто добавить еще одну формулу:
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$A$79;СТРОКА(A1)*2;0);"")

Автор - SLAVICK
Дата добавления - 20.01.2016 в 14:52
Gustav Дата: Среда, 20.01.2016, 14:54 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1409
Репутация: 541 ±
Замечаний: 0% ±

начинал с Excel 4.0...
я говорил про ПЕРЕМЕСТИТЬ... Вообщем если переместить невозможно то покажите как сделать чтоб каждая четная строка была во втором столбце, а каждая нечетная в третьем.

1. В столбце B протягиваете в диапазоне B1:B80 чередующиеся значения 1, 2, 1, 2, 1, 2...1, 2, как признаки нечетности и четности.
2. В столбце C протягиваете в диапазоне C1:C80 значения от 1 до 80, т.е. фактически фиксируете исходный порядок строк.
3. Сортируете имеющиеся 3 столбца по возрастанию по столбцам B и C.
4. Дальше, думаю, всё понятно - выделяете мышкой и перетаскиванием пристраиваете блоки клеток с "1" и "2" друг к другу как надо.
5. Лишнее - удаляете.


Мой tip box - яд 41001663842605

Сообщение отредактировал Gustav - Среда, 20.01.2016, 14:56
 
Ответить
Сообщение
я говорил про ПЕРЕМЕСТИТЬ... Вообщем если переместить невозможно то покажите как сделать чтоб каждая четная строка была во втором столбце, а каждая нечетная в третьем.

1. В столбце B протягиваете в диапазоне B1:B80 чередующиеся значения 1, 2, 1, 2, 1, 2...1, 2, как признаки нечетности и четности.
2. В столбце C протягиваете в диапазоне C1:C80 значения от 1 до 80, т.е. фактически фиксируете исходный порядок строк.
3. Сортируете имеющиеся 3 столбца по возрастанию по столбцам B и C.
4. Дальше, думаю, всё понятно - выделяете мышкой и перетаскиванием пристраиваете блоки клеток с "1" и "2" друг к другу как надо.
5. Лишнее - удаляете.

Автор - Gustav
Дата добавления - 20.01.2016 в 14:54
kioki Дата: Среда, 20.01.2016, 15:07 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 42
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
SLAVICK, Gustav, Спасибо!
 
Ответить
СообщениеSLAVICK, Gustav, Спасибо!

Автор - kioki
Дата добавления - 20.01.2016 в 15:07
Wasilich Дата: Среда, 20.01.2016, 15:21 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1195
Репутация: 316 ±
Замечаний: 0% ±

2003
А если макросом?
[vba]
Код
Sub www()
  Dim i&, s&
  s = 1
  For i = 1 To Range("A" & Rows.Count).End(xlUp).Row Step 2
    Cells(s, 3) = Cells(i, 1)
    Cells(s, 2) = Cells(i + 1, 1)
    s = s + 1
  Next
End Sub
[/vba]
 
Ответить
СообщениеА если макросом?
[vba]
Код
Sub www()
  Dim i&, s&
  s = 1
  For i = 1 To Range("A" & Rows.Count).End(xlUp).Row Step 2
    Cells(s, 3) = Cells(i, 1)
    Cells(s, 2) = Cells(i + 1, 1)
    s = s + 1
  Next
End Sub
[/vba]

Автор - Wasilich
Дата добавления - 20.01.2016 в 15:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как переместить все нечетные строки во второй столбец? (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!