Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сложение и Вычитание чисел, при заданных условиях - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложение и Вычитание чисел, при заданных условиях (Формулы/Formulas)
Сложение и Вычитание чисел, при заданных условиях
fassil Дата: Четверг, 21.01.2016, 21:38 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Подскажите пожалуйста... Какую формулу написать. Есть числа 50 и 100 , эксель высчитывает , что между ними разница в + 100% , так вот мне нужно сделать так, что следующий столбец считал первое число 50 + 1% , если разница между числами превысила 50% . Думаю понятно, как только разница превышает 50% , то первое число прибавляет 1%.
 
Ответить
СообщениеПодскажите пожалуйста... Какую формулу написать. Есть числа 50 и 100 , эксель высчитывает , что между ними разница в + 100% , так вот мне нужно сделать так, что следующий столбец считал первое число 50 + 1% , если разница между числами превысила 50% . Думаю понятно, как только разница превышает 50% , то первое число прибавляет 1%.

Автор - fassil
Дата добавления - 21.01.2016 в 21:38
buchlotnik Дата: Четверг, 21.01.2016, 21:43 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
сегодня эпидемия какая-то - файл хдэ?
Код
=ЕСЛИ(B1/A1>1,5;A1*1,01;"")
К сообщению приложен файл: 123.xlsx(8Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Четверг, 21.01.2016, 21:49
 
Ответить
Сообщениесегодня эпидемия какая-то - файл хдэ?
Код
=ЕСЛИ(B1/A1>1,5;A1*1,01;"")

Автор - buchlotnik
Дата добавления - 21.01.2016 в 21:43
fassil Дата: Пятница, 22.01.2016, 00:21 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо!!! А как сделать , чтоб в этом же значении он вычитал 1% от первого числа , если разница отрицательная более чем - 1%. Ну и вообще хотелось бы добавить значения , чтобы если разница уже более 2%, то к первому числу прибавляет 2 % , так же и с вычитанием при разнице в более 2 %. Чтобы все в одной клеточки считал.
[moder]Прочтите правила форума.
Показывайте в примере что Вы хотите получить.[/moder]
К сообщению приложен файл: 777.xlsx(10Kb)


Сообщение отредактировал SLAVICK - Пятница, 22.01.2016, 00:30
 
Ответить
СообщениеСпасибо!!! А как сделать , чтоб в этом же значении он вычитал 1% от первого числа , если разница отрицательная более чем - 1%. Ну и вообще хотелось бы добавить значения , чтобы если разница уже более 2%, то к первому числу прибавляет 2 % , так же и с вычитанием при разнице в более 2 %. Чтобы все в одной клеточки считал.
[moder]Прочтите правила форума.
Показывайте в примере что Вы хотите получить.[/moder]

Автор - fassil
Дата добавления - 22.01.2016 в 00:21
_Boroda_ Дата: Пятница, 22.01.2016, 00:37 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=J4*(1+ОТБР(K4/J4-1;2))
К сообщению приложен файл: 777_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=J4*(1+ОТБР(K4/J4-1;2))

Автор - _Boroda_
Дата добавления - 22.01.2016 в 00:37
fassil Дата: Пятница, 22.01.2016, 07:28 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Пример так.. Но если разница от 1% до 2% то либо +1% либо - 1 % , зависит от полученной разницы. Но если разница от 2 % до 3%, то УЖЕ либо +2% либо -2%
 
Ответить
СообщениеПример так.. Но если разница от 1% до 2% то либо +1% либо - 1 % , зависит от полученной разницы. Но если разница от 2 % до 3%, то УЖЕ либо +2% либо -2%

Автор - fassil
Дата добавления - 22.01.2016 в 07:28
_Boroda_ Дата: Пятница, 22.01.2016, 07:31 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так у меня так и есть. Посчитайте на калькуляторе, если не верите.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак у меня так и есть. Посчитайте на калькуляторе, если не верите.

Автор - _Boroda_
Дата добавления - 22.01.2016 в 07:31
fassil Дата: Пятница, 22.01.2016, 13:28 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Да все верно. Спасибо.


Сообщение отредактировал fassil - Суббота, 23.01.2016, 12:09
 
Ответить
СообщениеДа все верно. Спасибо.

Автор - fassil
Дата добавления - 22.01.2016 в 13:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сложение и Вычитание чисел, при заданных условиях (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!