Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма по двум условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма по двум условиям (Формулы/Formulas)
Сумма по двум условиям
ringa Дата: Пятница, 22.01.2016, 10:36 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте.
Помогите, пожалуйста, правильно вычислить итоговую сумму. Первое условие столбец А, второе столбец В. Итоговая сумма для каждого столбца из условия выбора типа опоры и глубины котлована.
Хотела применить формулу СУММЕСЛИМН, но что-то не получается. Не могу понять как правильно назначить диапазон условия.
К сообщению приложен файл: 11.xls(34Kb)
 
Ответить
СообщениеЗдравствуйте.
Помогите, пожалуйста, правильно вычислить итоговую сумму. Первое условие столбец А, второе столбец В. Итоговая сумма для каждого столбца из условия выбора типа опоры и глубины котлована.
Хотела применить формулу СУММЕСЛИМН, но что-то не получается. Не могу понять как правильно назначить диапазон условия.

Автор - ringa
Дата добавления - 22.01.2016 в 10:36
YouGreed Дата: Пятница, 22.01.2016, 10:41 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
ringa,
Код
=СУММЕСЛИМН(C$4:C$18;$A$4:$A$18;$A23;$B$4:$B$18;$B23)


Обратите внимание, что в нижней таблице, есть такие наименования, которых нет в верхней, т.е. существует не соответствие, из-за которого могут не считаться некоторые данные.
Цитата
1У220-1+10

Цитата
1У220-1т+10
К сообщению приложен файл: __.xls(30Kb)


Сообщение отредактировал YouGreed - Пятница, 22.01.2016, 10:48
 
Ответить
Сообщениеringa,
Код
=СУММЕСЛИМН(C$4:C$18;$A$4:$A$18;$A23;$B$4:$B$18;$B23)


Обратите внимание, что в нижней таблице, есть такие наименования, которых нет в верхней, т.е. существует не соответствие, из-за которого могут не считаться некоторые данные.
Цитата
1У220-1+10

Цитата
1У220-1т+10

Автор - YouGreed
Дата добавления - 22.01.2016 в 10:41
_Boroda_ Дата: Пятница, 22.01.2016, 10:45 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно еще
Код
=СУММПРОИЗВ(C$4:C$18*($A$4:$A$18=$A23)*($B$4:$B$18=$B23))

Она медленнее, но понятнее (по крайней мере мне) и позволяет играться диапазонами для суммирования и проверки
Кстати, у ВАс не все значения были. Добавил недостающие
К сообщению приложен файл: 11_1.xls(38Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно еще
Код
=СУММПРОИЗВ(C$4:C$18*($A$4:$A$18=$A23)*($B$4:$B$18=$B23))

Она медленнее, но понятнее (по крайней мере мне) и позволяет играться диапазонами для суммирования и проверки
Кстати, у ВАс не все значения были. Добавил недостающие

Автор - _Boroda_
Дата добавления - 22.01.2016 в 10:45
ringa Дата: Пятница, 22.01.2016, 10:46 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
YouGreed, спасибо
Boroda_, в формуле смутило слово ПРОИЗВ, думала это для перемножения. Спасибо, попробую.
Да, я знаю, что не все значения. Это только небольшая часть таблицы, чтобы к теме прикрепить. На самом деле таблица большая и строк много.


Сообщение отредактировал ringa - Пятница, 22.01.2016, 10:54
 
Ответить
СообщениеYouGreed, спасибо
Boroda_, в формуле смутило слово ПРОИЗВ, думала это для перемножения. Спасибо, попробую.
Да, я знаю, что не все значения. Это только небольшая часть таблицы, чтобы к теме прикрепить. На самом деле таблица большая и строк много.

Автор - ringa
Дата добавления - 22.01.2016 в 10:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма по двум условиям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!