Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества значений с функцией "Суммеслимн" - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества значений с функцией "Суммеслимн" (Формулы/Formulas)
Подсчет количества значений с функцией "Суммеслимн"
Mezhik Дата: Пятница, 22.01.2016, 14:57 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 40% ±

Добрый день!
Столкнулся с проблемой при подсчете количества значений через функцию Суммеслимн. Есть наименование идентичных продуктов, но каждый из них обладает произвольными цифрами. Подскажите, возможно ли подсчитать количество значений при помощи данной функции, чтобы подсчет велся только по названию?
К сообщению приложен файл: 7671802.xlsx(8Kb)
 
Ответить
СообщениеДобрый день!
Столкнулся с проблемой при подсчете количества значений через функцию Суммеслимн. Есть наименование идентичных продуктов, но каждый из них обладает произвольными цифрами. Подскажите, возможно ли подсчитать количество значений при помощи данной функции, чтобы подсчет велся только по названию?

Автор - Mezhik
Дата добавления - 22.01.2016 в 14:57
YouGreed Дата: Пятница, 22.01.2016, 15:03 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
Mezhik,
Код
=СУММПРОИЗВ(--(ЛЕВБ($A$2:$A$7;НАЙТИ(" ";$A$2:$A$7;1)-1)="Груша"))
К сообщению приложен файл: 0332996.xlsx(8Kb)


Сообщение отредактировал YouGreed - Пятница, 22.01.2016, 15:04
 
Ответить
СообщениеMezhik,
Код
=СУММПРОИЗВ(--(ЛЕВБ($A$2:$A$7;НАЙТИ(" ";$A$2:$A$7;1)-1)="Груша"))

Автор - YouGreed
Дата добавления - 22.01.2016 в 15:03
Nic70y Дата: Пятница, 22.01.2016, 15:04 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4113
Репутация: 879 ±
Замечаний: 0% ±

Excel 2013
подсчете количества

думаю это не очень красиво кол-во суммировать, а не считать.
Код
=СЧЁТЕСЛИ(A:A;"Груша*")
Код
=СЧЁТЕСЛИ(A:A;"*Груша*")
не массивные


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Пятница, 22.01.2016, 15:07
 
Ответить
Сообщение
подсчете количества

думаю это не очень красиво кол-во суммировать, а не считать.
Код
=СЧЁТЕСЛИ(A:A;"Груша*")
Код
=СЧЁТЕСЛИ(A:A;"*Груша*")
не массивные

Автор - Nic70y
Дата добавления - 22.01.2016 в 15:04
pabchek Дата: Пятница, 22.01.2016, 15:04 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 746
Репутация: 169 ±
Замечаний: 0% ±

Excel 2007
Формула массива (кнтрл+шифт+ентер)
Код
=СУММ(--НЕ(ЕОШ(ПОИСК(C2;A$2:A$7))))

не массива
Код
=СУММПРОИЗВ(--НЕ(ЕОШ(ПОИСК(C2;A$2:A$7))))


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Пятница, 22.01.2016, 15:07
 
Ответить
СообщениеФормула массива (кнтрл+шифт+ентер)
Код
=СУММ(--НЕ(ЕОШ(ПОИСК(C2;A$2:A$7))))

не массива
Код
=СУММПРОИЗВ(--НЕ(ЕОШ(ПОИСК(C2;A$2:A$7))))

Автор - pabchek
Дата добавления - 22.01.2016 в 15:04
Mezhik Дата: Пятница, 22.01.2016, 15:08 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 40% ±

А при помощи Счётеслимн?
 
Ответить
СообщениеА при помощи Счётеслимн?

Автор - Mezhik
Дата добавления - 22.01.2016 в 15:08
_Boroda_ Дата: Пятница, 22.01.2016, 15:09 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11504
Репутация: 4735 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Да не вопрос
Код
=СЧЁТЕСЛИМН(A:A;"Груша*")

Более того, "МН" не нужно
Код
=СЧЁТЕСЛИ(A:A;"Груша*")


Кстати, Николай уже это написал выше. Я только что заметил.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Пятница, 22.01.2016, 15:25
 
Ответить
СообщениеДа не вопрос
Код
=СЧЁТЕСЛИМН(A:A;"Груша*")

Более того, "МН" не нужно
Код
=СЧЁТЕСЛИ(A:A;"Груша*")


Кстати, Николай уже это написал выше. Я только что заметил.

Автор - _Boroda_
Дата добавления - 22.01.2016 в 15:09
Mezhik Дата: Пятница, 22.01.2016, 15:12 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 40% ±

Огромное спасибо! Просто нужно добавить звездочку и все получится)))
 
Ответить
СообщениеОгромное спасибо! Просто нужно добавить звездочку и все получится)))

Автор - Mezhik
Дата добавления - 22.01.2016 в 15:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества значений с функцией "Суммеслимн" (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!