Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нахождение и последующее сравнение нужных данных в таблице - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нахождение и последующее сравнение нужных данных в таблице (Формулы/Formulas)
Нахождение и последующее сравнение нужных данных в таблице
НикНик Дата: Воскресенье, 24.01.2016, 09:38 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Доброго времени суток, уважаемые форумчане!
Суть проблемы в следующем. Имеются две таблицы ФАКТ и ПЛАН. Необходимо собрать данные из обеих таблиц в сводную ПЛАН-ФАКТ и высчитать превышения. Таблица ПЛАН получается методом выгрузки из стороннего ПО и последующего копирования в наш документ, т.е. при каждом копировании в таблице внизу будет проявляться новая строчка. Данные из ФАКТ в соответствующие столбцы таблицы ПЛАН-ФАКТ переносятся.
Как сделать так, чтобы по значению Гл(м) в табл.ПАН-ФАКТ (ст.В) искал соответствующую строку в таблице ПЛАН (ст.А) и заносил данные в табл. ПЛАН-ФАКТ по схеме?
Пр.инт Зен Аз Верт
План-Факт L M N O План H B C D соответственно

Сумбурно получилось, но надеюсь, понятно. Сколько бьюсь, не могу найти решения.
Спасибо!
[moder]Пример в файле приложите[/moder]
К сообщению приложен файл: 0064285.xlsx(17Kb)


Сообщение отредактировал НикНик - Воскресенье, 24.01.2016, 09:52
 
Ответить
СообщениеДоброго времени суток, уважаемые форумчане!
Суть проблемы в следующем. Имеются две таблицы ФАКТ и ПЛАН. Необходимо собрать данные из обеих таблиц в сводную ПЛАН-ФАКТ и высчитать превышения. Таблица ПЛАН получается методом выгрузки из стороннего ПО и последующего копирования в наш документ, т.е. при каждом копировании в таблице внизу будет проявляться новая строчка. Данные из ФАКТ в соответствующие столбцы таблицы ПЛАН-ФАКТ переносятся.
Как сделать так, чтобы по значению Гл(м) в табл.ПАН-ФАКТ (ст.В) искал соответствующую строку в таблице ПЛАН (ст.А) и заносил данные в табл. ПЛАН-ФАКТ по схеме?
Пр.инт Зен Аз Верт
План-Факт L M N O План H B C D соответственно

Сумбурно получилось, но надеюсь, понятно. Сколько бьюсь, не могу найти решения.
Спасибо!
[moder]Пример в файле приложите[/moder]

Автор - НикНик
Дата добавления - 24.01.2016 в 09:38
Pelena Дата: Воскресенье, 24.01.2016, 10:28 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 10468
Репутация: 2362 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте
Код
=ЕСЛИОШИБКА(ИНДЕКС(план;ПОИСКПОЗ($B3;Гл_план;0);ПОИСКПОЗ(СЖПРОБЕЛЫ(ЛЕВСИМВ(L$2;ПОИСК("(";L$2)-1));План!$A$2:$L$2;0));"")

[p.s.]Перенос строки внутри ячейки можно делать сочетанием клавиш Alt+Enter[/p.s.]
К сообщению приложен файл: 7060939.xlsx(17Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте
Код
=ЕСЛИОШИБКА(ИНДЕКС(план;ПОИСКПОЗ($B3;Гл_план;0);ПОИСКПОЗ(СЖПРОБЕЛЫ(ЛЕВСИМВ(L$2;ПОИСК("(";L$2)-1));План!$A$2:$L$2;0));"")

[p.s.]Перенос строки внутри ячейки можно делать сочетанием клавиш Alt+Enter[/p.s.]

Автор - Pelena
Дата добавления - 24.01.2016 в 10:28
gling Дата: Воскресенье, 24.01.2016, 10:33 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1402
Репутация: 343 ±
Замечаний: 0% ±

2010
Почитайте про ВПР().
Код
=ВПР($B3;План!$A$4:$L$16;8;0)
Код
=ВПР($B3;План!$A$4:$L$16;СТОЛБЕЦ(B1);0)
 
Ответить
СообщениеПочитайте про ВПР().
Код
=ВПР($B3;План!$A$4:$L$16;8;0)
Код
=ВПР($B3;План!$A$4:$L$16;СТОЛБЕЦ(B1);0)

Автор - gling
Дата добавления - 24.01.2016 в 10:33
НикНик Дата: Воскресенье, 24.01.2016, 11:27 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо огромное! Сейчас буду разбираться.
 
Ответить
СообщениеСпасибо огромное! Сейчас буду разбираться.

Автор - НикНик
Дата добавления - 24.01.2016 в 11:27
НикНик Дата: Воскресенье, 24.01.2016, 18:38 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый вечер, уважаемые форумчане!
После переноса листов в основной документ, переименования вкладок и т.д. формулы перестали работать, так в общем и должно быть. Но я так и не заставил их работать, сколько не пытался поменять номера строк и заменить в формуле то, что изменил в листах. Причем не получилось ни с первой более сложной, ни второй ВПР (), сколько не читал. Если не сложно, подкорректируйте в новом документе.
Спасибо!
К сообщению приложен файл: 9520576.xlsx(69Kb)


Сообщение отредактировал НикНик - Воскресенье, 24.01.2016, 18:45
 
Ответить
СообщениеДобрый вечер, уважаемые форумчане!
После переноса листов в основной документ, переименования вкладок и т.д. формулы перестали работать, так в общем и должно быть. Но я так и не заставил их работать, сколько не пытался поменять номера строк и заменить в формуле то, что изменил в листах. Причем не получилось ни с первой более сложной, ни второй ВПР (), сколько не читал. Если не сложно, подкорректируйте в новом документе.
Спасибо!

Автор - НикНик
Дата добавления - 24.01.2016 в 18:38
gling Дата: Воскресенье, 24.01.2016, 18:50 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1402
Репутация: 343 ±
Замечаний: 0% ±

2010
Цитата
Если не сложно
Не сложно, но корректировать нечего, в файле в столбцах L:O формул нет. Нужно заново написать? И какой из вариантов Вы выбрали? Показали бы в файле, что не получается, а мы подправим. Так будет понятней, что Вы делаете не так.
И в новом файле на листе План-факт нет столбца Гл по которому искали. По какому критерию сейчас сравнивать/искать? Или Измер. глуб., м, это и есть Гл?


Сообщение отредактировал gling - Воскресенье, 24.01.2016, 18:58
 
Ответить
Сообщение
Цитата
Если не сложно
Не сложно, но корректировать нечего, в файле в столбцах L:O формул нет. Нужно заново написать? И какой из вариантов Вы выбрали? Показали бы в файле, что не получается, а мы подправим. Так будет понятней, что Вы делаете не так.
И в новом файле на листе План-факт нет столбца Гл по которому искали. По какому критерию сейчас сравнивать/искать? Или Измер. глуб., м, это и есть Гл?

Автор - gling
Дата добавления - 24.01.2016 в 18:50
_Boroda_ Дата: Воскресенье, 24.01.2016, 19:00 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9831
Репутация: 4151 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Такой вариант
Код
=ИНДЕКС('5D_Plan'!$C$24:$L$524;$B2+1;ПРОСМОТР(;-ПОИСК('5D_Plan'!$C$22:$L$22;L$1);СТОЛБЕЦ('5D_Plan'!$A$22:$J$22)))

Код
=ВПР(B2;'5D_Plan'!$B$24:$L$524;ПРОСМОТР(;-ПОИСК('5D_Plan'!$B$22:$L$22;L$1);СТОЛБЕЦ('5D_Plan'!$A$22:$K$22));)
К сообщению приложен файл: 9520576_1.xlsx(76Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТакой вариант
Код
=ИНДЕКС('5D_Plan'!$C$24:$L$524;$B2+1;ПРОСМОТР(;-ПОИСК('5D_Plan'!$C$22:$L$22;L$1);СТОЛБЕЦ('5D_Plan'!$A$22:$J$22)))

Код
=ВПР(B2;'5D_Plan'!$B$24:$L$524;ПРОСМОТР(;-ПОИСК('5D_Plan'!$B$22:$L$22;L$1);СТОЛБЕЦ('5D_Plan'!$A$22:$K$22));)

Автор - _Boroda_
Дата добавления - 24.01.2016 в 19:00
НикНик Дата: Воскресенье, 24.01.2016, 19:16 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Не сложно, но корректировать нечего, в файле в столбцах L:O формул нет.


Странно, скачал формулы есть. Я пробовал оба варианта, в первой строке более сложный, во второй Ваш. Да, Измер. глуб., м, это и есть Гл. Прошу прощения, за сумбур. Предпочтение самому простому варианту, чтобы потом при изменении форм, можно было быстренько подкорректировать. Продублировал файлик.
[moder]Не нужно цитировать весь пост целиком.
Изменил за Вас.[/moder]
К сообщению приложен файл: 0795444.xlsx(69Kb)


Сообщение отредактировал SLAVICK - Воскресенье, 24.01.2016, 19:29
 
Ответить
Сообщение
Не сложно, но корректировать нечего, в файле в столбцах L:O формул нет.


Странно, скачал формулы есть. Я пробовал оба варианта, в первой строке более сложный, во второй Ваш. Да, Измер. глуб., м, это и есть Гл. Прошу прощения, за сумбур. Предпочтение самому простому варианту, чтобы потом при изменении форм, можно было быстренько подкорректировать. Продублировал файлик.
[moder]Не нужно цитировать весь пост целиком.
Изменил за Вас.[/moder]

Автор - НикНик
Дата добавления - 24.01.2016 в 19:16
gling Дата: Воскресенье, 24.01.2016, 19:27 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1402
Репутация: 343 ±
Замечаний: 0% ±

2010
У вас почти все правильно, только диапазон поиска начинается со столбца B, а у Вас с A. Столбец А пуст. Вашу формулу оставил для сравнения.
К сообщению приложен файл: 0029988.xlsx(74Kb)
 
Ответить
СообщениеУ вас почти все правильно, только диапазон поиска начинается со столбца B, а у Вас с A. Столбец А пуст. Вашу формулу оставил для сравнения.

Автор - gling
Дата добавления - 24.01.2016 в 19:27
Udik Дата: Воскресенье, 24.01.2016, 19:40 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1300
Репутация: 162 ±
Замечаний: 0% ±

Excel 2013
НикНик, ВПР ищет в крайнем левом столбце, поэтому диапазон должен начинаться со столбца поиска :)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
СообщениеНикНик, ВПР ищет в крайнем левом столбце, поэтому диапазон должен начинаться со столбца поиска :)

Автор - Udik
Дата добавления - 24.01.2016 в 19:40
НикНик Дата: Воскресенье, 24.01.2016, 19:49 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
У вас почти все правильно, только диапазон поиска начинается со столбца B, а у Вас с A. Столбец А пуст. Вашу формулу оставил для сравнения.


Спасибо огромное, вроде разобрался!
 
Ответить
Сообщение
У вас почти все правильно, только диапазон поиска начинается со столбца B, а у Вас с A. Столбец А пуст. Вашу формулу оставил для сравнения.


Спасибо огромное, вроде разобрался!

Автор - НикНик
Дата добавления - 24.01.2016 в 19:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нахождение и последующее сравнение нужных данных в таблице (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!