Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Создание динамического списка по нескольким условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создание динамического списка по нескольким условиям (Формулы/Formulas)
Создание динамического списка по нескольким условиям
zzbear Дата: Понедельник, 25.01.2016, 17:54 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
Добрый день.

Есть иерархический список уникальных клиентов.

В отчет в зависимости от выбранного условия иерархии (Дивизион), необходимо чтоб в той же последовательности, что и в списке подтягивались наименования (Клиентов) а так-же дополнительное свойство контрагентов (Территория).
К сообщению приложен файл: 9990201.xlsx(11Kb)
 
Ответить
СообщениеДобрый день.

Есть иерархический список уникальных клиентов.

В отчет в зависимости от выбранного условия иерархии (Дивизион), необходимо чтоб в той же последовательности, что и в списке подтягивались наименования (Клиентов) а так-же дополнительное свойство контрагентов (Территория).

Автор - zzbear
Дата добавления - 25.01.2016 в 17:54
Pelena Дата: Понедельник, 25.01.2016, 18:22 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11038
Репутация: 2463 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Формула массива вводится сочетанием клавиш Ctrl+Shift+Enter
Код
=ЕСЛИОШИБКА(ИНДЕКС('Список клиентов'!$B$2:$B$31;НАИМЕНЬШИЙ(ЕСЛИ('Список клиентов'!$A$2:$A$31=$A$1;СТРОКА('Список клиентов'!$A$2:$A$31)-1);СТОЛБЕЦ(A1)));"")
К сообщению приложен файл: 2913195.xlsx(12Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Формула массива вводится сочетанием клавиш Ctrl+Shift+Enter
Код
=ЕСЛИОШИБКА(ИНДЕКС('Список клиентов'!$B$2:$B$31;НАИМЕНЬШИЙ(ЕСЛИ('Список клиентов'!$A$2:$A$31=$A$1;СТРОКА('Список клиентов'!$A$2:$A$31)-1);СТОЛБЕЦ(A1)));"")

Автор - Pelena
Дата добавления - 25.01.2016 в 18:22
zzbear Дата: Понедельник, 25.01.2016, 18:28 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
Спасибо.
Сейчас буду пробовать.
 
Ответить
СообщениеСпасибо.
Сейчас буду пробовать.

Автор - zzbear
Дата добавления - 25.01.2016 в 18:28
krosav4ig Дата: Понедельник, 25.01.2016, 18:29 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1465
Репутация: 596 ±
Замечаний: 0% ±

Excel 2007, 2013
вариант с доп. столбцом и сводной
К сообщению приложен файл: 8187620.xlsx(18Kb)


(_)Õvõ(_)
 
Ответить
Сообщениевариант с доп. столбцом и сводной

Автор - krosav4ig
Дата добавления - 25.01.2016 в 18:29
_Boroda_ Дата: Понедельник, 25.01.2016, 18:41 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Немассивная формула
Код
=ЕСЛИОШИБКА(ИНДЕКС(ИНДЕКС('Список клиентов'!$B2:$B31;ПОИСКПОЗ($A1;'Список клиентов'!$A2:$A31;)):ИНДЕКС('Список клиентов'!$B2:$B31;ПОИСКПОЗ($A1;'Список клиентов'!$A2:$A31;)+СЧЁТЕСЛИ('Список клиентов'!$A2:$A31;$A1)-1);СТОЛБЕЦ(A1));"")
К сообщению приложен файл: 9990201_1.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНемассивная формула
Код
=ЕСЛИОШИБКА(ИНДЕКС(ИНДЕКС('Список клиентов'!$B2:$B31;ПОИСКПОЗ($A1;'Список клиентов'!$A2:$A31;)):ИНДЕКС('Список клиентов'!$B2:$B31;ПОИСКПОЗ($A1;'Список клиентов'!$A2:$A31;)+СЧЁТЕСЛИ('Список клиентов'!$A2:$A31;$A1)-1);СТОЛБЕЦ(A1));"")

Автор - _Boroda_
Дата добавления - 25.01.2016 в 18:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Создание динамического списка по нескольким условиям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!