Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматически расширяемый диапазон для расчета СРЗНАЧ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматически расширяемый диапазон для расчета СРЗНАЧ (Формулы/Formulas)
Автоматически расширяемый диапазон для расчета СРЗНАЧ
rido Дата: Вторник, 26.01.2016, 08:42 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день)
Прошу помочь с решением проблемы:

В файле-вложении столбец А содержит данные. Столбец В - расчет средне-арифметического значения n-го количества значений столбца А (включая значение текущей строки). Ячейка Е1 - число n (количество членов для формулы СРЗНАЧ).

Задача состоит в том, чтобы при изменении значения ячейки Е1 автоматически расширялся диапазон расчета СРЗНАЧ в столбце В по каждой строке.

Пример для ячейки В11:
При значении Е1 = 3; В11 = 7;
При значении Е1 = 5; В11 = 6;
При значении Е1 = 8; В11 = 4,75
К сообщению приложен файл: ___.xlsx(9Kb)
 
Ответить
СообщениеДобрый день)
Прошу помочь с решением проблемы:

В файле-вложении столбец А содержит данные. Столбец В - расчет средне-арифметического значения n-го количества значений столбца А (включая значение текущей строки). Ячейка Е1 - число n (количество членов для формулы СРЗНАЧ).

Задача состоит в том, чтобы при изменении значения ячейки Е1 автоматически расширялся диапазон расчета СРЗНАЧ в столбце В по каждой строке.

Пример для ячейки В11:
При значении Е1 = 3; В11 = 7;
При значении Е1 = 5; В11 = 6;
При значении Е1 = 8; В11 = 4,75

Автор - rido
Дата добавления - 26.01.2016 в 08:42
Nic70y Дата: Вторник, 26.01.2016, 09:18 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3661
Репутация: 759 ±
Замечаний: 0% ±

Excel 2013
так нужно?
Код
=СРЗНАЧ(ИНДЕКС(A$2:A2;СТРОКА(C1)):ИНДЕКС(A$2:A2;ЕСЛИ(E$1>СТРОКА(C1);0;СТРОКА(C1)-E$1+1)))
начиная с B2, так правильнее
Код
=СРЗНАЧ(ИНДЕКС(A$2:A2;СТРОКА(C1)):ИНДЕКС(A$2:A2;ЕСЛИ(E$1>СТРОКА(C1);0;СТРОКА(C1)-E$1)+1))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Вторник, 26.01.2016, 09:23
 
Ответить
Сообщениетак нужно?
Код
=СРЗНАЧ(ИНДЕКС(A$2:A2;СТРОКА(C1)):ИНДЕКС(A$2:A2;ЕСЛИ(E$1>СТРОКА(C1);0;СТРОКА(C1)-E$1+1)))
начиная с B2, так правильнее
Код
=СРЗНАЧ(ИНДЕКС(A$2:A2;СТРОКА(C1)):ИНДЕКС(A$2:A2;ЕСЛИ(E$1>СТРОКА(C1);0;СТРОКА(C1)-E$1)+1))

Автор - Nic70y
Дата добавления - 26.01.2016 в 09:18
Pelena Дата: Вторник, 26.01.2016, 09:48 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 10401
Репутация: 2355 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Или так ещё можно для В2
Код
=ЕСЛИ(СЧЁТ($A$2:A2)<$E$1;"";СРЗНАЧ(СМЕЩ(A2;;;-$E$1)))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИли так ещё можно для В2
Код
=ЕСЛИ(СЧЁТ($A$2:A2)<$E$1;"";СРЗНАЧ(СМЕЩ(A2;;;-$E$1)))

Автор - Pelena
Дата добавления - 26.01.2016 в 09:48
_Boroda_ Дата: Вторник, 26.01.2016, 11:04 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9818
Репутация: 4147 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Может, вот так еще пойдет
Код
=СРЗНАЧ(A2:ИНДЕКС(A:A;МАКС(2;СТРОКА()-E$1+1)))

Делает среднее по тому количеству, которое есть
К сообщению приложен файл: -3-1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожет, вот так еще пойдет
Код
=СРЗНАЧ(A2:ИНДЕКС(A:A;МАКС(2;СТРОКА()-E$1+1)))

Делает среднее по тому количеству, которое есть

Автор - _Boroda_
Дата добавления - 26.01.2016 в 11:04
rido Дата: Вторник, 26.01.2016, 11:48 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем ОГРОМНОЕ спасибо) Задача решена
 
Ответить
СообщениеВсем ОГРОМНОЕ спасибо) Задача решена

Автор - rido
Дата добавления - 26.01.2016 в 11:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматически расширяемый диапазон для расчета СРЗНАЧ (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!