Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт ячеек COUNTIF с условием AND - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт ячеек COUNTIF с условием AND (Формулы/Formulas)
Подсчёт ячеек COUNTIF с условием AND
hiderline Дата: Среда, 27.01.2016, 11:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Имеется скажем 2 столбца A1:A100 и B1:B100, в каждую ячейку которого сносится статусное состояние, пусть будет "ok".
Нужно подсчитать количество пар (A1;B1), (A2;B2),...,(A100;B100), в которых обе ячейки имеют статус "ok". (Прим. Статус будет иметь текстовый формат).
То есть грубо говоря, ниже приведённый код.
[vba]
Код
int A[100], B[100];
int count =0;
for (int i=0: i<100; i++)
{
if (A[i]=B[i])
count++;
}
[/vba]
 
Ответить
СообщениеИмеется скажем 2 столбца A1:A100 и B1:B100, в каждую ячейку которого сносится статусное состояние, пусть будет "ok".
Нужно подсчитать количество пар (A1;B1), (A2;B2),...,(A100;B100), в которых обе ячейки имеют статус "ok". (Прим. Статус будет иметь текстовый формат).
То есть грубо говоря, ниже приведённый код.
[vba]
Код
int A[100], B[100];
int count =0;
for (int i=0: i<100; i++)
{
if (A[i]=B[i])
count++;
}
[/vba]

Автор - hiderline
Дата добавления - 27.01.2016 в 11:02
YouGreed Дата: Среда, 27.01.2016, 11:16 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
hiderline, пример, пожалуйста...
На вскидку.
Код
=ЕСЛИ($H2=$I2;...)


Сообщение отредактировал YouGreed - Среда, 27.01.2016, 11:20
 
Ответить
Сообщениеhiderline, пример, пожалуйста...
На вскидку.
Код
=ЕСЛИ($H2=$I2;...)

Автор - YouGreed
Дата добавления - 27.01.2016 в 11:16
Manyasha Дата: Среда, 27.01.2016, 11:18 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1989
Репутация: 819 ±
Замечаний: 0% ±

Excel 2010, 2016
так?
Код
=СУММПРОИЗВ(--(A1:A100=B1:B100))


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениетак?
Код
=СУММПРОИЗВ(--(A1:A100=B1:B100))

Автор - Manyasha
Дата добавления - 27.01.2016 в 11:18
hiderline Дата: Среда, 27.01.2016, 12:52 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Приложил пример.
В идеале статусов может быть в количестве N, причём статус N не имеет смысла или даже не может быть установлен до тех пор, пока предыдущие так же не будут выполнены.
Но в силу того, что каждый статус будет заполняться разными людьми и в разных местах, было неплохо добавить блокировку на установление статуса, если предыдущий не выполнен.
Для подсчёта результирующего, необходимо, чтобы все статусы от в одной строке были выполнены, только в этом случае счётчик делает инкремент.

Надеюсь, что доходчиво объяснил.
К сообщению приложен файл: Question.xlsx(11Kb)
 
Ответить
СообщениеПриложил пример.
В идеале статусов может быть в количестве N, причём статус N не имеет смысла или даже не может быть установлен до тех пор, пока предыдущие так же не будут выполнены.
Но в силу того, что каждый статус будет заполняться разными людьми и в разных местах, было неплохо добавить блокировку на установление статуса, если предыдущий не выполнен.
Для подсчёта результирующего, необходимо, чтобы все статусы от в одной строке были выполнены, только в этом случае счётчик делает инкремент.

Надеюсь, что доходчиво объяснил.

Автор - hiderline
Дата добавления - 27.01.2016 в 12:52
YouGreed Дата: Среда, 27.01.2016, 13:00 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
hiderline,
Код
=ЕСЛИ(СУММПРОИЗВ(--($A6:$C6=$A$6))<3;"";"ok")
К сообщению приложен файл: 0365444.xlsx(11Kb)
 
Ответить
Сообщениеhiderline,
Код
=ЕСЛИ(СУММПРОИЗВ(--($A6:$C6=$A$6))<3;"";"ok")

Автор - YouGreed
Дата добавления - 27.01.2016 в 13:00
hiderline Дата: Среда, 27.01.2016, 13:35 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Уже похоже на правду, но вы сделали сначала подсчёт результатов в жёлтом столбце, который называется "ИТОГ",
но в идеале такового столбца не будет. Нужна просто ячейка с формулой, которая будет выполнять все выше приведённые действия.
Можно ли добавить формулой все действия, которые выполняются для ячеек "ИТОГ" в ячейку "TOTAL"?
 
Ответить
СообщениеУже похоже на правду, но вы сделали сначала подсчёт результатов в жёлтом столбце, который называется "ИТОГ",
но в идеале такового столбца не будет. Нужна просто ячейка с формулой, которая будет выполнять все выше приведённые действия.
Можно ли добавить формулой все действия, которые выполняются для ячеек "ИТОГ" в ячейку "TOTAL"?

Автор - hiderline
Дата добавления - 27.01.2016 в 13:35
_Boroda_ Дата: Среда, 27.01.2016, 13:51 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11501
Репутация: 4735 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
было неплохо добавить блокировку на установление статуса, если предыдущий не выполнен

Смотрите в файле. Сделано Данные - Проверка данных. Имя см. в списке имен (Контрл F3)
тогда в желтом итоговом столбце просто вот так
Код
=C6&""
К сообщению приложен файл: Question-1-1.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
было неплохо добавить блокировку на установление статуса, если предыдущий не выполнен

Смотрите в файле. Сделано Данные - Проверка данных. Имя см. в списке имен (Контрл F3)
тогда в желтом итоговом столбце просто вот так
Код
=C6&""

Автор - _Boroda_
Дата добавления - 27.01.2016 в 13:51
YouGreed Дата: Среда, 27.01.2016, 14:04 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
hiderline,
Код
=СУММПРОИЗВ(--($A$6:$A$16=$A$6)*--($B$6:$B$16=$A$6)*--($C$6:$C$16=$A$6))& "/11"

Код
=СУММПРОИЗВ(--($A$6:$A$16=$A$6)*--($B$6:$B$16=$A$6)*--($C$6:$C$16=$A$6))/11
К сообщению приложен файл: 5950535.xlsx(11Kb)
 
Ответить
Сообщениеhiderline,
Код
=СУММПРОИЗВ(--($A$6:$A$16=$A$6)*--($B$6:$B$16=$A$6)*--($C$6:$C$16=$A$6))& "/11"

Код
=СУММПРОИЗВ(--($A$6:$A$16=$A$6)*--($B$6:$B$16=$A$6)*--($C$6:$C$16=$A$6))/11

Автор - YouGreed
Дата добавления - 27.01.2016 в 14:04
Manyasha Дата: Среда, 27.01.2016, 14:06 | Сообщение № 9
Группа: Модераторы
Ранг: Старожил
Сообщений: 1989
Репутация: 819 ±
Замечаний: 0% ±

Excel 2010, 2016
_Boroda_, а зачем Если в имени ok_1?
Код
=ЕСЛИ(Sheet1!A6="ok";Sheet1!A6;"")

Можно же и так
Код
=Sheet1!A6
К сообщению приложен файл: Question-1-1-1.xlsx(12Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщение_Boroda_, а зачем Если в имени ok_1?
Код
=ЕСЛИ(Sheet1!A6="ok";Sheet1!A6;"")

Можно же и так
Код
=Sheet1!A6

Автор - Manyasha
Дата добавления - 27.01.2016 в 14:06
_Boroda_ Дата: Среда, 27.01.2016, 14:43 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11501
Репутация: 4735 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно же и так

Теоретически да, а вот практически - не совсем. Введи в любую пустую ячейку "Не ОК", скопируй и вставь в столбец А, например. Проверка данных разрешает вставку и ругаться не будет.
Кстати, в желтом тогда лучше
Код
=ЕСЛИ(C6="ok";"ok";"")
К сообщению приложен файл: Question-1-2.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Можно же и так

Теоретически да, а вот практически - не совсем. Введи в любую пустую ячейку "Не ОК", скопируй и вставь в столбец А, например. Проверка данных разрешает вставку и ругаться не будет.
Кстати, в желтом тогда лучше
Код
=ЕСЛИ(C6="ok";"ok";"")

Автор - _Boroda_
Дата добавления - 27.01.2016 в 14:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт ячеек COUNTIF с условием AND (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!