Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение двух и более столбцов и выведение результата - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух и более столбцов и выведение результата (Формулы/Formulas)
Сравнение двух и более столбцов и выведение результата
dogma Дата: Четверг, 28.01.2016, 08:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

pro2010
Добрый день коллеги!

Нужна помощь. Есть две вкладки с данными, необходимо сравнить три столбца и выдать результат (СПП-элемент) в другую вкладку. Что-то типа функции ВПР но только сравнивать не один столбец а три.
К сообщению приложен файл: _1.xlsx(38Kb)
 
Ответить
СообщениеДобрый день коллеги!

Нужна помощь. Есть две вкладки с данными, необходимо сравнить три столбца и выдать результат (СПП-элемент) в другую вкладку. Что-то типа функции ВПР но только сравнивать не один столбец а три.

Автор - dogma
Дата добавления - 28.01.2016 в 08:40
ReAnima Дата: Четверг, 28.01.2016, 09:03 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 8 ±
Замечаний: 20% ±

Excel 2013
Если верно понял:

Код
=ЕСЛИОШИБКА(ИНДЕКС('6297П_Р'!J2:J259;ПОИСКПОЗ(B5&C5&E5;'6297П_Р'!$H$2:$H$259&'6297П_Р'!$I$2:$I$259&'6297П_Р'!$K$2:$K$259;0));"")


Формула массива
 
Ответить
СообщениеЕсли верно понял:

Код
=ЕСЛИОШИБКА(ИНДЕКС('6297П_Р'!J2:J259;ПОИСКПОЗ(B5&C5&E5;'6297П_Р'!$H$2:$H$259&'6297П_Р'!$I$2:$I$259&'6297П_Р'!$K$2:$K$259;0));"")


Формула массива

Автор - ReAnima
Дата добавления - 28.01.2016 в 09:03
YouGreed Дата: Четверг, 28.01.2016, 09:10 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
dogma, Так?
Код
=ИНДЕКС('6297П_Р'!$J$2:$J$259;ПОИСКПОЗ(Реестр!$B5&Реестр!$C5;'6297П_Р'!$H$2:$H$259&'6297П_Р'!$I$2:$I$259;);)

Формула массива вводится одновременным нажатием клавиш Ctrl+Shift+Enter
К сообщению приложен файл: 9670319.xlsx(39Kb)
 
Ответить
Сообщениеdogma, Так?
Код
=ИНДЕКС('6297П_Р'!$J$2:$J$259;ПОИСКПОЗ(Реестр!$B5&Реестр!$C5;'6297П_Р'!$H$2:$H$259&'6297П_Р'!$I$2:$I$259;);)

Формула массива вводится одновременным нажатием клавиш Ctrl+Shift+Enter

Автор - YouGreed
Дата добавления - 28.01.2016 в 09:10
dogma Дата: Четверг, 28.01.2016, 09:17 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

pro2010
Да, так, спасибо большое очень выручили
 
Ответить
СообщениеДа, так, спасибо большое очень выручили

Автор - dogma
Дата добавления - 28.01.2016 в 09:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух и более столбцов и выведение результата (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!