Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Замена и удаление ненужных слов в таблице иксель - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Замена и удаление ненужных слов в таблице иксель (Формулы/Formulas)
Замена и удаление ненужных слов в таблице иксель
toolsup1 Дата: Вторник, 02.02.2016, 11:18 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Помогите, пожалуйста, справиться с заданием, которое напишу ниже и также оно продублировано в самой табличке. Сломала всю голову :'(
Заранее большое спасибо форумчане!

Задание:
1. Необходимо заполнить третий столбец на листе "Таблица" русским переводом, критерии для заполнения следующие:
- Все опции, в английском названии которых содержится "Manual", необходимо присвоить русское название "Сервисная документация"
- Все опции, в английском названии которых содержится "Transducer", необходимо присвоить русское название "Ультразвуковой датчик"
- Все опции, в английском названии которых содержится "Option", необходимо присвоить русское название "Программное обеспечение"
2. Оставшиеся позиции необходимо пометить прочерком и выделить желтой заливкой ячейки
3. Позициям, английские названия которых "NO"или "Yes", необходимо добавить комментарий "Перевод не требуется"
К сообщению приложен файл: Excel_task111.xlsx(17Kb)
 
Ответить
СообщениеПомогите, пожалуйста, справиться с заданием, которое напишу ниже и также оно продублировано в самой табличке. Сломала всю голову :'(
Заранее большое спасибо форумчане!

Задание:
1. Необходимо заполнить третий столбец на листе "Таблица" русским переводом, критерии для заполнения следующие:
- Все опции, в английском названии которых содержится "Manual", необходимо присвоить русское название "Сервисная документация"
- Все опции, в английском названии которых содержится "Transducer", необходимо присвоить русское название "Ультразвуковой датчик"
- Все опции, в английском названии которых содержится "Option", необходимо присвоить русское название "Программное обеспечение"
2. Оставшиеся позиции необходимо пометить прочерком и выделить желтой заливкой ячейки
3. Позициям, английские названия которых "NO"или "Yes", необходимо добавить комментарий "Перевод не требуется"

Автор - toolsup1
Дата добавления - 02.02.2016 в 11:18
Pelena Дата: Вторник, 02.02.2016, 11:30 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 10414
Репутация: 2358 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/ПОИСК($F$2:$F$6;B2);$G$2:$G$6);"-")
К сообщению приложен файл: 9559047.xlsx(19Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/ПОИСК($F$2:$F$6;B2);$G$2:$G$6);"-")

Автор - Pelena
Дата добавления - 02.02.2016 в 11:30
buchlotnik Дата: Вторник, 02.02.2016, 11:43 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2203
Репутация: 659 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
почти как у Елены
Код
=ПРОСМОТР(;-1/ПОИСК($E$2:$E$7;B2);$F$2:$F$7)
К сообщению приложен файл: _Excel_task111.xlsx(19Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениепочти как у Елены
Код
=ПРОСМОТР(;-1/ПОИСК($E$2:$E$7;B2);$F$2:$F$7)

Автор - buchlotnik
Дата добавления - 02.02.2016 в 11:43
_Boroda_ Дата: Вторник, 02.02.2016, 11:43 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9827
Репутация: 4148 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Или так?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(" "&F$3:F$7&" ";" "&B2&" ");G$3:G$7);"-")

Проверьте по вот таким значениям
Panoramic Imaging
3D9-3v Broadband Curved Array transducer no


Вернее, вот так (файл _2)
Код
=ПРОСМОТР(;-ПОИСК(" "&F$2:F$7&" ";" "&B2&" ");G$2:G$7)
и немного дополнить таблицу соответствия
Если без таблицы, то вот так
Код
=ПРОСМОТР(;-ПОИСК(" "&{"*":"NO":"Yes":"Option":"Manual":"Transducer"}&" ";" "&B3&" ");{"-":"Перевод не требуется":"Перевод не требуется":"Программное обеспечение":"Сервисная документация":"Ультразвуковой датчик"})
К сообщению приложен файл: Excel_task111_1.xlsx(20Kb) · Excel_task111_2.xlsx(20Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИли так?
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК(" "&F$3:F$7&" ";" "&B2&" ");G$3:G$7);"-")

Проверьте по вот таким значениям
Panoramic Imaging
3D9-3v Broadband Curved Array transducer no


Вернее, вот так (файл _2)
Код
=ПРОСМОТР(;-ПОИСК(" "&F$2:F$7&" ";" "&B2&" ");G$2:G$7)
и немного дополнить таблицу соответствия
Если без таблицы, то вот так
Код
=ПРОСМОТР(;-ПОИСК(" "&{"*":"NO":"Yes":"Option":"Manual":"Transducer"}&" ";" "&B3&" ");{"-":"Перевод не требуется":"Перевод не требуется":"Программное обеспечение":"Сервисная документация":"Ультразвуковой датчик"})

Автор - _Boroda_
Дата добавления - 02.02.2016 в 11:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Замена и удаление ненужных слов в таблице иксель (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!