Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сцепить все ячейки таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сцепить все ячейки таблицы (Формулы/Formulas)
Сцепить все ячейки таблицы
NightHawk Дата: Вторник, 02.02.2016, 22:42 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!

Есть таблица, два столбца
A
часы
наручные часы
B
Москва
СПБ

Как сцепить так, чтобы каждый A сцепился с B? т.е. перебор A1 с B1, A2 с B1. Перебрались все A с B1 далее A1 с B2 и т.д.

Т.е. в результате получится
C
часы москва
наручные часы москва
часы спб
наручные часы спб

Подскажите в каком направлении можно копать? Может уже есть решения, поиск мне не помог.
 
Ответить
СообщениеЗдравствуйте!

Есть таблица, два столбца
A
часы
наручные часы
B
Москва
СПБ

Как сцепить так, чтобы каждый A сцепился с B? т.е. перебор A1 с B1, A2 с B1. Перебрались все A с B1 далее A1 с B2 и т.д.

Т.е. в результате получится
C
часы москва
наручные часы москва
часы спб
наручные часы спб

Подскажите в каком направлении можно копать? Может уже есть решения, поиск мне не помог.

Автор - NightHawk
Дата добавления - 02.02.2016 в 22:42
SLAVICK Дата: Вторник, 02.02.2016, 23:03 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1922
Репутация: 650 ±
Замечаний: 0% ±

2007,2010,2013,2016
? Может уже есть решения, поиск мне не помог

есть и не один раз. Например:
здесь, здесь, здесь.
И еще много раз. Если ничего не подошло - давайте пример будем смотреть.


Иногда все проще чем кажется с первого взгляда.
 
Ответить
Сообщение
? Может уже есть решения, поиск мне не помог

есть и не один раз. Например:
здесь, здесь, здесь.
И еще много раз. Если ничего не подошло - давайте пример будем смотреть.

Автор - SLAVICK
Дата добавления - 02.02.2016 в 23:03
gling Дата: Вторник, 02.02.2016, 23:16 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1392
Репутация: 341 ±
Замечаний: 0% ±

2010
Здравствуйте. Попробуйте формулу.
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$3;ЦЕЛОЕ(СТРОКА(A2)/2))&" "&ИНДЕКС($B$2:$B$3;СТРОКА(A1)-ЦЕЛОЕ((СТРОКА(A1)-1)/2)*2);"")
 
Ответить
СообщениеЗдравствуйте. Попробуйте формулу.
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$3;ЦЕЛОЕ(СТРОКА(A2)/2))&" "&ИНДЕКС($B$2:$B$3;СТРОКА(A1)-ЦЕЛОЕ((СТРОКА(A1)-1)/2)*2);"")

Автор - gling
Дата добавления - 02.02.2016 в 23:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сцепить все ячейки таблицы (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!