Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как подсчитать количество символов в ячейке? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как подсчитать количество символов в ячейке? (Формулы/Formulas)
Как подсчитать количество символов в ячейке?
Tina90 Дата: Среда, 03.02.2016, 22:25 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: -16 ±
Замечаний: 60% ±

Excel 2013
Здравствуйте! Какой формулой можно подсчитать количество символов в ячейке, первый символ которой решетка #???
 
Ответить
СообщениеЗдравствуйте! Какой формулой можно подсчитать количество символов в ячейке, первый символ которой решетка #???

Автор - Tina90
Дата добавления - 03.02.2016 в 22:25
_Boroda_ Дата: Среда, 03.02.2016, 22:28 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
ДЛСТР
Код
=ДЛСТР(A1)
К сообщению приложен файл: 19871169.xlsx(8Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДЛСТР
Код
=ДЛСТР(A1)

Автор - _Boroda_
Дата добавления - 03.02.2016 в 22:28
Tina90 Дата: Среда, 03.02.2016, 22:40 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: -16 ±
Замечаний: 60% ±

Excel 2013
Нет, функцию ДЛСТР я знаю, она не подходит.((( Она будет считать только если перед решеткой будет цифра или буква или еще что....
К сообщению приложен файл: 8094357.xlsx(8Kb)


Сообщение отредактировал Tina90 - Среда, 03.02.2016, 22:42
 
Ответить
СообщениеНет, функцию ДЛСТР я знаю, она не подходит.((( Она будет считать только если перед решеткой будет цифра или буква или еще что....

Автор - Tina90
Дата добавления - 03.02.2016 в 22:40
_Boroda_ Дата: Среда, 03.02.2016, 22:45 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вот поэтому и нужно всегда прикладывать пример. У Вас там не текст, а значение ошибки, а это совсем другое дело.
Если Вы объясните, зачем Вам это нужно, то, весьма вероятно, мы подскажем Вам немного другой способ решения Вашей проблемы.
Кстати -
Она будет считать только если перед решеткой будет цифра или буква или еще что

ничего подобного. Посмотрите мой файл из сообщения выше.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВот поэтому и нужно всегда прикладывать пример. У Вас там не текст, а значение ошибки, а это совсем другое дело.
Если Вы объясните, зачем Вам это нужно, то, весьма вероятно, мы подскажем Вам немного другой способ решения Вашей проблемы.
Кстати -
Она будет считать только если перед решеткой будет цифра или буква или еще что

ничего подобного. Посмотрите мой файл из сообщения выше.

Автор - _Boroda_
Дата добавления - 03.02.2016 в 22:45
Tina90 Дата: Среда, 03.02.2016, 22:54 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: -16 ±
Замечаний: 60% ±

Excel 2013
Спасибо, я посмотрела Ваш файл, там наверное какая то другая решетка! У меня много ячеек, где возникают #ЗНАЧ! время от времени. Избавляться от ошибок я не хочу, это слишком нудно, но если количество симвлов в ячейке будет меньше 7 тогда я смогу исключить такие ячейки из цепочки вычислений! Потому что не ошибочные значения всегда больше 20 символов!
ЗЫ функция ДЛСТР должна считать символы (цифры,буквы,знаки препинания и так далее)! В том числе и любые решетки и любые звездочки????


Сообщение отредактировал Tina90 - Среда, 03.02.2016, 23:02
 
Ответить
СообщениеСпасибо, я посмотрела Ваш файл, там наверное какая то другая решетка! У меня много ячеек, где возникают #ЗНАЧ! время от времени. Избавляться от ошибок я не хочу, это слишком нудно, но если количество симвлов в ячейке будет меньше 7 тогда я смогу исключить такие ячейки из цепочки вычислений! Потому что не ошибочные значения всегда больше 20 символов!
ЗЫ функция ДЛСТР должна считать символы (цифры,буквы,знаки препинания и так далее)! В том числе и любые решетки и любые звездочки????

Автор - Tina90
Дата добавления - 03.02.2016 в 22:54
buchlotnik Дата: Среда, 03.02.2016, 23:02 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3117
Репутация: 853 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так может проще
Код
=ЕСЛИОШИБКА(A1;"")
или
Код
=ЕСЛИОШИБКА(A1;0)

[offtop]
Цитата
какая то другая решетка!
улыбнуло B)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Среда, 03.02.2016, 23:02
 
Ответить
Сообщениетак может проще
Код
=ЕСЛИОШИБКА(A1;"")
или
Код
=ЕСЛИОШИБКА(A1;0)

[offtop]
Цитата
какая то другая решетка!
улыбнуло B)

Автор - buchlotnik
Дата добавления - 03.02.2016 в 23:02
_Boroda_ Дата: Среда, 03.02.2016, 23:04 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
там наверное какая то другая решетка

hands
Поверьте мне, решетки одинаковые. Смотрите файл.
А исключить такие вещи можно функцией
Код
=ЕОШИБКА(A1)

Или сразу в свою начальную формулу напишите вот так
Код
=ЕСЛИОШИБКА(Ваша_формула;"")

Тогда вместо таких значений будет выдавать пусто
функция ДЛСТР должна считать символы (цифры,буквы,знаки препинания и так далее)! В том числе и любые решетки и любые звездочки????
Совершенно верно. НО!!! Это не относится к значениям ошибки
(#Н/Д, #ЗНАЧ!, #ССЫЛ!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? или #ПУСТО!)
К сообщению приложен файл: 8094357_1.xlsx(8Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
там наверное какая то другая решетка

hands
Поверьте мне, решетки одинаковые. Смотрите файл.
А исключить такие вещи можно функцией
Код
=ЕОШИБКА(A1)

Или сразу в свою начальную формулу напишите вот так
Код
=ЕСЛИОШИБКА(Ваша_формула;"")

Тогда вместо таких значений будет выдавать пусто
функция ДЛСТР должна считать символы (цифры,буквы,знаки препинания и так далее)! В том числе и любые решетки и любые звездочки????
Совершенно верно. НО!!! Это не относится к значениям ошибки
(#Н/Д, #ЗНАЧ!, #ССЫЛ!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? или #ПУСТО!)

Автор - _Boroda_
Дата добавления - 03.02.2016 в 23:04
Tina90 Дата: Среда, 03.02.2016, 23:05 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: -16 ±
Замечаний: 60% ±

Excel 2013
так может проще

Да!!! Так получается, спасибо! Но тема решеток все равно не раскрыта! )))
 
Ответить
Сообщение
так может проще

Да!!! Так получается, спасибо! Но тема решеток все равно не раскрыта! )))

Автор - Tina90
Дата добавления - 03.02.2016 в 23:05
Tina90 Дата: Среда, 03.02.2016, 23:07 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: -16 ±
Замечаний: 60% ±

Excel 2013
НО!!! Это не относится к значениям ошибки

А почему?? Неужели #ЗНАЧ! не состоит из символов?? Тогда из чего же? Из оливье, фуагра???)))
 
Ответить
Сообщение
НО!!! Это не относится к значениям ошибки

А почему?? Неужели #ЗНАЧ! не состоит из символов?? Тогда из чего же? Из оливье, фуагра???)))

Автор - Tina90
Дата добавления - 03.02.2016 в 23:07
_Boroda_ Дата: Среда, 03.02.2016, 23:13 | Сообщение № 10
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Это что-то типа указателя на то, что вычисления неверные. Они как бы зарезервированы Excelем и он не производит с ними стандартные операции для текста. Это просто нужно принять как данность - так Майкрософт установил.

Вода - мокрая, водка - вкусная, а значения ошибки - не текст.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЭто что-то типа указателя на то, что вычисления неверные. Они как бы зарезервированы Excelем и он не производит с ними стандартные операции для текста. Это просто нужно принять как данность - так Майкрософт установил.

Вода - мокрая, водка - вкусная, а значения ошибки - не текст.

Автор - _Boroda_
Дата добавления - 03.02.2016 в 23:13
Tina90 Дата: Среда, 03.02.2016, 23:23 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: -16 ±
Замечаний: 60% ±

Excel 2013
Понятно. Какой злобный этот эксель!! )))
 
Ответить
СообщениеПонятно. Какой злобный этот эксель!! )))

Автор - Tina90
Дата добавления - 03.02.2016 в 23:23
Nic70y Дата: Четверг, 04.02.2016, 07:22 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4121
Репутация: 881 ±
Замечаний: 0% ±

Excel 2013
для новых версий на русском
Код
=ЕСЛИОШИБКА(ДЛСТР(A1);ИНДЕКС({7:8:6:8:5:7:4:16};ТИП.ОШИБКИ(A1)))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Четверг, 04.02.2016, 07:24
 
Ответить
Сообщениедля новых версий на русском
Код
=ЕСЛИОШИБКА(ДЛСТР(A1);ИНДЕКС({7:8:6:8:5:7:4:16};ТИП.ОШИБКИ(A1)))

Автор - Nic70y
Дата добавления - 04.02.2016 в 07:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как подсчитать количество символов в ячейке? (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!