Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Изменение чисел в ячейках с текстом - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Изменение чисел в ячейках с текстом (Формулы/Formulas)
Изменение чисел в ячейках с текстом
Inna2016 Дата: Пятница, 05.02.2016, 22:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день!
Подскажите, пожалуйста, как отредактировать следующие строки в файле (приложен):

Есть массив с данными (я оставила только кусок, там более 20000 строк).

- Массово изменить в строках со словом ОЖИДАНИЕ число после двоеточия и присвоить рандомное от 1 до 99, в каждой строке - своё.
- В строках Соотношение нужно прибавить цифру 1 к числам (как пример - к 462 и 399, чтобы стало 463 и 400).
Соотношение : 462 : 399 : Стоимость : 0 : 0 : 0

Пробовала через сортировку по алфавиту и постановки функции СЛУЧМЕЖДУ(1;99) и подстановки +1 к числам после разбивки столбцов.
Есть ли способ проще?

Буду очень признательна за помощь!
К сообщению приложен файл: 02369.xlsx(11Kb)
 
Ответить
СообщениеДобрый день!
Подскажите, пожалуйста, как отредактировать следующие строки в файле (приложен):

Есть массив с данными (я оставила только кусок, там более 20000 строк).

- Массово изменить в строках со словом ОЖИДАНИЕ число после двоеточия и присвоить рандомное от 1 до 99, в каждой строке - своё.
- В строках Соотношение нужно прибавить цифру 1 к числам (как пример - к 462 и 399, чтобы стало 463 и 400).
Соотношение : 462 : 399 : Стоимость : 0 : 0 : 0

Пробовала через сортировку по алфавиту и постановки функции СЛУЧМЕЖДУ(1;99) и подстановки +1 к числам после разбивки столбцов.
Есть ли способ проще?

Буду очень признательна за помощь!

Автор - Inna2016
Дата добавления - 05.02.2016 в 22:14
_Boroda_ Дата: Пятница, 05.02.2016, 22:49 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3923 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В соотношениях могут быть только два трезначных числа или любые?
Вот так может быть -
Соотношение : 4 : 3 : Стоимость : 0 : 0 : 0?
В стоимости всегда нули или могут быть любые числа -
Соотношение : 462 : 399 : Стоимость : 64 : 235 : 10?

В общем слечае такой вариант формулы в соседнем столбце -
Код
=ЕСЛИ(ЛЕВБ(A1)="о";ЛЕВБ(A1;11)&СЛУЧМЕЖДУ(1;99);ЛЕВБ(A1;14)&ПСТР(A1;14;ПОИСК(":";A1;15)-15)+1&" : "&ПСТР(A1;ПОИСК(":";A1;15)+2;ПОИСК(" ";ПСТР(A1;ПОИСК(":";A1;15)+2;99)))+1&ПСТР(A1;ПОИСК(" : с";A1);99))
К сообщению приложен файл: 02369_1.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВ соотношениях могут быть только два трезначных числа или любые?
Вот так может быть -
Соотношение : 4 : 3 : Стоимость : 0 : 0 : 0?
В стоимости всегда нули или могут быть любые числа -
Соотношение : 462 : 399 : Стоимость : 64 : 235 : 10?

В общем слечае такой вариант формулы в соседнем столбце -
Код
=ЕСЛИ(ЛЕВБ(A1)="о";ЛЕВБ(A1;11)&СЛУЧМЕЖДУ(1;99);ЛЕВБ(A1;14)&ПСТР(A1;14;ПОИСК(":";A1;15)-15)+1&" : "&ПСТР(A1;ПОИСК(":";A1;15)+2;ПОИСК(" ";ПСТР(A1;ПОИСК(":";A1;15)+2;99)))+1&ПСТР(A1;ПОИСК(" : с";A1);99))

Автор - _Boroda_
Дата добавления - 05.02.2016 в 22:49
Inna2016 Дата: Пятница, 05.02.2016, 23:46 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Огромное Вам спасибо! Это именно то, что нужно!
Только, позвольте уточнить: если понадобится изменить только одно из чисел в Соотношении во всем массиве, то как будет выглядеть формула?

Соотношение : 462 : 399 : Стоимость : 0 : 0 : 0
Соотношение : 462: 402 : Стоимость : 0 : 0 : 0
Поменяется, например, только "второй столбец" чисел (399 и 402).

В стоимости всегда будут нули.
 
Ответить
СообщениеОгромное Вам спасибо! Это именно то, что нужно!
Только, позвольте уточнить: если понадобится изменить только одно из чисел в Соотношении во всем массиве, то как будет выглядеть формула?

Соотношение : 462 : 399 : Стоимость : 0 : 0 : 0
Соотношение : 462: 402 : Стоимость : 0 : 0 : 0
Поменяется, например, только "второй столбец" чисел (399 и 402).

В стоимости всегда будут нули.

Автор - Inna2016
Дата добавления - 05.02.2016 в 23:46
_Boroda_ Дата: Суббота, 06.02.2016, 00:06 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3923 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Первый кусок
Код
ПСТР(A1;14;ПОИСК(":";A1;15)-15)

второй
Код
ПСТР(A1;ПОИСК(":";A1;15)+2;ПОИСК(" ";ПСТР(A1;ПОИСК(":";A1;15)+2;99)))

К каждому прибавляется 1. Если не нужно где-то, то +1 рядом (справа) с соответствующим куском сотрите


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПервый кусок
Код
ПСТР(A1;14;ПОИСК(":";A1;15)-15)

второй
Код
ПСТР(A1;ПОИСК(":";A1;15)+2;ПОИСК(" ";ПСТР(A1;ПОИСК(":";A1;15)+2;99)))

К каждому прибавляется 1. Если не нужно где-то, то +1 рядом (справа) с соответствующим куском сотрите

Автор - _Boroda_
Дата добавления - 06.02.2016 в 00:06
Inna2016 Дата: Суббота, 06.02.2016, 12:15 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Ещё раз благодарю Вас!
Спасибо!
 
Ответить
СообщениеЕщё раз благодарю Вас!
Спасибо!

Автор - Inna2016
Дата добавления - 06.02.2016 в 12:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Изменение чисел в ячейках с текстом (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!